完全 BIOS 手册

This page uses frames, but your browser doesn't support them.


完全BIOS手册—AWARD BIOS设置手册

AWARD BIOS设置手册

    AWARD BIOS是目前兼容机中应用较为广泛的一种BIOS，但是由于里面的信息全为英文且需要用户对于相关专业知识的理解相对深入，所以有些用户设置起来感到困难很大。如果这些有关信息设置不当的话，将会大大影响整台电脑主机的性能。下面介绍一下AWARD BIOS中的有关设置选项的含义和设置方法,AWARD BIOS的主菜单主要有以下几个菜单项：

Standard CMOS Setup(标准CMOS设定)：

在本菜单中，用户可以修改日期、时间、第一主IDE设备(硬盘)和IDE设备(硬盘或CD－ROM)、第二个主IDE设备 (硬盘或CD－ROM)和从IDE设备(硬盘或CD－ROM)、软驱A与B、显示系统的类型、什么出错状态要导致系统启动暂停等。

    说明：

    (1)用户可以在Type(类型)和Mode(模式)项设置 为Auto，使BIOS自动检测硬盘。也可以在主菜单中的IDE HDD Auto Detection操作来设置。用户还可以使用User选 项，手动设定硬盘的参数。您必须输入柱面数(Cyls)，磁 头数 (Heads)，写预补偿(Precomp)，磁头着陆区(Landz) ，每柱面扇区数(Sectorxs)，工作模式(Mode)等几种参数 。硬盘大小在上述参数设定后自动产生。

    (2) 显示类型可选EGA/VGA(EGA、VGA、SEGA、SV GA、PGA显示适配卡选用)、CGA 40(CGA显示卡，40列方式 )、CGA80(CGA显示卡，80列方式)、MONO(单色显示方式， 包括高分辨率单显卡 )等四种，用户应根据情况正确选用 。

    (3) 暂停的出错状态选项有：All Errors(BIOS 检测到任何错误，系统启动均暂停并且给出出错提示)、N o Errors (BIOS检测到任何错误都不使系统启动暂停)、A ll But Keyboard(BIOS检测到除了磁盘之外的错误后使系 统启动暂停，磁盘错误暂停)、All But Disk/Key(BIOS检 测到除了键盘或磁盘之外的错误后使系统启动暂停。

BIOS Features Setup(BIOS功能设定)

    该项用来设置系统配置选项清单，其中有些选项 由主板本身设计确定，有些选项用户可以进行修改设定， 以改善系统的性能。主要说明如下：

    (1) CPU Internal Cache:缺省为Enable(开启) ，它允许系统使用CPU内部的第一级Cache。486、586档次 的CPU内部一般都带有Cache，除非当该项设为开启时系统 工作不正常，此项一般不要轻易改动。该项若置为Disabl e(关闭)，将会降低系统的性能。

    (2) External Cache：缺省设为Enable，它用来 控制主板上的第二级(L2)Cache。根据主板上是否带有Cac he，选择该项的设置。

    (3) Quick Power On Self Test：缺省设置为En able，该项主要功能为加速系统上电自测过程，它将跳过 一些自测试。使引导过程加快。

    (4) Hard Disk Boot From:选择由主盘、从盘或 SCSI硬盘启动。

    (5) Boot Sequence：选择机器开电时的启动顺 序。当机器开电时，有以下四种启动顺序：

    C，A　　　系统将按硬盘，软驱顺序寻找启动盘

    A，C　　　系统将按软驱，硬盘顺序寻找启动盘

    CDROM，C，A　系统按CDROM，硬盘，软驱顺序寻 找启动盘

    C，CDROM，A　系统按硬盘，CDROM，软驱顺序寻 找启动盘

    请注意，某些老式主板并不支持由CD－ROM启动 。

    现在的新主板增加了更多的启动顺序如D，A；LS 120，C；ZIP，C等。

    (6) Swap Floppy Drive:(交换软盘驱动器)缺省 设定为Disable。当它Disable时，BIOS把软驱连线扭接端 子所接的软盘驱动器当作第一驱动器。当它开启时，BIOS 将把软驱连线对接端子所接的软盘驱动器当作第一驱动器 ，即在 DOS下A盘当作B盘用，B盘当作A盘用。

    (7) Boot Up Floppy Seek：当Enable时，机器 启动时BIOS将对软驱进行寻道操作。

    (8) Floppy Disk Access Contol：当该项选在R /W状态时，软驱可以读和写，其它状态只能读。

    (9) Boot Up Numlock Strtus:该选项用来设置 小键盘的缺省状态。当设置为ON时，系统启动后，小键盘 的缺省为数字状态；设为 OFF时，系统启动后，小键盘的 状态为箭头状态。

    (10) Boot Up System Speed：该选项用来确定 系统启动时的速度为 HIGH还是LOW。

    (11)Typematic Rate Setting:该项可选Enable 和 Disable。当置为Enable时，如果按下键盘上的某个键 不放，机器按您重复按下该键对待；当置为 Disable时， 如果按下键盘上的某个键不放，机器按键入该键一次对待 。

    (12) Typematic Rate:如果(11)选项置为Enable ，那么可以用此选项设定当您按下键盘上的某个键一秒钟 ，那么相当于按该键6次。该项可选6、8、10、12、15、2 0、24、30。

    (13) Typematic Delay：如果(11)选项置为Enab le，那么可以用此选项设定按下某一个键时，延迟多长时 间后开始视为重复键入该键。该项可选250、500、750、1 000，单位为毫秒。

    (14) Security Option:选择System时，每次开 机启动时都会提示您输入密码，选择Setup时，仅在进入C MOS Setup时会提示您输入密码。

    (15)PS/2 Mouse Function Control：当该项设 为Enable，机器提供对于PS/2类型鼠标的支持。否则，选 Disable。

    (16) Assign PCI IRQ For VGA:选Enable时，机 器将自动设定PCI显示卡的IRQ到系统的DRAM中，以提高显 示速度和改善系统的性能。

    (17) PCI/VGA Palett Snoop：该项用来设置PCI /VGA卡能否与MPEG ISA/VESA VGA卡一起用。当PCI/VGA卡 与MPEG ISA/VESA VGA卡一起用时，该项应设为Enable,否 则，设为 Disable。

    (18) OS Select For DRAM>64MB：该项允许您在 OS/2操作系统中，使用64M以上的内存。该项可选为NON－ OS2，OS2。

    (19) System BIOS Shadow:该选项的缺省设置默 认为Enable，当它开启时，系统BIOS将拷贝到系统Dram中 ，以提高系统的运行速度和改善系统的性能。

    (20) Video BIOS Shadow:缺省设定为开启(Enab le)，当它开启时，显示卡的BIOS将拷贝到系统DRAM中， 以提高显示速度和改善系统的性能。

    (21) C8000－CBFFF Shadow/DFFFF Shadow:这些 内存区域用来作为其他扩充卡的 ROM映射区，一般都设定 为禁止(Disable)。如果有某一扩充卡ROM需要映射，则用 户应搞清楚该 ROM将映射地址和范围，可以将上述的几个 内存区域都置为 Enable;但这样将造成内存空间的浪费。 因为映射区的地址空间将占用系统的 640K～1024K之间的 某一段内存。

Chipset Features Setup(芯片组功能设定)

该项用来设置系统板上芯片的特性。它有以下选项：

    (1) ISA Bus Clock frequency(PCICLK/4)ISA传 输速率率设定

    设定值有：PCICLK/3；PCICLK/4。

    (2) Auto Configuration(Enabled)自动状态设 定

    当设定为Enabled时BIOS依最佳状况状态设定， 此时BIOS会自动设定DRAM Timing，所以会有无法修改DRA M的细项时序，我们强烈建议选用Enabled，因为任意改变 DRAM的时序可能造成系统不稳或不开机。

    (3) Aggressive Mode(Disabled)高级模式设定

    当您想获得较好的效能时，而且系统在非常稳定 状态下，可以尝试 Enabled此项功能以增加系统效能，不 过必须使用较快速DRAM(60ns以下)。

Power Management Setup(节电功能设定)

    该项为电源管理设定，用来控制主板上的“绿色 ”功能。该功能定时关闭视频显示和硬盘驱动器以实现节 能的效果。

    具体来说，实现节电的模式有四种：

    1、Doze模式　　　　当设定时间一到，CPU时钟 变慢，其他设备照常运作；

    2、Standby模式　　当设定时间一到，硬盘和显 示将停止工作，其他设备照常运作；

    3、Suspend模式　　当设定时间一到，除CPU以 外的所有设备都将停止工作；

    4、HDD Power Down模式　当设定时间一到，硬 盘停止工作，其他设备照常运作。

    该菜单项下面的可供选择的内容有以下几种：

       (1) Power Management节电模式的主控项，有四 种设定：

    Max Saving(最大节电)在一个较短的系统不活动 的周期 (Doze、Standby、Suspend、HDD Power Down四种 模式的缺省值均为1分钟)以后，使系统进入节电模式，这 种模式节电最大。

    MIN Saving(最小节电)在一段较长的系统不活动 的周期在这种情况下， (Doze,Standby,Suspend三种模式 的缺省值均为 1小时，HDD Power Down模式的缺省值为15 分钟 )后，使系统进入节电模式。

    Disable　关闭节电功能，是缺省设置。

    User Defined(用户定义)允许用户根据自己的需 要设定节电的模式。

    (2) Video Off Method(视频关闭)该选项可设为 V/H Sync＋Blank、Dpms、Blank Screen三种。

    V/H Sync＋Blank将关闭显示卡水平与垂直同步 信号的输出端口，向视频缓冲区写入空白信号。

    DPMS(显示电源管理系统)设定允许BIOS在显示卡 有节电功能时，对显示卡进行节能信息的初始化。只有显 示卡支持绿色功能时，用户才能使用这些设定。如果没有 绿色功能，则应将该行设定为Blank Screen(关掉屏幕)。

    Blank Screen(关掉屏幕)当管理关掉显示器屏幕 时，缺省设定能通过关闭显示器的垂直和水平扫描以节约 更多的电能。没有绿色功能的显示器，缺省设定只能关掉 屏幕而不能终止 CRT的扫描。

    (3) PM Timers(电源管理记时器)下面的几项分 别表示对电源管理超时设置的控制。Doze,Stand By和Sus pend Mode项设置分别为该种模式激活前的机器闲置时间 ，在MAX Saving模式，它每次在一分钟后激活。在MIN Sa ving模式，它在一小时后激活。

    (4)Power Down和Resume Events(进入节电模式 和从节电状态中唤醒的事件 )。该项下面所列述的事件可 以将硬盘设在最低耗电模式，工作、等待和悬挂系统等非 活动模式中若有事件发生，如敲任何键或 IRQ唤醒、鼠标 动作、 MODEM振铃时，系统自动从电源节电模式下恢复过 来。

    (5)Soft－Off By Pwr－Bttn:ATX机箱的设计不 同于传统机箱，按下开关4秒以上才能关闭系统；选择ins tant－off方式将使ATX机器等同于传统机器，而若置为de lay 4 sec方式，那么您按住开关的时间不足4秒时将使系 统进入Suspend Mode。

PNP/PCI Configuration Setup(即插即用与PCI状态 设定 )

    该菜单项用来设置即插即用设备和PCI设备的有 关属性。

    (1)PNP OS Installed：如果软件系统支持Plug －Play,如Win 95，可以设置为YES。

    (2)Resources Controlled By：AWARD BIOS支持 “即插即用”功能，可以检测到全部支持“即插即用”的 设备，这种功能是为类似 Win95之类操作系统所设计，可 以设置Auto(自动)或Manual(手动)。

    (3) Resources Configuration Data：缺省值是 Disabled，如果选择Enabled，每次开机时，Extend Syst em Configuration Data(扩展系统设置数据)都会重新设 置。

    (4)IRQ3/4/5/7/9/10/11/12/14/15， Assingned To：在缺省状态下，所有的资源除了IRQ3/4，都设计为 被PCI设备占用，如果某些ISA卡要占用某资源可以手动设 置。

Intergrated Peripherals Setup(外部设备设定)

    该菜单项用来设置集成主板上的外部设备的属性 。

    (1) IDE HDD Block Mode：如果选择Enable,可 以允许硬盘用快速块模式 (Fast Block Mode)来传输数据 。

    (2) IDE PIO Mode　这个设置取决于系统硬盘的 速度，共有AUTO，0，1，2，3，4五个选项，Mode4硬盘传 输速率大于是 16.6MB/秒，其它模式的小于这个速率。请 不要选择超过硬盘速率的模式，这样会丢失数据。

    (3) IDE UMDA(Ultra DMA)Mode:Intel 430TX芯 片提供了Ultra DMA Mode，它可以把传输速率提高到一个 新的水准。

Load BIOS Defaults(装入BIOS缺省值)

    主机板的CMOS中有一个出厂时设定的值。若CMOS 内容被破坏，则要使用该项进行恢复。由于BIOS缺省设定 值可能关掉了所有用来提高系统的性能的参数，因此使用 它容易找到主机板的安全值和除去主板的错误。

    该项设定只影响BIOS和Chipset特性的选定项。 不会影响标准的CMOS设定。移动光标到屏幕的该项然后按 下 y键，屏幕显示是否要装入BIOS缺省设定值，回 答Y即装入，回答N即不装入。选择完后，返回主菜单。

Supervisor Password And User Password Setup(管 理者与使用者密码设定 )

    User Passowrd Setting功能为设定密码。如果 要设定此密码，首先应输入当前密码，确定密码后按y，屏幕 自动回到主画面。输入User Passowrd可以使用系统，但不 能修改CMOS的内容。输入Supervisor Password可以输入、 修改CMOS BIOS的值，Supervisor Password是为了防止他 人擅自修改CMOS的内容而设置的。 用户如果使用IDE硬盘驱动器，该项功能可以自 动读出硬盘参数，并将它们自动记入标准CMOS设定中，它 最多可以读出四个 IDE硬盘的参数。

  以上介绍了Award BIOS Setup的常用选项的含义 及设置办法。更改设置后，请选 Save and Exit Setup项 来保存修改的内容，以便使所修改的内容生效。

    编后：AWARD BIOS是一种常用的BIOS，各大主板 制造商都在它的基础上进行了修改与添加，因而本文只是 一个参考，读者最好能仔细阅读随机附带的主板说明书。

BIOS相关程序及OEM LOGO图片下载


如何用好大容量IDE硬盘

本文摘自《CBI》

随着IBM以迅雷不及掩耳之势掀起硬盘市场的降价浪潮，99年主流IDE硬盘的容量比98年有大幅度的提升，2.1G和4.3G，甚至6.4G硬盘都已变成了低容量的型号，取而代之的是8G、10G和12G左右的大容量硬盘。不过，很多朋友在购买了这些大容量硬盘之后却遇到了不少问题，例如主板不认识硬盘，操作系统不支持，无法实现引导多种操作系统等等，让不少朋友对大容量硬盘产生不好的印象，其实，这些问题都是由于使用的主板BIOS或操作系统存在着8G容量限制造成的，而并非是硬盘本身的问题，下面就让我们来认识一下这种限制，然后突破它，放心使用大容量硬盘。

8G限制的来源
    硬盘是以扇区为单位来管理空间的，一个扇区可以存放512字节。硬盘、IDE控制器和BIOS都需要有一种方法来定位硬盘中的每个扇区，但是由于最初设计上的不一致，它们采用了不同的表示方式，现在的硬盘和IDE控制器都使用28位来定位扇区，最大能支持228×512字节=128GB的容量，而较老的BIOS只使用了24位来定位扇区，即使在引入了LBA工作模式后，最大也只能支持224×512字节=8GB的容量，这就是8G容量限制的根源所在。由于操作系统需要调用BIOS的13H号中断来对硬盘进行读写操作，如果不做任何特殊处理的话，常见的多种操作系统在使用老式BIOS的机器上也都要受到8G容量限制。

突破8G限制的方法
    那么要对BIOS进行什么特殊处理才能支持8G以上的硬盘呢？答案是加入INT 13H扩展，即对磁盘读写中断进行扩展。INT 13H扩展内部使用32位来定位扇区，它与LBA工作模式配合可以支持大至128G的硬盘。从98年初开始生产的BIOS陆续加入了INT 13H扩展，到了98年下半年，几乎所有的新版BIOS都集成了INT 13H扩展，因此这些BIOS都能够支持大容量硬盘，正确检测出其型号与参数。如果你购买了一块8G以上的硬盘，但BIOS无法识别它，或者认为它的容量只有8G，这就说明BIOS太老了。在这种情况下，最好的解决方法是升级主板的BIOS，只要主板能够升级BIOS，并且主板厂商提供新版BIOS，把它下载后一升级就全OK了。
    可是不少老主板无法升级BIOS，或者根本找不到新版BIOS，这怎么办？别急，硬盘厂商会为我们提供一个工具软件来对大容量硬盘进行分区、格式化，并帮助部分操作系统读写8G以上的硬盘空间，这个工具软件可以从硬盘厂商的网站上下载，例如IBM（http://www.storage.ibm.com）和Quantum（http://www.quantum.com）提供的都是有名的DM（Disk Manager）工具，该软件与常用的DOS、Windows和Windows NT操作系统都兼容，并且支持FAT32格式。

大容量IDE硬盘的使用
    在操作系统系统方面，MS-DOS 6.22、Windows 95和Windows NT 4.0（未安装SP4）都是在引入INT 13H扩展功能之前推出的，所以即便BIOS本身支持INT 13H扩展，它们也不认识，无法调用该功能，故而仍然会或多或少受到容量上的限制：或者不能使用8G以上的空间，或者系统分区被限制在8G以内。Windows 95 OSR2、Windows 98和Windows 2000对大容量硬盘具有良好的支持，只要BIOS支持或者使用了DM的驱动程序，管理和使用8G以上空间就不成问题。
    因此，当你购买了一块大容量硬盘后，笔者建议应以Windows 98（将来是Windows 2000）为主来管理硬盘，并根据不同的要求，对硬盘分区进行规划和使用：
    1．如果只准备使用Windows 98，那么分区原则上可以任意，但笔者建议你把C盘（主分区）限制在8G以内，而把8G以上的空间划分到一个FAT32分区之中，系统应安装到C盘内；
    2．如果还准备使用DOS 6.22，那么C盘应使用FAT16，先在C盘上安装DOS 6.22，然后再安装Windows 98;
    3．如果要安装Windows NT 4.0但不使用NTFS分区，那么可让C盘和D盘都使用FAT16，并在Windows 98下安装NT 4.0到D盘，安装好后把NT升级至Service Pack 4，然后再装一个FAT32驱动程序，让NT 4.0也能访问其它FAT32驱动器，这种安装方式可以顺利实现NT 4.0和Windows 98的多重引导；
    4．如果准备让NT 4.0使用NTFS分区，那么要在8G以内为NT保留一个分区，用做系统分区，安装完毕后升级至SP4，再把系统分区转换成NTFS格式，此外还可以把8G以上空间转换成NTFS分区来使用；
    5．如果要安装Linux，建议使用最新版的RedHat 6.0，并根据Linux的要求来分区。
    总之，在安装多种操作系统时，8G以内的空间很重要，操作系统本身应安装到8G以内，用于启动的活动分区应设置在8G以内，而8G以上空间可以使用FAT32或NTFS文件系统来管理。
    如果BIOS无法升级，只能用DM来突破8G限制，那么在使用DM对硬盘进行分区和格式化后，可以先向C盘中传递DOS（最好是7.0以上）系统，并在CONFIG.SYS之中装载DM的DOS版驱动程序，然后从C盘启动之后再来安装Windows 98，安装完毕后，再把DM的Windows版安装到Windows 98中。

使用大容量硬盘过程中常见的一些严重问题及处理方法
    如果在安装NT 4.0的过程中选择格式化硬盘分区，或者要求把FAT16格式转换成NTFS格式，则有可能会出现死机，这是因为NT 4.0所带的ATAPI IDE驱动程序Atapi.sys与大容量硬盘不兼容的缘故。此时可以根据前面第3点和第4点中介绍的基本要求来安装NT，或者按照以下步骤来安装：
    1．到ftp://ftp.microsoft.com/bussys/winnt/winnt-unsup-ed/fixes/nt40/atapi/ATAPI.EXE去下载SP4版的ATAPI IDE驱动程序，下载之后把它拷贝到一张空软盘上，并在软盘上运行自解压程序ATAPI.EXE；
    2．从NT的三张安装盘启动；
    3．当安装程序提问是否自动检测大容量存储设备（mass storage devices）时，按S键让安装程序跳过检测，以便手工指定存储设备；
    4．当安装程序给出一个空的存储设备列表时，再次按S键，插入第1步制作的软盘，并连续按两次回车键；
    5．安装程序读盘完毕后会列出ATAPI SP4 IDE驱动程序，按回车键以表示确认；
    6．此时安装程序会显示ATAPI SP4 IDE驱动程序已经安装，按回车键继续安装过程；
    7．此后的安装过程中如果要格式化硬盘分区，安装程序会提示插入包含有ATAPI SP4 IDE驱动程序的软盘（即第1步制作的软盘），按照提示操作即可。
    如果BIOS支持8G以上硬盘，但NT4仍然可能会认为IBM DTTA-351010、IBM DTTA-351680、Quantum Bigfoot TX 12GB等型号硬盘的容量只有8G或7.5G，这同样是由于Atapi.sys存在着兼容性问题，此时仍可按上述方法来安装NT。
    在使用Windows 9x的系统中，如果把大容量硬盘作为非启动盘，那么在系统属性中可能显示这个硬盘工作在MS-DOS兼容方式下，设备管理器中相应的IDE控制器上可能显示有黄色惊叹号，这是由于Windows 9x内部的缺陷造成的，对Windows 98来说，需要获得4.10.2002以上版本的驱动程序Esdi_506.pdr，对Windows 95 OSR2来说，需要获得4.00.1119以上版本的Esdi_506.pdr，这些文件需要向微软的技术支持部门索取。


完全BIOS手册—华碩 BIOS设定方式說明

华碩 BIOS设定方式說明

BIOS(基本輸入輸出系統)为出厂時燒錄在主机板上FlashROM之程式,其扮演著硬体与作业系 統溝通的角色,透过BIOS可设定系統操作模式及硬体之相关參数。系統关机時,BIOS会先進行关机自我測試 (POST)。此時,按下<Del>鍵即可進入BIOS设定主画面。其功能及操作方式說明如下:

【StandardCMOSSetup】系統基本參数设定

此选項之功能主要为设定系統基本參 数。使用者可透过移動亮棒的方式來选择欲设定的項 目,用<PageUp>及<PageDown>鍵來修改內容。在 每一选項中,您可按<F1>鍵來顯示該选項可供选 择之內容。

Date(日期)

设定目前日期。可设定之範圍为:

Month(月)：1至12

Day(日)：1至31

    Year(年)：至2079

Time(時間)

设定目前時間。可设定之範圍为:

Hour(時)：00至23

Minu7te(分)：00至59

Second(秒)：00至59

HardDisks(硬盘)

此选項用來设定系統中所有IDE硬盘 (PrimaryMaster/Slave;SecondaryMaster/Slave)之類型。各选項說明如 下:

Auto:允許系統关机時自動偵測硬盘 類型並加以设定。

None:未安裝硬盘。

User:允許使用者自行设定硬盘之相 关參数。包括CYLS(磁柱数),HEAD(讀寫頭数),PRECOMP(寫入預 補償),LANDZ(放位置)。在硬盘机所附之說明書均磁頭停詳 載這些規格。

[請注意]:BIOS不支援SCSI硬盘之设定。

至於MODE的选項有三種:

  1. NORMAL模式:为傳統之標準模式,支援硬 盘机容量最高至528MB。
  2. LBA(LogicalBlockAddressingMode)模式:適用於 硬盘机容量超过且支援邏輯區塊定址(LBA)功能者。
  3. LARGE模式:当硬盘机容量超过528MB,而 硬盘或作业系統不支援LBA模式時,可採用此选項。

DriverA/DriverB(None)

此选項设定軟盘机之類型，可供选择 之項目有:360KB,5.25in;1.2MB,5.25in;720KB,3.5in;1.44MB,3.5in;2.88MB, 3.5in;None等六種類型。

Floppy3ModeSupport(預设值为Disable)

若使用日本標準模式之軟盘机(Floppy3 Mode),則设定之。否則請取消(disable)此设定功能。可供选 择之項目有:driveA,driveB,Both,及Disable。

Video(視訊顯示卡型態,預设值为EGA/VGA)

设定顯示卡之種類,可供选择之項目有 :MONO(單色),EGA/VGA(彩色),CGA40,CGA80。

HaltOn(暫停关机,預设值为AllError)

本欄设定何種型態的异常將会導致系 統暫停关机,可供选择之項目有:

AllErrors:有任何錯誤,系統均顯示錯 誤信息,並暫停关机。

NoErrors:無論任何錯誤系統均照常 关机。

All,Butkeyboard:有任何錯誤,系統暫停 关机,但鍵盤异常則照常关机

All,ButDisk/Key:有任何錯誤,系統暫停 关机,但磁盘机及鍵盤异常則照常关机。

【BIOSFeaturesSetup】BIOS特殊參数设定

本項设定可根據您的系統及需求來強 化您系統的性能,但若對设定之功能不甚了解,建議您 使用預设值。在本項设定主画面右下方描述了功能 鍵之操作方法。BIOS特殊參数设定功能說明如下：

VirusWarning病毒防護警告(預设值为Disable)

此功能可防止硬盘之关机磁區及分割 區被更改,任何試圖寫入該區之動作將会導致系統当 机並顯示警告信息。

[請注意]:当您安裝新的作业系統( 如Win95)時,請先取消(disable)此功能,以免因衡突而無法 順利安裝。

CPUInternalCache(CPU內部快取記憶体,預设值为Enable)

本項功能用於啟用(enable)或取消(disable) CPULevel1快取記憶体。就整体速度而言,啟用L1快取將 比取消L1快取時提升許多。因此,預设值为啟用(enable)。

ExternalCache(外部快取功能，預设值为Enable)

本項功能用於啟用(enable)或取消(disable) CPULevel2快取記憶体。就整体速度而言,啟用L2快取將 比取消L2快取時提升許多。因此,預设值为啟用(enable)。Pentium ProCPU已內建L2快取記憶体。

QuickPowerOnSelfTest(快速关机自我測試, 預设值为Enable)

电脑关机時,BIOS会執行一連串之关机 自我測試。当啟用本功能時,会精簡及跳过相同項目 之測試,以縮短关机時間。

HDDSequenceSCSI/IDEFirst(IDE/SCSI硬盘关机優先順序, 預设值为IDE)

当同時安裝SCSI及IDE硬盘時,本选項功 能可用來选择以SCSI或IDE硬盘作为关机硬盘。

BootSequence(关机順序,預设值为C,A)

此选項设定当电脑关机時,选择由A盘, C盘及CD-ROM关机之優先順序。提供之选項有：

A,CD-ROM,C;

CD-ROM,C,A;

D,A;

E,A;

F,A;

Conly;

A,C;

C,A;

SwapFloppyDrive(軟盘机互換,預设值为Disable)

当啟用(enable)本項功能時,則A,B盘互換 。亦即原先A盘被指定成B盘,B盘被指定为A盘。如此 一來,您就不需打关机殼互換排線了。

BootUpFloppySeek(关机軟盘搜尋,預设值为Disable)

当啟用(enable)本功能,則电脑关机時,BIOS 之POST程式会去偵測Floppy是否存在。否則,跳过此偵測 動作。

FloppyDiskAccessControl(軟盘存取控制讀/取, 預设值为R/W)

本功能主要用來控制軟盘之存取。当 选取&ldquo;ReadOnly&rdquo;時,則只能由軟盘讀取資料,而 無法將系統之資料拷貝至軟盘中,当选取R/W時,則軟 盘可正常讀取資料。

BootUpNumLockStatus(关机数字鍵鎖定狀態, 預设值为On)

  On:关机時数字鍵设定为数字狀態

  Off:关机時数字鍵设定为方向狀態

IDEHDDBlockModeSectors(IDE硬盘磁區设定, 預设值为HDDMAX)

新式IDE硬盘大多支援一次傳輸多個磁 區之功能。啟用(enable)本功能則可加快硬盘存取速度 。选項有HDDMAX,Disabled,2,4,8,16,及32。

TypematicRateSetting(鍵盤速率设定,預设值为Disable)

本选項用來決定是否啟用鍵盤速率设 定功能。若啟用(enable),則TypematicRate及TypematicRelay之设定 才有作用。

TypematicRate(字元/秒,鍵盤重覆率,預设值为6)

本选項设定:当您按鍵不放時,每秒出 現之字元数。选項有：6,8,10,12,15,20,24,30(字元/秒) 。

Typematicdelay(輸入延遲時間,預设值为250ms)

当按鍵不放,則超过设定延遲時間後, 鍵盤会以一定速率重覆輸入字元。选項有250ms,500ms, 750ms,1000ms。

SecurityOption(安全选項设定,預设值为System)

本选項设定要求使用者輸入密碼之時 机,有下列兩種选項:System:每次关机時,电脑会要求輸 入正確密碼,否則無法关机。Setup:只有在進入BIOS设定 時,系統才会要求輸入確密碼。

PS/2MouseFunctionControl(PS/2滑鼠功能控制, 預设值为Auto)

若设定为Auto:則关机時,系統將会偵測 PS/2滑鼠是否存在。若存在,則IRQ12即保留給PS/2Mouse使 用。若设定为disable:則IRQ12保留給介面卡使用,此時PS/2 滑鼠沒有作用。

PCI/VGAPaletteSnoop(預设值为Disable)

若使用非標準VGA卡(如影像加速卡、MPEG 卡)有時無法正常顯現色彩,此時设为"Enable"將可 解決此問題。除此之外,建議使用預设值。

OS/2OnboardMemory>64M(預设值为Disable)

若作业系統使用OS/2,且安裝之主記憶 体容量超过64MB則设定为啟用(enable),否則设定为預设 值Disable。

VideoBIOSShadow(視訊BIOS快速執行功能,預设值为 Enable)

啟動本功能,則VGA之BIOS即拷貝至主記 憶体以加速執行速度,若取消(disable)此功能,則顯示速 度將變得很慢。

C8000-CBFFFtoDC000-DFFFF(預设值为Disable)

若您使用其他介面卡,則选取此功能時 ,系統將会利用Shadow技術來加快介面卡上ROM之執行速 度。不过,如此一來將会佔用主記憶体之空間。

【ChipsetFeaturesSetup】晶片組參数设定：

本选項主要是經由晶片組之參数设定, 來調整硬体文件之性能.若對這些设定內容不甚了解 建議您採用預设值。

AutoConfiguration(自動设定,預设值为60nsDRAM)

您可依照您所使用的記憶体來选取60M DRAMor70NSDRAM选項,則BIOS会根據您的设定自動調整第2到 9选項。若选择&ldquo;disable&rdquo;(取消),則第2至第9选 項可自行調整。

SDRAMCAS#Latency(預设值为3T)

若您使用华碩之SDRAM模組,則可设为2T 來獲得更快之存取速度。否則請设为預设值3T,或洽詢 您的經銷商有关DIMM之規格。

SDRAMSpeculativeRead(預设值为Disable)

PassiveRelease(預设值Enable)

RelayTransaction(預设值为Disable)

16-bitI/ORecoveryTime(16位元之I/O恢復時間, 預设值为1BUSCLK)

定義为16-bitISA卡I/O之恢復時間。

8-bitI/ORecoveryTime(8位元之I/O恢復時間, 預设值为1BUSCLK)

定義为8-bitISA卡I/O之恢復時間。

VIDEOBIOSCacheable(視訊快取功能,預设值为Disable)

Enable:啟用快取功能以加快顯示速度。

Disable:取消此功能。

MemoryHoleatAddress(預设值为None)

一些ISA卡会要求使用14-16MB或15-16MB之記 憶位址空間,若选取14MB-16MB或15MB-16MB,則系統將無法使用 這部份之記憶体空間。您可选取None來取消此功能。

OnboardFDCSwapA:B:(A，B盘互換,預设值为NoSwap)

当啟用(enable)本項功能時則A,B盘互換 。亦即原先A盘被指定成B盘,B盘被指定为A盘。如此 一來，您就不需打关机殼互換排線了。

OnboardSerialPort1:(預设值为3F8H/IRQ4)

设定主机板上串列埠1之位址及IRQ,选 項有:

3F8H/IRO4;

2F8H/IRQ3;

3E8H/IRQ4;

2E8H/IRQ10;

Disable;

OnboardSerialPort2:(預设值为2F8H/IRQ3)

设定主机板上串列埠2之位址及IRQ,选 項有:

3F8H/IRQ4;

2F8H/IRQ8;

3E8H/IRQ4;

2E8H/IRQ10;

Disable;

OnboardParallelPort:(預设值为378H/IRQ7)

设定主机板上並列埠之位址及IRQ。

ParallelPortMode(並列埠模式,預设值为ECP+EPP)

设定並列埠之操作模式,有下列选項:

Normal:一般速度單向執行。

EPP:最高速度雙向執行。

ECP:超高速雙自執行。

ECP+EPP:ECP与EPP二種模式並用。

ECPDMASelect(ECPDMA通道选择,預设值为3)

若在ECP模式下操作時,則提供DMA通道选 择有1,3,Disable三種设定。

UART2UseInfrared(預设值为Disable)

本項功能用來支援紅外線（IR）傳輸 功能。

Enable：則设定第二串列埠UART支援紅外線 傳輸功能。

Disable：則设定第二串列埠UART支援COM2。

OnboardPCIIDEEnable(主机板IDE通道,預设值为Both)

用來啟用內建IDE通道。选項有：

PrimaryIDEChannel

SecondaryIDEChannel

Both(二者均啟用)

Disable(取消)。

IDE0Master/SlaveMode,IDE1Master/SlaveMode(硬盘時序模式设定, 預设值为Auto)

預设为Auto時,系統会自動偵測四個IDE 裝置之時序模式以確保以最佳速度運行。您也可以 自行设定時序模式为(0,1,2,3,4)。

      【PowerManagementSetup】（电源管理设定）

VideoOFFOption（关閉螢幕省电设定,預设值为Susp, Stby->Off）

本选項用來设定螢幕省电管理模式中 啟用&ldquo;螢幕关閉&rdquo;之時机。可选用之項目 說明如下：

Susp,Stby->Off:只在待机(Standby) 或暫停(Suspend)之省电模式下才关閉螢幕。

Suspend->Off:只在暫停(Suspend) 模式下才关閉螢幕顯示。

Alwayson:在任何模式下均不关 閉螢幕顯示。

Allmodes->Off:在任何省电模 式下均关閉螢幕顯示。

VideoOFFMethod(螢幕关閉方式,預设值为V/H SYNC+Blank)

用來选择螢幕关閉之模式。但若無法 順利关閉螢幕,則设定为"Blank"若顯示卡支援DPMS 功能,則设定为"DPMS"。

PWRButton<4secs(按住电源关关鍵少於4秒, 預设值为SoftOff)

本功能设定当压住电源按鍵時間少於4秒之情況下, 系統之操作模式。

SoftOff:執行ATX电源軟体关机。

Suspend:系統進入暫停（Suspend）模式。

NOFunction:取消任何有关ATX关关之功能。

[請注意]:一旦PWR压住超过4秒,則不 論如何设定,系統均会关机。

PWRUpOnModemAct(数据机动作時关机,預设值为Enable)

ACPWRLossRestart(預设值为Disable)

--PMTimers--

HDDPowerDown：

当系統在选定之時間內未對硬盘進行 存取動作,則進入省电模式。省电模式依耗电量大小 依序为DozeMode(睡眠模式),Standbymode(待机模式)及Suspend Mode(暫停模式)。若硬盘在各模式选定之時間內尚無 動作,則依序進入下一個更省电模式。

FanMonitor(XXXXRPM)

主机板內建監控裝置能偵測風扇轉速( 轉/秒),若無安裝支援此功能之風扇,則选取Ignore(忽 略),以免產生錯誤信息。

ThermalMonitor(xxxC/xxxF)

主机板內建監控裝置能偵測CPU及主机 板之溫度。若选取Ignore則当CPU及主机板溫度异常時, 將不顯示錯誤信息。

VoltageMonitor(xx.xV)

主机板內建監控裝置能偵測系統之电 压值。若选取Ignore則当系統电压异常時，將不顯示錯 誤信息。

【PNPandPCISetup】即插即用与PCI之设定

PNPOSInstalled(是否安裝PNP作业系統,預设值为No)

当您使用的是具有即插即用(PNP)功能 的作业系統時(如Windows95),則您可选择Yes。

SlotXIRQ(PCI插槽的中断值,預设值为Auto)

用來设定每一個PCI插槽之IRQ值,項目有 NA,9,10,11,12,13,14,15,及Auto(即由BIOS自動设定)。

PCILatencyTimer(預设值为32PCIClock)

採用&ldquo;32PCIClock&rdquo;將可使主机板 之PCI速度最快。

IRQXXUsedByISA(預设值为No/ICU)

用來保留特定IRQ給non-PnP之ISA卡。

DMAXXUsedByISA(預设值为No/ICU)

用來保留特定DMA通道給non-PnP之ISA卡。

ISAMEMBlockBASE(預设值为No/ICU)

用來保留給ISA卡之記憶体之區塊大小 与位址。

SYMBIOSSCSIBIOS(預设值为Auto)

本項功能可选用Auto來啟用內建NCRSCSI BIOS,您可选取Disable來取消此項功能。

USBFunction（万用埠功能设定,預设值为Disable）

本項功能用來啟用USB之功能,本主机板 可支援万用序列埠(USB),但現在之作业系統尚未支援 USB功能,所以目前採用預设值为(disable)。

      【LoadBIOSDefault】（載入BIOS參数預设值）

当系統安裝後不太穩定,則可选用本功 能。此時系統將会取消一些高效能之操作模式设定, 而處在最保守狀態下。如此,使用者便可順利关机並 進而找出問題。当选择本項時,主画面会出現下列信 息:

    LoadBIOSDefaults（Y/N）?

鍵入Y並按Enter即可執行本項功能。

[請注意]:本項设定不会影响CMOS內儲存 之设定值。

          【LoadSetupDefaults】載入设定預设值

此为BIOS出厂设定值。此時系統会以最 佳化之模式運作。选择此功能時,主画面会出現下列 信息:

  LoadSETUPDefaults（Y/N）?

鍵入Y並按Enter即可執行本項功能。

【SupervisorPasswordandUserPassword】(密碼设定)

本功能用來设定System及Setup之密碼,本 項功能需配合BIOSFeaturesSetup中之SecurityOption使用。

[請注意]:假若您遺忘了密碼,需透过清 除CMOS之內容才得以重新关机。

【IDEHDDAutoDetection】(硬盘型態自動偵測)

此項可自動偵測IDE硬盘之規格及相关 參数,並能自動存入CMOS之设定(BIOSStandardCMOSSetup)中。

【SaveandExitSetup】將设定值儲存後，离关设定主画面。

【ExitWithoutSaving】不儲存设定值，直接离关设定主画面


完全BIOS手册—什么是BIOS和COMS

什么是BIOS和COMS

什么是BIOS

系统开机启动 BIOS，即微机的基本输入输出系统(Basic Input-Output System)，是集成在主板上的一个ROM芯片，其中保存有微机系统 最重要的基本输入/输出程序、系统信息设置、开机上电自检程序和系统启动自举程序。在主板上可以看到BIOS ROM芯片， 请参见微机主板图。一块主板性能优越与否，很大程度上取决于板上的BIOS管理功能是否先进。

一、BIOS中断例程 即BIOS中断服务程序。它是微机系统软、硬件之间的一个可编程接口，用于程序软件功能与微机硬件实现的衍接。 DOS/Windows操作系统对软、硬盘、光驱与键盘、显示器等外围设备的管理即建立在系统BIOS的基础上。程序员也可以通过 对INT 5、INT 13等中断的访问直接调用BIOS中断例程。

二、BIOS系统设置程序 微机部件配置情况是放在一块可读写的CMOS RAM芯片中的，它保存着系统CPU、软硬盘驱动器、显示器、键盘等部件的信息。 关机后，系统通过一块后备电池向CMOS供电以保持其中的信息。如果CMOS中关于微机的配置信息不正确，会导致系统性能降 低、零部件不能识别，并由此引发一系统的软硬件故障。在BIOS ROM芯片中装有一个程序称为“系统设置程序”，就是用来 设置CMOS RAM中的参数的。这个程序一般在开机时按下一个或一组键即可进入，它提供了良好的界面供用户使用。这个设置 CMOS参数的过程，习惯上也称为“BIOS设置”。新购的微机或新增了部件的系统，都需进行BIOS设置。

三、POST上电自检 微机接通电源后，系统将有一个对内部各个设备进行检查的过程，这是由一个通常称之为POST(Power On Self Test,上电自 检)的程序来完成的。这也是BIOS的一个功能。完整的POST自检将包括CPU、640K基本内存、1M以上的扩展内存、ROM、主板、 CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘测试。自检中若发现问题，系统将给出提示信息或鸣笛警告。

四、BIOS系统启动自举程序 在完成POST自检后，ROM BIOS将按照系统CMOS设置中的启动顺序搜寻软硬盘驱动器及CDROM、网络服务器等有效的启动驱动器 ，读入操作系统引导记录，然后将系统控制权交给引导记录，由引导记录完成系统的启动。

什么是CMOS

CMOS（本意是指互补金属氧化物半导体——一种大规模应用于集成电路芯片制造的原料）是微机主板上的一块可读写的RAM芯 片，用来保存当前系统的硬件配置和用户对某些参数的设定。CMOS可由主板的电池供电，即使系统掉电，信息也不会丢失。 CMOS RAM本身只是一块存储器，只有数据保存功能，而对CMOS中各项参数的设定要通过专门的程序。早期的CMOS设置程序驻留 在软盘上的(如IBM的PC/AT机型)，使用很不方便。现在多数厂家将CMOS设置程序做到了BIOS芯片中，在开机时通过特定的按键 就可进入CMOS设置程序方便地对系统进行设置，因此CMOS设置又被叫做BIOS设置。 早期的CMOS是一块单独的芯片MC146818A(DIP封装)，共有64个字节存放系统信息,见CMOS配置数据表。386以后的微机一般将 MC146818A芯片集成到其它的IC芯片中(如82C206，PQFP封装)，最新的一些586主板上更是将CMOS与系统实时时钟和后备电池集 成到一块叫做DALLDA DS1287的芯片中。随着微机的发展、可设置参数的增多，现在的CMOS RAM一般都有128字节及至256字节 的容量。为保持兼容性，各BIOS厂商都将自己的BIOS中关于CMOS RAM的前64字节内容的设置统一与MC146818A的CMOS RAM格式 一致，而在扩展出来的部分加入自己的特殊设置，所以不同厂家的BIOS芯片一般不能互换，即使是能互换的，互换后也要对 CMOS信息重新设置以确保系统正常运行. 你认识主板上的BIOS芯片吗？ 介绍常见的BIOS芯片的识别 ROM BIOS是主板上存放微机基本输入输出程序的只读存贮器，其功能是微机的上电自检、开机引导、基本外设I/O和系统CMOS 设置。 主板上的ROM BIOS芯片是主板上唯一贴有标签的芯片，一般为双排直插式封装(DIP)，上面印有“BIOS”字样。虽然有些BIOS 芯片没有明确印出“BIOS”，但凭借外贴的标签也能很容易地将它认出。 586以前的BIOS多为可重写EPROM芯片，上面的标签起着保护BIOS内容的作用(紫外线照射会使EPROM内容丢失)，不能随便撕下。 586以后的ROM BIOS多采用EEPROM(电可擦写只读ROM)，通过跳线开关和系统配带的驱动程序盘，可以对EEPROM进行重写，方便 地实现BIOS升级。 常见的BIOS芯片有AMI、Award、Phoenix等，在芯片上都能见到厂商的标记。


完全BIOS手册—BIOS与CMOS

BIOS与CMOS

本文摘自：超能地带

我们经常听道什么bios、coms，它们是什么，有什么区别？具体如下：

BIOS，(Basic Input/output system)即基本输入/输出系统。它实际上是被固化到计算机中的一组程序，为计算机 提供最低级的、最直接的硬件控制。准确地说，BIOS是硬件与软件程序之间的一个“转换器”或者说是接口(虽然它本身也只是一个程序) ，负责解决硬件的即时需求，并按软件对硬件的操作要求具体执行。程序员可以通过对INT 5、INT 13等中断的访问直接调用BIOS中断例程。
BIOS是固化在主板上的ROM芯片，而系统设置程序，微机部件配置情况是则是放在一块可读写的CMOS RAM芯片中的，它保存着系统CPU、软硬盘驱动器、显示器、键盘等部件的信息，关机后，系统通过一块后备电池向CMOS供电以保持其中的信息。当微机接通电源后，系统将有一个对内部各个设备进行检查的过程，这是由一个通常称之为POST(Power On Self Test,上电自 检)的程序来完成的。这也是BIOS的一个功能。完整的POST自检将包括CPU、640K基本内存、1M以上的扩展内存、ROM、主板、 CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘测试。自检中若发现问题，系统将给出提示信息或鸣笛警告。在完成POST自检后，ROM BIOS将按照系统CMOS设置中的启动顺序搜寻软硬盘驱动器及CDROM、网络服务器等有效的启动驱动器 ，读入操作系统引导记录，然后将系统控制权交给引导记录，由引导记录完成系统的启动。
目前市场上主要的BIOS有AMI BIOS和Award BIOS。586以前的BIOS多为可重写EPROM芯片，上面的标签起着保护BIOS内容的作用(紫外线照射会使EPROM内容丢失)，不能随便撕下。 586以后的ROM BIOS多采用EEPROM(电可擦写只读ROM)，通过跳线开关和系统配带的驱动程序盘，可以对EEPROM进行重写，方便地实现BIOS升级，这就是我们常说的BIOS升级。

CMOS，（是指互补金属氧化物半导体——一种大规模应用于集成电路芯片制造的原料）是微机主板上的一块可读写的RAM芯 片，用来保存当前系统的硬件配置和用户对某些参数的设定。CMOS可由主板的电池供电，即使系统掉电，信息也不会丢失。 CMOS RAM本身只是一块存储器，只有数据保存功能，而对CMOS中各项参数的设定要通过专门的程序。早期的CMOS设置程序驻留 在软盘上的(如IBM的PC/AT机型)，使用很不方便。现在多数厂家将CMOS设置程序做到了BIOS芯片中，在开机时通过特定的按键 就可进入CMOS设置程序方便地对系统进行设置，因此CMOS设置又被叫做BIOS设置。 早期的CMOS是一块单独的芯片MC146818A(DIP封装)，共有64个字节存放系统信息,见CMOS配置数据表。386以后的微机一般将 MC146818A芯片集成到其它的IC芯片中(如82C206，PQFP封装)，最新的一些586主板上更是将CMOS与系统实时时钟和后备电池集 成到一块叫做DALLDA DS1287的芯片中。随着微机的发展、可设置参数的增多，现在的CMOS RAM一般都有128字节及至256字节 的容量。为保持兼容性，各BIOS厂商都将自己的BIOS中关于CMOS RAM的前64字节内容的设置统一与MC146818A的CMOS RAM格式 一致，而在扩展出来的部分加入自己的特殊设置，所以不同厂家的BIOS芯片一般不能互换，即使是能互换的，互换后也要对 CMOS信息重新设置以确保系统正常运行.


完全BIOS手册—修改 BIOS LOGO F&Q

修改 BIOS LOGO F&Q
本文摘自《电脑报》
原作者及主页为：吴朝相的 EXE 主页

自从在写了那篇关于修改 BIOS 里能源之星 LOGO 的东西以后，我的E-MAIL 信箱就没空过，为了我和大家的方便，今天特别总结了一些常见的问题整理成文，希望大家在来信之前都看看本文。

0、 修改的必备条件
你的 BIOS 一定要是 AWARD 公司出品的；你的主板支持 BIOS 升级和你已经把升级跳线打开；你已经会使用升级软件 AWDFLASH ；你要为万一升级失败做好心理准备！

1、 那里有文章提到的软件 DOWNLOAD ？
别笑，这个问题占的比例不少！ 以前我把所有的软件都压成一个文件，方便大家下载，现在既然搞了这个BIOS DIY ，就把软件分门别类分开，起码方便更新！大家可以到： http://topage.126.com/这个地方的BIOS DIY专栏里面找到这些软件！

2、 EPADOS 运行出错
我的机器运行这个程序没一点问题，就是不知道为什么那么多的朋友都说运行不了。建议大家都用MICROSOFT 的 MOUSE 驱动程序，最后当然最好是在 WINDOWS 95/98 的 DOS 窗口下运行啦，如果还不行，请在纯 DOS环境下试试，再不行的话，不是你 DOWNLOAD 回来时损坏了，就是你的机不行了。

3、 用 EPADOS 转换出来的 EPA 文件，在四个角上有“MR”字样
那是因为你的 EPADOS 未注册所造成的，解决方法当然就是下载一个注册版本咯，本站就有。

4、 可以把 EPA 文件转换成 BMP 文件吗？
可以，只要你有 BMPTOEPA 这个软件的注册版本就可以，我这里有这个软件，但是未注册版本。

5、 可以把 BIN 文件里面的 EPA 、 BMP 文件分离出来吗？
可以的，输入 CBROM ***. BIN /EPA EXTRACT 这个命令后，再输入一个文件名就可以了。同理要分离 BMP的话用 CBROM ***. BIN /LOGO EXTRACT 命令，如果你的BIOS有这个文件的话。

6、 用 CBROM 看到的 EPApattern 项后面的文件名是 XXX. BIN 该如何办？
我没太多的试验，但我自己的 BIOS 就是显示 XXX.BIN 的，我把它当 EPA 办，没问题，因为都已经是 97年的 TX 主板了，还想是 BMP ？ 想都想到啦。但有朋友说按 EPA 和 BMP 都不行，我也不知道是什么原因了。

7、 用 CBROM ***. BIN /D 看到一大堆乱码
我也想不通这个问题，因为我没遇到过，虽然我也没换过多少台机，但网友们给我发来的所有 BIOS 文件都没这个问题。只能劝你再用新的 CBROM 1. 30 试试了。

8、 我的 BIOS 文件里是用 EPA 的，我可以加开机是全屏的 BMP LOGO 图形吗？
我的实践告诉我，是不可以的，虽然你可以用 LOGO 参数强行把 BMP 文件写进 BIN 文件里，但开机时是毫无反应的，就像你根本就没做过一样。至于强行写入后会不会有其它副作用，就不得而知了。

9、 我在用epados工具转换bmp epa 格式文件时提示：2564bytes wrong bmp filesise!/falsche bmp....
请大家注意，如果按 136*126 的格式画出来的单色 BMP 图形标准是 2582 Bytes 的，如果你的不是， 那应该是你作图软件有问题，或者你的图形不是单色的。

10、我想为自己的机器增加开机时像品牌机一样的全屏画面，但写入 BMP 后花屏，或没反应。
这个可是最近碰到的辣手问题，因为我的 BIOS 不支持，所以也没地方试验。说说我的看法吧，如果你写入 16 色的 BMP 不成功，我想应该是和 FLASH ROM 的大小有点关系的，毕竟它们有 1M 和 2M 之分嘛。所以你最好先看看你的 BIOS 是不是 2M 的，如果是，成功机会大些。还有就是 BMP 的文件格式问题了，由最新的资料看来，一些品牌机里面的 BMP 文件并不是一个 BMP 格式的图形文件，而是一个二进制的不知名格式文件（起码我是不知道）。如果大家有谁知道这其中的密秘，还要请你指教一下哦！由最新的消息来看，大家可以把原来的 BMP 文件导出来分析分析一下文件的开头几个字节，可能会有发现的。


完全BIOS手册—BIOS????

BIOS极其功能

▲BIOS是什么?

所谓BIOS，实际上就是微机的基本输入输出系统(Basic Input System),其内容集成在微机主板上的一个ROM芯片上，主要保存着有关微机系统最重要的基本输入输出程序,系统信息设置,开机上电自检程序和系统启动自举程序等。

▲BIOS的功能

BIOS ROM 芯片不但可以在主板上看到，而且BIOS管理功能如何在很大程度上决定了主板性能是否优越。BIOS管理功能包括：

1.BIOS中断服务程序实质上是微机系统中软件与硬件之间的一个可编程接口，主要用于程序软件功能与微机硬件之间 接。例如,WINDOWS98对软驱,光驱,硬盘等管理,中断的设置等服务、程序。

2. BIOS系统设置程序：微机部件配置记录是放在一块可写的CMOS RAM芯片中的，主要保存着系统的基本情况,CPU特性,软硬盘驱动器等部件的信息。在BIOS ROM 芯片中装有“系统设置程序”，主要来设置CMOS RAM中的各项参数。这个程序在开机时按某个键就可进入设置状态，并提供良好的界面。

3.POST上电自检：微机接通电源后，系统首先由(Power On Self Test,上电自检)程序来对内部各个设备进行检查。通常完整的POST自检将包括对CPU,640K基本内存,1M以上的扩展内存,ROM,主板,CMOS存储器,串并口,显示卡,软硬盘子系统及键盘进行测试，一旦在自检中发现问题，系统将给出提示信息或鸣笛警告。

4. BIOS系统启动自举程序：系统完成POST自检后，ROM BIOS就首先按照系统CMOS设置中保存的启动顺序搜索软硬盘驱动器及CD-ROM,网络服务器等有效地启动驱动器，读入操作系统引导记录，然后将系统控制权交给引导记录，并由引导记录来完成系统的顺序启动。


完全BIOS手册—BIOS ID大揭秘

BIOS ID大揭秘

本文摘自《电脑报》

编者按：现在许多玩家都在试图升级自己的BIOS，因为通过升级可以解决老版本中存在的BUG，也能支持更多的新硬件。但升级BIOS是一件较危险的事，特别需要认准该BIOS是哪个厂家提供的，否则用错了可能导致机器无法启动。有许多读者来信反映，他们不慎将主板的说明书弄丢了，或者主板说明书只有短短的几页，根本没写有关BIOS的信息。我们特意刊登这篇文章，让各位玩家了解一下，如何在这种情况下知道自己的主板BIOS信息。
鉴别BIOS最准确的办法就是识别BIOS ID，也就是说，只要BIOS ID相同的主板，其BIOS程序是通用的。
    这里介绍一下如何记录你的BIOS ID，并从中发现主板的有关信息(以AWARD公司的BIOS为例)：
    1.打开计算机电源；
    2.在屏幕的左上角将出现Award Modular BIOS(这并不是系统BIOS的版本号)，在内存检测时按下Pause键；
    3.查看屏幕底端，有一系列数字与字母组成的标志，比如：10/16/97－i430TX－ALI513x－2A59IF3BC－00。
    其中最重要的标号是“2A59IF3BC”。“2A59I”是主板所采用的芯片组类型的编码(附后)。而其中第6、第7位字符尤为重要，它是硬件厂商的代码信息，比如上面给的符号序列中的“F3”，它代表“FYI(福扬)”系列主板。
    另外，“ALI513x”指主板的I/O芯片是采用ALI公司的513x系列。有些电脑爱好者以为同是TX芯片组的BIOS就可以拿来升级自己的TX主板，结果导致键盘不能用或找不到串并口，其原因就是因为不同厂家的TX主板采用了不同的I/O芯片。
    主板BIOS ID中芯片组的编码信息:
    2A69K:Intel 440BX chipset (Pentium Ⅱ based chipset)
    2A69J:Intel 440LX chipset (Pentium Ⅱ based chipset)
    2A69H:Intel 440FX chipset (Pentium Ⅱ/Pentium Pro based chipset)
    2A59C:Intel Triton FX chipset (Socket 7 based m/b)
    2A59F:Intel Triton Ⅱ HX chipset (Socket 7 based m/b)
    2A59G:Intel Triton VX chipset (Socket 7 based m/b)
    2A59H:Intel Triton VX chipset (Socket 7 based m/b)
    2A59I:Intel Triton TX chipset (Socket 7 based m/b)
    2A59A:Intel Natoma (Neptune) Chipset
    2A597:Intel Mercury Chipset
    2A59B:Intel Mercury Chipset
    2A5C7:VIA VT82C570 Chipset
    2A5G7:VLSI VL82C594 Chipset
    2A5GB:VLSI Lynx VL82C541/VL82C543
    2A5IA:SiS 501/02/03 Chipset
    2A5IC:SiS 5501/02/03 Chipset
    2A5ID:SiS 5511/12/13 Chipset
    2A5IE:SiS 5101－5103 chipset
    2A5IF:SiS 5596 chipset
    2A5IH:SiS 5571 Chipset
    2A5Ⅱ:SiS 5598 Chipset
    2A5IK:SiS 5591 Chipset
    2A5KB:Ali 1449/61/51 Chipset
    2A5KF:ALI 1521/23 Chipset
    2A5KI:ALI IV＋ M1531/M1543 Chipset
    2A5LA:VIA Apollo VP1 Chipset (VT82C580VP)
    2A5LC:VIA Apollo VP2 Chipset
    2A5LD:VIA VPX Chipset
    2A5LE:VIA Apollo (M)VP32A5L7:VIA VT82C570
    2A5L9:VIA VT82C570M
    2A5R5:Forex 601A－613 Chipset
    2A5UI:Opti 82C822/596/597 Chipset
    2A5UL:Opti 82C822/571/572 Chipset
    2A5UM:Opti 82C822/546/547 Chipset
    2A5UN:Opti Viper－M 82C556/557/558 Chipset or Opti Viper 82C556/557/558
    2A5X7:UMC 82C890 Chipset
    2A5X8:UMC UM8886BF/UM8891BF/UM8892BF Chipset
    2A4H2:Contaq 82C596－9 Chipset
    2A4IB:SiS 496/497 Chipset
    2A4KC:Ali 1439/45/31 Chipset
    2A4KD:Ali 1489 Chipset
    2A4L4:VIA 486A/482/505 Chipset
    2A4L6:VIA 496/406/505 Chipset
    2A4UK:OPTI－802G－822
    2A4X5:UMC 8881/8886 Chipset
    2C403:EFAR EC802G－B Chipset
    2C4I8:SiS 471B/E Chipset
    2C4I9:SIS 85C471B/E/G Chipset
    2C4K9:ALI 14296 Chipset
    2C4L2:VIA 82C486A Chipset
    2C4L6:VIA VT496G Chipset
    2C4UK:OPTI － 802G
    2C4X2:UMC UM82C491/82C493 chipset
    2C4X6:UMC UM498F/496F
    2A431:Cyrix 5510 chipset (MediaGx)
    看了以上内容，希望大家在升级自己的主板时都能顺利完成。


完全BIOS手册—如何修改ＢＩＯＳ中的显示信息

如何修改ＢＩＯＳ中的显示信息

本文摘自《电脑报》
原作者及主页为：吴朝相的 EXE 主页

相信如果大家看了《电脑报》第15期《如何修改BIOS里“能源之星”LOGO》后，对修改 BIOS 的升级文件已经有点经验了吧！顺着这个方向，这次我们来看看如何再进一步修改里面的提示信息吧！

    有了上次的经验，相信大家对CBROM这个软件也略知一二了，不知道大家留意到它的那个MIB参数没有，经过我的研究，其实这个MIB就是英文Menu In Bios的缩写。看单词大家应该明白是什么意思了吧，没错，就是在BIOS里面加上一个提示菜单。增加的这个菜单在哪里显示呢？在开机按DEL键进入设置菜单的时候，你会看到多了一个可以按的功能键：F5，只要你一按，新加的菜单就会出现。如图：

    大家看明白了吧？这个功能的主要作用是把你想要记住的简单、重要内容放到FLASH ROM里面去，这样一来，绝对比放在硬盘里面保险，比写在纸上保密（只要你加上CMOS密码，除非你碰到CIH发作）。可以看到，我把我机器的基本配置和主板跳线开关的跳线方法写了进去，这样的好处不用我多说：方便！如果你觉得还不够，也可以把你的存折提款密码也写上去，锻炼一下自己的胆量！反正就看你的发挥了。好了，下面来看看如何做这个菜单吧！

    首先要确定的是你主板的BIOS是不是1998年4月15日以后发表的版本，如果不是，那就免谈了，跳过这篇文章得啦。这个要求达到后，就自己编辑一个文本文件，把要显示的内容打上去，这个文本文件的要求是：第一，必需是纯文本文件，用WIN95的写字板或干脆到DOS下用EDIT都可以，存成TXT文件；第二，当然，现在我们说的BIOS都是指AWARD公司的，而不是其他公司的BIOS，它是不能支持中文的，所以请使用英文。第三，最后就是文件的大小问题，一般来说，它可以支持1000行，每行78个字符的文本文件，当然这个大小是随不同的主板各有不同的，如果这样都还不能满足你的写作欲的话，就请阁下多用英文缩写吧！文件编辑好后，就可以用CBROM把这个文本文件追加到BIOS升级文件里去了，输入cbrom126 wcxbios.bin/mib topage.txt，这里我的BIOS升级文件是WCXBIOS.BIN，编辑好的文本文件是TOPAGE.TXT，这步做完，再用cbrom126 wcxbios.bin/d查看，应该发现你的文本文件已经被成功追加到BIOS文件里了。

    接下来就是用AWDFLASH把修改好的BIOS文件写到FLASH ROM里去了，如果你还不懂如何升级的话，请看上次的那篇改LOGO的文章里面的介绍，如果没这两个工具可以到我的主页http://topage.126.com下载。

    其实除了可以加入菜单外，BIOS里的大部分信息都是可以改的，只要你有MODBIN这个软件。这也是AWARD公司发表的软件，功能就是修改BIOS里大部分你能看到的文字。你可以把那些你认为难记的单词改成自己认为好记及有趣的单词，比如：你可以把USER PASSWORD改成 WCX PASSWORD，把Enabled和Disabled分别改成OK和NO，反正你想如何改都可以自由发挥。进入软件操作界面后，你甚至可以连开机显示“能源之星”标志时候显示的一句提示信息也改掉，按F2还可以进行模拟显示。改好后，也是像改LOGO和加菜单一样，用AWDFLASH写进FLASH ROM就可以了。这个软件目前在INTERNET上能找到的大部分是 4.50.63版本，我用了些时间，找到了它的4.50.75版本，应该是最新的了，也可以到我的主页下载。

    这次就先写到这儿，下次有什么发现，再与大家探讨。顺便告诉大家，上次那篇改LOGO的文章发表后，有很多朋友都表示有兴趣，故在我的主页开辟了一个BIOS专栏，有空去看看。再次提醒，升级BIOS有一定的危险性，如果没信心，千万别乱改。再有就是升级BIOS一定要在纯DOS或“Safe Command Prompt Only”环境下进行。
(吴朝相)


完全BIOS手册—BIOS文字信息全面修改

BIOS文字信息全面修改

本文摘自《电脑报》
原文作者及主页为：北京张雁 [北京张雁网站]

如果你已经修改了自己电脑开机时右上方的EPA能源之星图案（俗称开机LOGO），那么当你看完本文时，你就可以实现对开机时BIOS显示的所有文字信息的修改了，比如开机系统提示 ZhangYanBIOS v9.9 Found DVDROM: xxx ZIP250 Pentium III 550 等（ 快看 图1 图2 ），怎么样！让你体验到前所未有的个性化电脑。

本文是针对实用Award BIOS的主板进行修改的，并且要求你对BIOS以及Flash BIOS和十六进制编辑器有所了解，这方面的知识和关于修改EPA图案的方法可以参考前几期的《电脑报》。下面我们就开始修改开机信息的行动。

开机画面1 5K
图 1

开机画面 3K
图 2

BIOS菜单画面 10K
图 3

行动一：准备相应的修改程序

程序1：MODBIN.EXE（60K） Award公司发布用于修改BIOS二进制文件（就是存放BIOS 的文件），它只能直接修改BIOS开机显示的极少信息（好象就一句话），但也就是它暴露了BIOS的全部信息，别着急往下看。
程序2：AWDFLASH.EXE（15K） 还是Award公司发布用于备份和复原BIOS的程序。
程序3：一个十六进制的编辑器，比如PcTools5.0，但我向大家推荐能直接运行在Win98下的SoftscapeTools 2.0（82K）。
程序4：一个多任务的操作系统，比如Win95 或 Win98（200MB）（太普及了！）。

行动二：修改信息

到DIY的时候了，一步一步来。
第一步：进入Win95/98 ，在MS-DOS方式下运行AWDFLASH.EXE 将你的主板的BIOS备份成 TEMPBIOS.BIN（文件名任意，扩展名是BIN），然后退出AWDFLASH。
第二步：运行MODBIN.EXE 在 Load File 中选择刚刚生成的 TEMPBIOS.BIN并确认，确认完后切换到Win95/98 （注意：别关闭MODBIN.EXE的MS-DOS窗口），此时你会发现在MODBIN.EXE的目录（文件夹）中，多出了一个ORIGINAL.TMP 文件，哈哈！这个文件就算是BIOS的全部了。
第三步：在不关闭MODBIN.EXE的MS-DOS窗口的情况下，开启一个新的MS-DOS窗口运行十六进制的编辑器，用十六进制的编辑器编辑ORIGINAL.TMP 文件，你将会看到并能修改BIOS开机所显示的一切文字信息和BIOS有关的一切文字信息，比如开机时按del键进入的BIOS设置菜单的文字（见图3）等等等，剩下的就看你怎么高兴怎么改了。
第四步：修改完信息后退出十六进制的编辑器，切换到原先的MODBIN.EXE的MS-DOS窗口在Update File 中确认TEMPBIOS.BIN被修改，并退出。
第五步：退出Win95/98返回到MS-DOS 7.0的状态，运行AWDFLASH.EXE将刚修改完的TEMPBIOS.BIN 复原到主板的BIOS中，OK！修改BIOS文字信息行动完成

还没完，我有话说！

修改BIOS文字信息行动是完了，但我的话还没完。大家都知道的用来保存和升级BIOS的.BIN文件，它实际上是由多个文件组成并经过压缩处理的文件，这些文件有BIOS程序主文件，EPA图象文件，Logo BitMap文件等等。你可以用CBROM.EXE 程序查看.BIN文件中的文件组成信息。而我们所修改的就是其中的BIOS程序主文件ORIGINAL.TMP，所以要想修改BIOS中的文字信息就要将ORIGINAL.TMP从BIOS的.BIN文件中释放出来。其实CBROM.EXE已经可以从BIOS的.BIN文件中释放和装入一部分文件，但并没有提供释放BIOS程序主文件ORIGINAL.TMP的功能，我想可能是由于Award公司认为这个主文件最好不应该交给由用户修改吧。所以推出了MODBIN.EXE程序来对BIOS程序主文件ORIGINAL.TMP进行小量的修改。但偏偏.......

我对主板BIOS的认识并不深，我想它还会有其它有趣的应用吧。文中所提到的程序可以到我的网站 http://member.netease.com/~yanking 和 http://zhangyanweb.yeah.net 中下载或 http://topage.126.com 。当然也欢迎与我交流 yanking@netease.com 。最后希望你的行动顺利完成。


什么是BIOS设置
本文摘自《电脑报》

  我们所使用的计算机都是由一些硬件设备组成的，而这些硬件设备会由于用户的不同需要而在品牌、类型、性能上有很大差异。例如，对于硬盘，就可能存在容量大小和接口类型等方面的不同，而不同的硬件配置所对应的参数也不同，因此，我们在使用计算机之前，一定要确定它的硬件配置和参数，并将它们记录下来，存入计算机，以便计算机启动时能够读取这些设置，保证系统正常运行。
    通常情况下，我们通过设置程序对硬件系统设置参数。由于ROM(只读存储器)具有只能读取、不能修改且掉电后仍能保证数据不会丢失的特点，因此这些设置程序一般都放在ROM中，我们常常称其为BIOS设置。此外，运行设置程序后的设置参数都放在主板的CMOS RAM芯片中，这是由于随着系统部件的更新，所设置的参数可能需要修改，而RAM的特点是可读取、可写入，加上CMOS有电池供电，因此能长久地保持参数不会丢失，但电池如果使用时间较长，电力不足，也可能会产生掉电现象，系统设置参数会丢失，这时只需要更换一只新电池并重新进行设置就可以了，从上面我们也可以看出，BIOS设置和CMOS设置是不完全相同的，二者不能混淆。
    一、BIOS设置程序的基本功能
    BIOS的设置程序目前有各种流行的版本，由于每种设置都是针对某一类或几类硬件系统，因此会有一些不同，但对于主要的设置选项来说，大都相同，一般分为下面几项：
    ＊基本参数设置
    包括系统时钟、显示器类型、启动时对自检错误处理的方式。
    ＊磁盘驱动器设置
    包括自动检测IDE接口、启动顺序、软盘硬盘的型号等。
    ＊键盘设置
    包括上电是否检测硬盘、键盘类型、键盘参数等。
    ＊存储器设置
    包括存储器容量、读写时序、奇偶校验、ECC校验、1M以上内存测试及音响等。
    ＊Cache设置
    包括内/外Cache、Cache地址／尺寸、BIOS显示卡Cache设置等。
    ＊ROM SHADOW设置
    包括ROM BIOS SHADOW、VIDEO SHADOW、各种适配卡SHADOW
    ＊安全设置
    包括硬盘分区表保护、开机口令、Setup口令等。
    ＊总线周期参数设置
    包括AT总线时钟(ATBUS Clock)、AT周期等待状态(AT Cycle Wait State)、内存读写定时、Cache读写等待、Cache读写定时、DRAM刷新周期、刷新方式等。
    ＊电源管理设置
    是关于系统的绿色环保节能设置，包括进入节能状态的等待延时时间、唤醒功能、IDE设备断电方式、显示器断电方式等。
    ＊PCI局部总线参数设置
    关于即插即用的功能设置，PCI插槽IRQ中断请求号、PCI IDE接口IRQ中断请求号、CPU向PCI写入缓冲、总线字节合并、PCI IDE触发方式、PCI突发写入、CPU与PCI时钟比等。
    ＊板上集成接口设置
    包括板上FDC软驱接口、串并口、IDE接口的允许／禁止状态、串并口、I／O地址、IRQ及DMA设置、USB接口、IrDA接口等。
    ＊其它参数设置
    包括快速上电自检、A20地址线选择、上电自检故障提示、系统引导速度等。
    二、BIOS设置程序的进入方法
    进入BIOS设置程序通常有三种方法
    1.开机启动时按热键
    在开机时按下特定的热键可以进入BIOS设置程序，不同类型的机器进入BIOS设置程序的按键不同，有的在屏幕上给出提示，有的不给出提示，几种常见的BIOS设置程序的进入方式如下：
    Award BIOS：按Ctrl＋Alt＋Esc，
    屏幕有提示；
    AMI BIOS:按Del或Esc，屏幕有提示；
    COMPAQ BIOS:屏幕右上角出现光标
    时按F10，屏幕无提示；
    AST BIOS：按Ctrl＋Alt＋Esc，屏幕无
    提示。
    2.用系统提供的软件
    现在很多主板都提供了在DOS下进入BIOS设置程序而进行设置的程序，在Windows 95的控制面板和注册表中已经包含了部分BIOS设置项。
    3.用一些可读写CMOS的应用软件
    部分应用程序，如QAPLUS提供了对CMOS的读、写、修改功能，通过它们可以对一些基本系统配置进行修改。


完全BIOS手册—如何使用CBLOGO

如何使用CBLOGO

摘自联想QDI主页

准备一个256色Bitmap文件，640X480分辩率或少一些，同时要确信你的‘ *.bmp '文件不是很大，把这个文件复制到你的硬盘中。

  1. 把 ‘ cblogo.exe ' 文 件 也 复 制 到 你 的 硬 盘 中 。
  2. 准 备 一 张 DOS6.2x 的 启 动 盘 ( 或 Win95/98 dos 启 动 盘 ) 不 包 括 Auto EXEC.BAT 和 Config.sys 文 件。
  3. 把 启 动 盘 放 入 软 驱 中 ， 然 后 启 动 你 的 系 统
  4. 切 换 到 你 的 硬 盘 上, 然 后 按 下 面 程 序 安 装:
    CBLOGO *.bmp (bitmap 文 件 ) /l <enter>
  5. 然 后 屏 幕 上 会 显 示 下 面 的 信 息:
    "Message: Please power off or reset system" 。
  6. 最 后 重 新 启 动 系 统 。


CMOS与BIOS一样吗？

CMOS是互补金属氧化物半导体的缩写。其本意是指制造大规模集成电路芯片用的一种技术或用这种技术制造出来的芯片。在这里通常是指微机主板上的一块可读写的RAM芯片。它存储了微机系统的实时钟信息和硬件配置信息等，共计128个字节。系统在加电引导机器时，要读取CMOS信息，用来初始化机器各个部件的状态。它靠系统电源和后备电池来供电，系统掉电后其信息不会丢失。 BIOS是基本输入输出系统的缩写，指集成在主板上的一个ROM芯片，其中保存了微机系统最重要的基本输入输出程序、系统开机自检程序等。它负责开机时，对系统各项硬件进行初始化设置和测试，以保证系统能够正常工作。 由于CMOS与BIOS都跟微机系统设置密切相关，所以才有CMOS设置和BIOS设置的说法。CMOS RAM是系统参数存放的地方，而BIOS中系统设置程序是完成参数设置的手段。因此，准确的说法应是通过BIOS设置程序对CMOS参数进行设置。而我们平常所说的CMOS设置和BIOS设置是其简化说法，也就在一定程度上造成了两个概念的混淆。


完全BIOS手册—修复被破坏的 BIOS

修复被破坏的 BIOS
本文摘自《电脑报》

读了2月8日第6期23版《主板复苏记》一文，立刻勾起了我的一段回忆，特此提笔，希望能与各位读者交流一下。

1998年12月25日晚上（我的计算机时钟绝对准确），在进行完日常的一系列操作后，又准备对系统进行一下“挖潜”工作，我相信这是大多数PC 发烧友的共同爱好。主板的BIOS已经被升级过好几次了，而且目前我还没找到更新的BIOS升级数据文件，所以我把目光转向了主板附带光盘上的DMI（Desktop Management Interface，桌面管理接口）程序。DMI为用户提供了一个与系统硬件直接对话的机会，它里面提供的许多功能是CMOS设置不具备的，如调整主板上的二级缓存大小和CPU Internal Cache大小等等，几乎每一项设置都对我有着极大的诱惑力。第一次使用DMI时，为了安全起见，用软盘启动，并且跳过了Autoexec.bat和Config.sys文件，成功地修改了包括CPU Internal Cache在内的很多内容。有了第一次的成功经验，决定将步子迈得大些，再尝试一下修改DMI提供的设置。

这一次我在Windows的MS－DOS方式下直接启动DMI程序，我想它无非是按照一定格式修改一些与系统各硬件相关的信息，不会完全重写BIOS，危险性要比升级Flash BIOS低得多，更何况Windows 98也不会对危及系统的操作置之不理，所以没有过多的担心。在浏览完DMI提供的“内部信息”后，修改了其中几项，然后按下F10键更新系统信息，屏幕上的内容在停顿了几秒钟后，弹出了不可更改信息的提示，然后，所有项的内容变得完全一样了。我想反正也没改写成功，估计问题不大，只要正常退出就没事了，于是按Esc键退出程序。回到Windows 98，看到系统有一个关于程序错误的提示，这种提示不知每天要遇上多少次，所以漫不经心地将它关闭了。当然不会就此罢休，于是再次进入MS－DOS方式下，键入“DMICFG”，回车后，黑屏，键盘没有任何响应，更惨的是按下Reset键后，喇叭里传来一长两短和两声乐音的报警，屏幕上再也看不到那些熟悉的版本信息了，同时软驱灯在亮着。一个可怕的念头快速闪过脑海，但是又被我迅速地否定掉了，谁愿意发生那件事呢？接下来就是一连串无谓的“检查”：不断地按下Reset键；时不时关断电源；打开机箱拔插一下各连线；给CMOS放电；甚至取下CPU。除了拔下硬盘或软驱后，报警声改为连续短音外，其他没有什么变化，最后证明BIOS已被破坏！

通常解决BIOS被破坏的办法是找一块好的BIOS芯片替换一下，然后进行一连串复杂的操作才能修复。正好是周末，去哪里寻找相同的BIOS芯片呢？抱着一丝希望，我把自己所有有关电脑的书籍、报刊、杂志拿出来，开始寻找解决办法。很快，我找到了理论依据：Flash BIOS是以区块（Block）来作为消除和写入单位的，其中有一部分是Boot Block，一般情况下，这一部分区块是不会被破坏的，因为它需要加载＋12V的电压（BIOS的其它部分只需加载＋5V的电压），当Flash BIOS的其它区域被破坏时，Boot Block中的程序可利用磁盘重建整个Flash ROM，但是，它只支持ISA显卡。看来真有希望了!

第二天，我找来一块ISA显卡装上，接好各连线，接通电源。报警声消失了，显卡的版本信息出现在漆黑已久的屏幕上，Award Boot Block启动信息出现了，最后系统顺利地启动了。接着屏幕上出现了一大堆英文提示，说找不到硬盘，并且提示了几种可能性。我以为是这个Boot Block不支持FAT32，也就没多加理会，毕竟这与看到计算机重新启动相比，实在是太微不足道了。虽然键盘还没完全正常，比如键盘上的各指示灯全不亮，有时候大小写也出现问题，但这并不影响接下去的工作。由于升级Flash BIOS所需的文件全部在硬盘上，此时无法使用硬盘，所以忙给朋友打电话，请他帮我从大众公司的主页上下载所需的文件。取得胜利的时刻到了：拿到带有升级文件的启动盘，放入软驱，顺利启动，从软盘上运行Flash BIOS升级程序……终于成功地将被破坏的BIOS恢复了。但是硬盘仍然无法找到，回想起自己曾经在慌乱中到机箱中乱拔过一气，很可能是把硬盘数据线弄松了。于是重新将数据线插牢，一切就又都恢复正常了。(北京　唐明)


完全BIOS手册—万一BIOS升级出了问题

万一BIOS升级出了问题

本文摘自 《新潮电子》

一般来说，升级BIOS的刻录过程并不危险，只要小心，不会发生大的问题。但是万一运气太差，刻录中途断电也是有可能发生的，这时BIOS 就肯定刻坏了。

遇到这样的情况，你可以与主板制造商联系，购买一块新BIOS芯片。你也可以用下面介绍的方法尝试一下，自己修复BIOS芯片。

借鸡下蛋——用完好的BIOS 芯片启动计算机
    可以利用一片与你的BIOS完全相同的、可以工作的BIOS启动计算机系统，然后换上刻坏的BIOS进行操作，将正确BIOS码写入BIOS芯片中。
    打开机箱后，拆下主板，首先我们要找到BIOS 芯片，一般来说，BIOS ROM是主板上唯一一片贴有标签的芯片，是双列直插式封装，Flash BIOS芯片的编号是29xxxx系列或28xxxx系列，如果是27xxxx系列就是普通芯片。拔起刻坏的芯片，如果你有芯片拔起器，这一步非常轻松，如果没有也没关系，用一字起子，你只要记着要轻、要慢、左右两边用力均衡就可以了。然后将可工作芯片对准插座轻轻压入。开机进入BIOS系统参数设置程序，BIOS Features Setup 一项中，开启所有ROM映射功能。最关键是要求System BIOS Cacheable 一项为Enable，即映射当前System BIOS到RAM当中去。重新用软盘启动计算机进入DOS状态，运行与你主板相应的BIOS刻录程序，并在程序中要求备份当前的BIOS程序，不要关闭计算机。
    按前面的拔起方法将刻坏的BIOS芯片替换下正常的BIOS芯片，内存驻留的System BIOS程序将支持硬件的正常运行，计算机系统不会产生任何混乱。此时继续运行刻录程序，用储存下来的BIOS程序更新BIOS。稍待片刻，BIOS源代码将写入芯片,如果提示出的更新字节数与你的ROM块容量相等，这块几乎报废的BIOS ROM就起死回生了，我们只要关机重新启动即可。
    以上所介绍的方法，经多次尝试，可行度极高。但北方的朋友要注意，在干燥的季节里，热插拔过程中产生的瞬间放电有可能对主板和芯片造成损害，在插拔前设置接地导线是非常必要的防护措施。

借尸还魂——用Boot Block引导块恢复BIOS芯片
BIOS被完全破坏了吗？不，这不一定是事实。
在BIOS中，有一个引导块（Boot Block），当进行BIOS升级时，这一区块一般是无法覆盖的，有些主板在升级程序写入之前会提示你是否覆盖引导区（Update BIOS Including Boot Block and ESCD），为保险起见，这时最好选“N”。这样，在写入失败后，BIOS中仍然有能力启动系统。不过，BIOS Boot Block只支持软驱和ISA显卡，如果你的计算机安装的是PCI显卡的话，启动电脑后就是黑屏，但软驱仍能运作。
升级失败后，我们首先在别的机子上制作一张启动盘，并将写入程序及正确的BIOS升级数据拷贝在启动盘上。然后用这张软盘启动计算机，执行写入程序即可恢复BIOS中的内容。如果计算机安装的是PCI显卡，就必须按照重写BIOS的步骤“摸黑”操作了,只要保证键入内容无误，电脑仍能正常恢复。


完全BIOS手册—升 级 主 板 BIOS 小 记

升 级 主 板 BIOS 小 记
本文摘自《电脑报》

升级主板的BIOS，是很多DIY迷很想做的事，但却无从下手。看了我的遭遇后，不知你有什么感觉？
    一直就想升级我的TX－97E主板的BIOS，在看了同学升级他的TX－97XE主板的BIOS后，没想到这么简单，遂决定一试。
    我的TX－97E主板的BIOS原为0107e版本，在网上找到TX5n0110.awd文件，是TX－97－n主板的升级文件，看样子版本提高不少，嘿嘿！于是开始操作，一切按部就班，改跳线、以实模式启动、运行Flash先保存当前BIOS，然后开始刷新。屏幕显示“Successfully”，一切OK，按照屏幕的提示关机。
    满怀希望按下电源，黑屏。等待，还是黑屏。再关机，再启动，依旧黑屏 。心猛地往下一沉 ，估计是TX5n0110.awd文件的问题，怪不得我保存下来的BIOS文件大小只有131072个字节，而TX5n0110.awd 的大小为262144个字节。胆子太大了，现在悔之晚矣，该怎么办呢？百般无奈之际，我想拔下BIOS芯片看看，没想到BIOS芯片插得很紧，很不好撬，我一用力，“啪”的一声，BIOS芯片被撬了下来，慌忙拿起仔细瞧,My God!真是祸不单行, BIOS芯片的一个引脚被撬断了，我欲哭无泪。
    不能坐以待毙，冷静下来以后我决定再赌一次，试试久闻大名的“热拔插法”。闲话少说，以最快的速度借来了TX－97E主板的BIOS芯片、电烙铁（准备焊接断脚）等。当然，这要冒点风险，万一把别人的BIOS芯片再搞坏，那可真是……动手前我深吸一口气，告诫自己别慌，要胆大心细，注意防止静电的破坏。由于实在害怕电烙铁的感应电荷击坏BIOS芯片，并且焊接纤细的引脚难度较大，于是决定直接用断了一脚的BIOS芯片试试再说。
    小心翼翼地将好的BIOS芯片插上主板，插入即可，此时不用太紧。开机引导，一切正常，进入DOS系统后，轻轻拔下好的BIOS芯片，换上断脚的BIOS芯片，将它插紧。运行Flash，屏幕提示找不到BIOS芯片，看来缺一脚不行。仔细观察发现BIOS芯片断脚处仍有一点点引脚伸出，只是太短，无法与插槽内的小簧片接触，这太好办了，我将一个废弃不用的8255芯片（任何DIP引脚的芯片均可）的一个引脚连根剪下，略略弯一个角度使其与BIOS芯片的断脚能紧密接触，用镊子夹住它仔细地插入断脚对应的那一个插槽内，让它与插槽内的小簧片和断脚都能接触到（小心别碰到其他管脚，以免引起短路），插好后再运行Flash，哇！找到BIOS芯片了，用原先备份的BIOS文件重新刷新，屏幕显示“Successfully”后，退出Flash程序，关机。边祈祷边按下电源开关，“嘀”，随着一声熟悉的鸣叫，久违的开机引导画面十分亲切的展现在我眼前，“成功啦！”我的心中一阵狂喜，高呼万岁！
    从这件事可以看出，升级主板的BIOS务必要谨慎，升级前先把自己的主板的BIOS保存为文件，与欲升级的BIOS文件比较一下，若不一样，就要小心了。就是出了故障也别急躁，以免忙中出错，造成更大的损失。处理故障时更要灵活对待，胆大心细。
    (请作者与编辑部联系)


升级BIOS有惊无险
本文摘自《电脑报》

    前日攒机一台：PⅡ 266 CPU（编号为SL2W7，被超频到400MHz）、梅捷6BA＋主板、PC100 64M SDRAM内存、PHILIPS 105A显示器、NEC 32速光驱、迈拓3.2G硬盘、ASUS V3000显卡。抱回家鏖战数日后，因为性能超卓，毫无故障，便不安分起来。先从华硕公司的主页上下载了显卡的2.05版驱动程序，解决了2.00版驱动程序不能实现抗锯齿功能的问题。接着就对主板的BIOS打起了主意，这块主板好像是梅捷缺货前的产品，BIOS比较“旧”，显示日期是“08/05/98”，批号为BA＋ _2AA2，便暗自想道：“如今已是12月了，我乃发烧玩家，BIOS如此落后，岂不被人耻笑。”事不宜迟，立即前往梅捷主页，发现最新的BIOS显示日期为“10/23/98”，文件名为6BAP2BA5.BIN，并且修正了XXXXXX问题（此处省去一大堆英文），下载！又发现更新BIOS的程序AWDFLASH.EXE，下载！又发现梅捷供专家定制开机外观（此处英文只是匆匆看过，没有深刻领会精神，结果造成后面工作的失误）的程序DMICFG.EXE，下载！

    接着着手更新BIOS，当系统询问是否保存现有BIOS时，BACK.BIN并保存到A盘。然后重启动，微机的运行立即不一样，其变化之处难以尽述。

    到了这一步，情况还是比较顺利的，可我没有就此“打住”，紧接着就开始“定制开机外观”，执行DMICFG.EXE，进入一个菜单，项目繁多，未曾细看，大胆创新，将改写过的信息写入BIOS中，其间程序“苦苦相劝”，可我仍义无反顾地连按“Y”键，启动……

    喇叭发出“三长两短”的叫声后，整个机器便死寂了，屏幕毫无显示。一瞬间，我清楚地知道BIOS完蛋了，心情悲痛之极——我的机器才买了7天啊！拔声卡、拔硬盘、拔光驱、按紧显卡、清零CMOS，能想到的招数都用光了，可情况依旧，至此，似乎只有热插拔BIOS芯片了，可那是大手术，再说，现在梅捷主板缺货这么严重，即使是经销商手里也没有6BA＋主板了。在电脑前坐了半夜，追悔莫及。

    突然，在再一次启动时，发现软驱好像在读盘，和每次用软盘引导时的情形很像，可屏幕仍是黑的。试着敲入DIR，又发生读盘现象，难道……抱着试试看的念头敲入AWDFLASH，回车，软驱又读盘，显然在执行程序。接下来应该是输入待写入的BIOS文件名了，可怎么也想不起来6BAP2BA5.BIN这一长文件名。又呆坐半个小时，忽然想到我备份过旧的BIOS，且文件名为BACK.BIN，大喜，立即敲入AWDFLASH BACK.BIN，回车，我回忆着AWDFLASH程序执行的步骤和时间，一会按“N”一会按“Y” 。估计已将BIOS写完了，重启动，心情错综复杂。

    不可思议，机器“沉默寡言”地启动了，我的眼泪差点掉了下来。估计原因是这样的，当DMICFG.EXE向BIOS中写入信息时,由于我设置得不正确,致使混乱、错误的信息被写入，如同升级BIOS失败一样，但梅捷主板似乎提供一个供大家“默写”的机会，可以靠回忆AWDFLASH程序的执行过程进行操作，从而使BIOS得以恢复。

    在此把这次历险公之于众，希望可被众“贪婪”玩家借鉴，以避免悲剧再度发生。


完全BIOS手册—升 级 BIOS 失 败 后 的 处 理

升 级 BIOS 失 败 后 的 处 理

本文摘自《电脑报》

BIOS芯片是主板初始信息的存放处，如今电脑上一般用的都是电可擦写式的BIOS芯片，也就是说，BIOS芯片中的内容是可以更新的。本文主要讲一下升级BIOS失败后的几种处理方法。升级BIOS一旦失败，就会使计算机无法启动，这时，很多人往往到经销商那里更换BIOS芯片。其实大可不必这么做，这里还有别的一些方法供你参考！

方法一：利用BIOS Boot Block引导块

    现在用Award BIOS的主板都有一个BIOS引导块，当你升级BIOS时，这一小部分引导块可以不被覆盖(Boot Block Write 跳线设置为“Disable”，并且在运行Flash程序时，不选择“Update BIOS Including Boot Block”方式)。这个BIOS引导块只支持软驱和ISA显示卡，所以很多人在升级BIOS失败后，当主板上仍插PCI显卡时，启动电脑会黑屏，但电脑却能读软驱，这就意味着主板的BIOS仍可以恢复。这个BIOS引导块可以引导正常的DOS启动盘并执行Autoexec.bat，只要把Flash程序和正确的BIOS文件拷贝到DOS启动盘上，然后在Autoexec.bat中添加上执行升级Flash BIOS的语句，如Awdflash Biosxxx.bin。可以在一台正常的电脑上做好这张盘，拿到需要恢复的电脑上运行；或找块ISA显卡插到电脑上，启动后执行软盘上的升级程序。如果没有ISA显卡，也可以在启动后黑屏的情况下，自己动手运行升级程序。这时电脑仍可以正常运行，只是屏幕没有显示，只要升级时键入的内容完全正确，一样可以成功。

方法二：利用Flash Recover Boot Block引导块

    对于另一些主板(例如某些使用Phoenix BIOS的主板)，主板上的BIOS中有一个Flash Recover Boot Block引导块,这个引导块不会被升级程序覆盖。主板上有一个Flash Recover Jumper跳线，BIOS升级失败或被CIH病毒破坏后可以恢复，方法如下：
    1.把Flash Recover Jumper跳线设置为“Enable”。
    2.把可引导的升级盘插入A驱动器（盘中的BIOS一定要是能正常工作的，文件名要符合主板的要求，因为主板要把软盘中的BIOS备份自动写回Flash BIOS）。
    3.重新启动电脑。
    4.因为这一小段代码是放在不可写入的引导块区域的，所以不支持显卡，升级过程只能靠声音和软驱指示灯的提示来判断是否完成。如电脑喇叭发声且软驱灯亮着时，表明系统正在恢复BIOS到Flash BIOS，当电脑喇叭不发声且软驱灯也不亮时，表明恢复完成。
    5.关掉电源。
    6.把Flash Recover Jumper跳线跳回默认位置。
    7.取出软盘，开启电源。

方法三：换一个新的BIOS芯片

    与你的主板制造商联系，设法得到一块BIOS芯片。也可以买一块与主板的BIOS 芯片兼容的ROM芯片，如27Cxxx、28Cxxx系列EPROM，用专门的可写EPROM的仪器将正常的BIOS写入，换下升级失败了的BIOS芯片。用这种方法还可以升级那些BIOS不是Flash BIOS的主板、显卡甚至MODEM的BIOS。这种EPROM一般也不贵,十块钱左右就可以买到(这种方法的限制是得找到紫外线EPROM的擦写器）。

方法四：热拔插法

    1.还有些主板的BIOS芯片中可能没有集成最初始的信息，或你无法找到ISA显卡，这时你可以找到与你的主板相同的好主板。先把好主板的BIOS芯片拔下，当然，你自己的BIOS芯片也要拔下，然后把好的BIOS芯片插入你自己的主板，启动计算机到DOS系统下，注意，进入DOS时不要外挂别的程序。当然，现在许多朋友的电脑都在用WIN95和WIN98，这时候你可以在计算机刚启动时按F8键，然后选择“Command Only模式”进入，最好直接用DOS引导盘启动，然后拔下那块好的BIOS芯片，再将你自己的BIOS芯片插入你的主板中，执行写入程序就行了！当然，你也可以把你的BIOS芯片拿到别人的电脑上写！
     2.当你找不到相同的主板时，还有一种方法可救你主板的BIOS，本人就是通过这种方法来使主板的BIOS起死回生的。本人的主板是海洋R12主板，从网上下载BIOS升级程序为主板BIOS升级，由于电压问题导致升级失败，造成机器无法启动。现在ISA显卡不好找，即使找到了也不知好不好用，后来从《电脑报》上看到一篇用不同主板来重写BIOS的文章，文中只说明了可以在两块不同的奔腾主板之间重写BIOS，没有说明是否可以在奔腾主板和奔腾二代主板之间重写BIOS。因本人的电脑买得早，朋友的电脑都是新买的，全是清一色奔腾二代电脑，所以找不到跟本人差不多的电脑，于是抱着试试看的心理拔下我的BIOS芯片来到同学家。先启动同学的电脑进入DOS系统，然后拔下他的BIOS芯片，插上我的BIOS芯片，试着用自带的写入程序写入BIOS。但电脑提示错误，于是换上他的BIOS写入程序来写入我的BIOS数据（一般来说，BIOS写入程序包括两部分：一部分是写入程序，也就是可运行的程序，另一个是以bin为扩展名的数据程序），写入成功，然后关机拔下本人的BIOS芯片。回到家里一试，又听到了电脑启动时美妙的声音！启动成功！
    注意：使用方法四时，在启动好的电脑以前，先把它的BIOS芯片拔下，然后再稍用力把好的BIOS芯片插回，不要插得太紧，等电脑启动后稍用力就可以把好的BIOS芯片拔下，然后换上自己的BIOS芯片，这样就不容易损坏好的BIOS芯片。还有一点要注意的是，在方法四的第2种方式中，因两块主板不同，所以写入电压有可能不同，这点一定要注意，不然可能造成无可挽回的损失。
    有关BIOS更详细的内容，可以到 http://www.award.com.tw/download 去看看，那里有各种BIOS和各种主板BIOS芯片的Flash程序和上百种的Flash BIOS程序


完全BIOS手册—用插拔法修复BIOS

用插拔法修复BIOS

用“插拔法”修复损坏的BIOS，观点是正确。此方法看似简单，但实际操作中有几个问题需要注意，现将本人在使用插拔法来修复损坏BIOS芯片过程中的一点体会介绍给大家。

准备15瓦以上的小型尖头电烙铁一把，一条足够长的导线，各种型号的螺丝刀一套， 还有与损坏的BIOS具有相同型号的新的BIOS芯片。

1.用手触摸一下已接地的金属导体，释放掉身体的静电（如果戴防静电手套则更好）。

2.打开机箱，拆下计算机主板上的各种板卡和连线，拔下CPU和内存条，卸下主板上的螺丝钉，从机箱中取出主板，找到主板上的BIOS芯片。BIOS芯片一般是40或32引脚的双列直插式EPROM块，芯片的最左下角的引脚是它的安装点，最右下角的引脚是它的接地引脚GND。把主板翻一个面，确定好BIOS芯片的位置和GND引脚。用已经通电达到足以熔化焊锡温度的电烙铁，快速地将接地导线的一头焊在BIOS芯片的GND引脚上。

关键点：

①焊接时动作要快，位置要准确，焊点不要太大，以免短路。而且操作时的电烙铁应在断电状态下，否则容易击穿主板上的其它芯片。

②保证接地导线的另一端不接地。

3.用一字螺丝刀从芯片槽中将BIOS芯片慢慢地撬起来，操作时动作要慢，用力要均匀，否则容易造成BIOS芯片断脚。也可以使用芯片起拔器来起拔芯片。

4.把事先准备好的一个同型号的BIOS芯片，按照缺角对点的原则，正确地将BIOS芯片插到主板上。随后连接好CPU、内存和主板上的各种板卡以及连线。重新启动机器，取消CONFIG.SYS和AUTOEXEC.BAT的所有设备驱动程序和内存驻留程序。进入BIOS设置，并将其中的“SYSTEM BIOS映射到RAM中”一项设置为“ENABLE”。再重新启动机器，运行BIOS升级程序，选择将当前系统中的BIOS备份到软盘上，将正确的BIOS程序代码备份到软盘上。

关键点：必须将“SYSTEM BIOS映射到RAM”选项设置成“ENABLE”，否则以下的操作毫无意义。

5.将上面焊接在主板上的导线的另一端接到一个金属导体上，如暖气管，并确定导线连接正确。将插槽内的BIOS芯片，用一字螺丝刀缓慢地撬起来，把原来坏的BIOS芯片再插上去。继续运行BIOS升级程序，选择要求更新BIOS功能，而且用于更新的BIOS程序代码是刚从好的BIOS芯片上备份下来的数据。

同时我们还要注意快速切断连接BIOS芯片的GND引脚与大地之间的导线，因为BIOS升级程序要对BIOS芯片进行全面检测，如果BIOS芯片有问题，BIOS升级程序是不能够正常工作的。经过几分钟的读写操作，如果升级程序提示操作完成，即可关机。最后，把焊在主板BIOS芯片上的GND引脚的导线焊下来，将主板装入到机箱中，修复工作就此结束。

关键点：

①在升级程序启动时，应把BIOS芯片的GND引脚与大地之间的导线快速切断。

②焊接操作时应防止静电对主板的破坏。

本方法的主要理论依据是两个方面:一个是利用“SYSTEM BIOS映射RAM”的功能，因为机器如果没有BIOS支持是不能启动的，当把正常运行机器主板上BIOS芯片拔出来，这时机器虽然没有了BIOS的支持，但是BIOS的程序代码全部映射到RAM中，这时操作系统可以直接从RAM中读取BIOS程序来支持机器的运行；二个是接地功能，因为在机器运行中，主板上任何部件都不能带电插拔，否则会由于瞬间高压产生的强大电流将芯片击穿，造成芯片报废。由于我们把BIOS芯片的GND引脚与大地相连，这时如果对BIOS芯片进行带电操作，所有可能产生的强大电流会导入到大地中，因而不必担心BIOS芯片被击穿。

本方法只适合修复在BIOS升级过程中因某种原因造成BIOS升级代码损坏的BIOS芯片。如果BIOS芯片是物理性损坏，请慎用此方法。

本方法已通过本人多次试验，每次均成功，操作时只要注意了以上的几个关键点，成功是有保证的。


完全BIOS手册—修复BIOS有新法

修复BIOS有新法

张雁

升级BIOS是提高系统性能的最有效方法，其好处多多不用再说，特别是近来横刮修改BIOS LOGO之风，使得越来越多的朋友热衷于修改BIOS。然而由于种种原因，在操作过程中难免会造成失败，而不得不采用种种高难度的方法修复。笔者近日寻得一修复BIOS的良方，没敢自己亲自享有，特献出来给大家（精神可佳！），希望会对你有所帮助。

    大家知道，在一般情况下FLASH ROM中的BOOT BLOCK模块不会被破坏，其症状表现为：黑屏, 但喇叭里还能听到一些嘀嘀声,而且软驱也是好的。当FLASH ROM的其它区域被破坏时，BOOT BLOCK可利用磁盘重建FLASH ROM，然而它只支持ISA显卡，所以出现这种情况后，解决方法就是我们经常提到的用ISA显卡替换PCI显卡，屏幕有显示后再恢复原来的BIOS。虽然这些看上去有希望，但现在找一块ISA显卡比找同型号的BIOS还难，修复BIOS又谈何容易。可仔细想一想，找一块ISA显卡不就是为了看到显示而进行恢复工作吗，也就是说在这种情况下除了显示部件不正常外，其他大部分部件还可以正常运行，包括唯一的希望 软驱。而我们何不利用软驱中的AUTOEXEC.BAT自动完成BIOS恢复工作呢？好，下面就来看看具体步骤：

1.做一张系统盘，删去里面的CONFIG.SYS和AUTOEXEC.BAT。
2.把公用BIOS更新程序AWDFLASH和BIOS数据文件拷到系统盘。
3.在系统盘中建立AUTOEXEC.BAT,并加入：AWDFLASH XXX.BIN /SN /PY（XXX.BIN是你的BIOS数据文件）。其中的/SN /PY参数表示不备份而仅仅更新BIOS。

当BIOS出现问题时，插入此盘后重新启动，系统会“自动”地更新BIOS，等数分钟后再重新启动，如果没问题的话，系统已恢复正常了。

以上方法是否有效笔者还没来得及亲自尝试，但从其思路来看的确是个好方法。另外，如果BIOS全部被破坏，则不适用于此种方法。

    AWDFLAHS可到 http://zyweb.myrice.com 下载。


完全BIOS手册—华硕主板 BIOS 的升级与管理

华硕主板 BIOS 的升级与管理

摘自ASUS主页

首先备份 BIOS

  1. 请 将 一 片 乾 净, 未 格 式 化 的 磁 片 放 入 A 磁 盘 中，然 後 在 DOS 提 示 符 号 下 键入 FORMAT A: /S，制 作 一 片 没 有 AUTOEXEC.BAT 与 CONFIG.SYS 的 开 机 片。
  2. 拷 贝 AFLASH.EXE 到 开 机 片 中。
  3. 执 行 开 机 片 中 的 AFLASH.EXE, 选 择 选 第 1 项 Save Current BIOS to File，将 目前 BIOS 中 所 有 资 料 储 存 在 开 机 片 中。接 下 来 请 叁 考 [1, Save Current BIOS to File] 之 说 明。

BIOS 升级程序（在需要时）

  1. 从 网 上 下 载 新 版 的 BIOS，并 将 它 存 在 磁 盘 片 中.
  2. 用 上 述 的 磁 盘 片 开 机。
  3. 在 A:\ 的 提 示 符 号 下 执 行 AFLASH.EXE。
  4. 在 MAIN MENU 中 选 择 第 2 项 Update BIOS Main Block From File。接 下 来 请 叁 考 [2. Update BIOS Including Boot Block and ESCD] 之 说 明。
  5. 完 成 更 新 程 序 後，离 开 快 闪 记 忆 体 更 新 公 用 程 式 并 关 掉 电 源。
  6. 重 新 开 机，并 按 ＜DELETE＞ 键 进 入 BIOS 程 式 设 定 画 面。您 必 须 先 选 择 "LOAD SETUP DEFAULTS" 来 启 动 新 的 BIOS，再 依 选 单 调 整 设 定 其 它 项 目。

    警告!     如果在更新BIOS的过程中遇到困难，不要关掉电源或是重新开机，只要再重复更新的程序即可。如果问题仍然存在，将备份在磁片上的原版BIOS重新写回去。如果快闪记忆体更新公用程式不能 成功完整地完成更新的程序，则您的系统可能会无法开机。如果无法开机，请和各地的经销商联系
    。

如何使用快闪记忆体更新公用程式

AFLASH.EXE 是 一 个 快 闪 记 忆 体 更 新 公 用 程 式，它 可 以 用 来 更 新 主 机 板 上 的 BIOS。在 开 机 时，从 萤 幕 左 上 角 所 显 示 的 最 後 四 个 数 字 可 以 知 道 BIOS 目 前 的 版 本，数 字 愈 大 表 示 版 本 愈 新。本 程 式 仅 在 DOS 模 式 下 执 行。

注意! 如果 Flash Memory 是 unknown 表 示 这 个 快 闪 晶 片, 已 经 有 问 题 不 能 被 写 入 升 级，或 是 不 支 持 PnP BIOS, 您 应 该 改 用 flash.exe 公 用 程 式 来 更 新。

更新公用程式主选单

1. Save Current BIOS To File (在电脑能够正常运作时进行)
这 个 选 项 允 许 您 将 目 前 快 闪 记 忆 体 的 内 容 复 制 到 磁 碟片 上。您 可 以 此 将 主 机 板 的 原 始 BIOS 备份，以 便 需 要 时 将 之 重 新 安 装 回 去。但 首 先 您 必 须 具 备 AFLASH.EXE 程式 及 可 当 开 机 磁 碟 的 磁 碟 机.
在 DOS 下利用 [ FORMAT A:/S ] 制 作 一 片 开 机 磁 碟 片, 里 面 不 要 有 AUTOEXEC.BAT 以 及 CONFIG.SYS 两 个 档 案; 之 後, 选 择 选 单 中 的 [1] ＜Enter＞，Save Current BIOS to File 的 画 面 会 出 现. 然 後, 当 询 问 档 案 名 称 的 问 句 出 现 时, 请 输 入 一 个 档 案 名 (譬 如 A:\XXX-XX.XXX ) 称 然 後 按 下＜Enter＞.

2. Update BIOS Including Boot Block and ESCD
这 个 选 项 可 以 更 新 BIOS 的 开 机 磁 区ⅱ从 另 一 个 BIOS 档 案 更 新 ACPI 的 ESCD(Extended System Configuration Data) 叁 数 值。
这 个 BIOS 档案 可 以 是 个 新档，或 是 由 Save Current BIOS to File 所备 份 的 档 案，新 版 BIOS 档 案 下 载 方 法 请 叁 考 下 一 页 说明。欲 更 新 BIOS 档 案，请 在 主 选 单 上 按 下 [2] 然 後 按 下＜Enter＞, 接 下 来 出 现 Update BIOS Including Boot Block and ESCD 的 画 面，键 入 欲 更 新 之 BIOS 档 名 及 路 径 (譬 如 A:\XXX-XX.XXX)，然 後 按 下＜Enter＞.

接下来的画面 请您确认是否 要更新，请按 下 Y 开始更新动作。

更新程式开始 更新 BIOS 资 讯，当程式结 束时，会出现 Flashed Successfully 讯 息。

请依据以下画面指示完 成 BIOS 程式更新。


完全BIOS手册

开始浏览《完全 BIOS 手册》

了解《完全BIOS手册》最新动态

开始浏览《完全BIOS手册》

《完全BIOS手册》由

zyweb_85.jpg (2298 字节) [张 雁 网 站]友情提供。

[张雁网站] http://zyweb.myrice.com Email: netfree@netease.com


left

完全 BIOS 手册

基础篇

什么是 BIOS

BIOS 是什么

BIOS极其功能

什么是POST自检

CMOS与BIOS一样吗

BIOS与CMOS

什么是BIOS 和 COMS

浅谈CMOS

BIOS ID大揭秘

设置篇

什么是BIOS设置

AWARD BIOS设置手册

AMI BIOS设置手册

华碩BIOS设置说明

免跳线主板BIOS设置

升级篇

为什么要升级 BIOS？

升级前还要知道什么

升级BIOS—资源篇

升级BIOS—实战篇

升级BIOS的每一步

升级BIOS完全手册

华硕BIOS升级与管理

LOGO 修改篇

修改能源之星LOGO

更改能源之星的图标

再谈改能源之星图标

修改BIOS显示信息

BIOS文字信息修改

大家谈BIOS LOGO

BIOS LOGO修改F&Q

如何使用CBLOGO

全屏开机画面

修复篇

万一BIOS出了问题

修复被破坏的 BIOS

升级失败的处理

修复BIOS有新法

用插拔法修复BIOS

升级BIOS有惊无险

升级主板 BIOS 小记

如何用好大容量硬盘

new.gif (945 字节) BIOS资源集锦

new.gif (945 字节) 下载《完全BIOS手册》离线浏览压缩包

下载BIOS程序及图片


完全BIOS手册—更改能源之星的图标

更改能源之星的图标

本文摘自 《新潮电子》

    每次我们刚开机时，电脑的右上角上都会浮现出能源之星的画面（如图1），只有少数主板和某些品牌机才会显示自己的品牌标志。我们能不能也像品牌机一样更新自己主板的BIOS，让它一开机就显示我们自己喜爱的标志而不用每天面对那千篇一律的能源之星呢？其实，要想实现上述想法，你只需三件有利工具就可以轻松搞定。这三样工具就是CBROM、BMP2EPA和AWDFLASH。下面我就逐步介绍修改过程。
    1．主修改程序CBROM
    CBROM程序是AWARD公司开发的，可用来显示 BIOS 程序中的内容，并可为BIOS添加新功能，把能源之星的标志换掉只是其中的功能之一。
    在DOS提示符下运行CBROM会调出该程序的使用说明。CBROM并不是直接更改主板的ROM，而是更改BIOS文件。该程序是把我们需要的图标写入BIOS文件，再刷入到主板的ROM芯片中来达到更改目的的。

    2．取得BIOS文件
    要得到主板的BIOS文件，只需在DOS下运行AWARD公司的BIOS刷新工具AWDFLASH即可把BIOS文件存到硬盘备用，比如存为BIOS.BIN。

    3．EPA图标文件
    BIOS中的图标并不是一般的BMP文件，而是136×126×2的单色BMP图片经过BMP2EPA.EXE转换而来的。比如图2的PⅢ标志。
    图2、图3、图4依次是PⅢ的源图，黑白两色图和正在转换为EPA格式的图。
    BMP2EPA P3.BMP P3.EPA (把BMP转换为EPA格式)
    BMP2EPA P3.EPA /L （重新为EPA图标上色）
    有了以上三样东西后，就可以更换BIOS的EPA图标了。
    CBROM.EXE BIOS.BIN /EPA P3.EPA
    上面的命令实质是把P3.EPA图标写入BIOS.BIN的EPA区来实现替换。然后再用AWDFLASH.EXE把修改后的BIOS.BIN写到主板的ROM中，再开机时，你就会看见自己的图标了。（图5是刷入赛扬图标的开机画面,改写BIOS的具体注意事项可参见《新潮电子》1999第四期）。
注:以上三个程序可在《新潮电子》主页(www.newsoft.com.cn)上下载。


完全BIOS手册—再谈更换“能源之星”的图标

再谈更换“能源之星”的图标

本文摘自 《新潮电子》

    本人对超酷的品牌机LOGO画面心仪已久，读完《新潮电子》第五期“更改能源之星的图标”一文后，立马就试。虽然按照步骤指示,本人的技嘉6BXC LOGO还是无法被更新，右上角LOGO图标依然没有改变，或一片空白。万般无奈，只好上网搬救兵。经过众网友兄弟的耐心讲解，终于搞定logo。特撰此文，作为该文的一点补充！
    LOGO画面有两种格式，即EPA格式和BMP格式。
    经过查寻，得知BIOS内藏LOGO图档具有两种格式，一种使用传统的EPA，另一种则直接使用BMP。从下面的CBROM.EXE BIOS.BIN /D指令画面即可了解。
    比如，技嘉6BXC，EPA Pattern的档名为AwardBmp.Bmp，可发现档案大小为5.64K。再深入观察，发现使用BMP图档的BIOS也不在少数，例如升技、大众的板子都是。怎样才能辨别呢？采用BMP图档的主机板BIOS，一开始的开机画面解析度为较高的640×480，若是一般的EPA图档，解析度较低，只有640×350。所以，如果您的BIOS经过侦测属于这种类型，那么直接采用BMP档案即可，使用EPA图档反而会造成更新失败。BMP图档大小一样必须是136×126，16色,可按照原文介绍的方法，将图档写入BIOS档案中，指令完全相同。

实际操作
    直接使用BMP图档确实比较方便，不必再经过EPA程序转换，且不受EPA编辑程序的限制，色彩具有连续性，这是因为EPA编辑转换程序只能针对一个区块进行著色工作，而非每个像素。采用一Intel Pentium III的BMP图档，取136×126大小，并转成16色，存成P3bmp.BMP，大小约8K。转成16色，色彩会有严重的失真，但可利用图型处理软件将图案修饰得更漂亮，或更改底色。将图案写入BIOS档案，接着将更新的BIOS重新写入Flash ROM，Reset开机后便可得到右图的画面，能源之星已被更换成功。另外在网络上查到有的主机板提供的BIOS是把Flash工具与BIOS做成一个exe文件，无法拿到 *.bin档来更改logo。但有一Flash工具Flash Utility V6.6可以帮你把Flash ROM上面的BIOS给“Save” 起来而得到该主板bin档。

超酷玩法---开机LOGO
    除了更改能源之星之外，还有一种超酷玩法。经查证CBROM.EXE另外还有个参数 /logo，同样适用16色BMP档。例如: CBROM.EXEBIOS.BIN/logo p3bmp.bmp，一样地将修改好的BIOS重新写入Flash ROM。开机后，便出现左图的画面，由LOGO图档以95桌面背景并排方式填满。这个LOGO会出现在EPA能源之星画面之前，而原来的能源之星就不出现，但在最下面一行有一段字:Press [TAB] to Show POST screen, [DEL] to enter SETUP。可按 [TAB] 键进入原EPA那一页，或按 [DEL] 进BIOS Setup。此时图档大小应该不限，看你的Flash ROM的大小(1 MB或2 MB)以及剩余空间而定，但仍须为16色，只要写得进去就行了，写不进去，会有回应讯息。总之，写入的LOGO档优先权比EPA档高，不管EPA是否有写入，LOGO档都会先显出。除非按[TAB]键，否则EPA那一页不会显出，两者都是16色BMP档。不过经过试验发现，这项功能似乎只适用于采用BMP图档的BIOS。


完全BIOS手册—如何修改 BIOS 里“能源之星”的 LOGO

如何修改 BIOS 里“能源之星”的 LOGO

本文摘自《电脑报》
原作者及主页为：吴朝相的 EXE 主页

相信大家对电脑开机的时候显示的那个“能源之星”的 LOGO 已经十分熟悉了吧！很早以前就在一报纸上看见过介绍有软件可以更换这个 LOGO 的了，无奈那个时候还没上 INTERNET ，这样“特别”的软件真的还不知道找那里去找才好。

前几天看突然又看见了一些这方面的报道，一口气看了该看的文字、下载了要用的软件后，马上就用我的主板进行测试。谢天谢地，我成功了，下面给大家终结一下我的经验。

先来看看简单的流程： 找来你的 BIOS 文件 -》 用软件把里面的 LOGO 文件换掉 -》 把改好的 BIOS 文件写进 FLASH ROM 里 -》 完成。怎么样，很容易吧！但在实际操作的时候还是有很多问题要注意的。首先当然是要确认你的主板是可以升级 BIOS 的啦，接着就要找来合适你主板使用的 BIOS 文件，如果找不到也没太大关系，因为我们可以自己从FLASH ROM里面 SAVE 出来的，再接着就是要准备好要用到的相关软件了，其中最重要的是这个名为 CBROM 的软件，它是 AWARD 公司的作品，绝对可以放心使用。这个软件除了可以用来换 LOGO 以外，还有很多其它的功能，各位可以慢慢的发掘。还有一个是软件是 BMP2EPA 的软件，它的功能是把我们自己设计好的 BMP 图形文件转换成专用的 EPA LOGO 格式。 当然还不能少的软件就是 BIOS 写入软件 AWDFLASH 了，这个软件相信不用我多介绍了，相信有升级过 BIOS 的朋友都应该知道它了。下面以我换 LOGO 的过程来举个例子：

我用的是技嘉的 TX 主板，BIOS 文件是到该公司的主页下载的最新版本。如果你找不到自己主板的 BIOS 文件，可以用 AWDFLASH 来生成。具体方法是进入 AWDFLASH 后按一下回车，接着按 Y ，输入文件名后生成的那个文件就是你要找的 BIOS 文件了。接着要做的就是用 CBROM 来看看你这个 BIOS 文件里的“能源之星” LOGO 是用什么格式存放的了，一般比较旧的主板都是用 EPA 格式的，新的主板也有直接用 BMP 格式的。我的 BIOS 文件是 WCXBIOS.BIN ,打入 cbrom126 wcxbios.bin /d 后显示如下图:

CBROM V1.26B (C)Award Software 1998 All Rights Reserved.
******** wcxbios.bin BIOS component ********
No. Item-Name Original-Size Compressed-Size Original-File-Name
===============================================================
0. System BIOS 20000h(128.00K) 15179h(84.37K) original.tmp
1. EPA pattern 0093Fh(2.31K) 003F3h(0.99K) wcx.epa
2. XGROUP CODE 01767h(5.85K) 010B2h(4.17K) awardext.rom
3. NCR ROM 04000h(16.00K) 02594h(9.39K) NCR307.16K

Total compress code space = 1A000h(104.00K)
Total compressed code size = 1910Eh(100.26K)
Remain compress code space = 00EF2h(3.74K)

  "EPA pattern"这行很明显的可以看出我的主板使用的是 EPA 格式,而且文件已经被我换成了我自己的 wcx.epa ,因为各主板的差异,这个文件名可能会有不同,但这个是没关系的,知道它是使用 EPA 格式就已经够了.现在我们已经可以开始制作自己的 LOGO 了,用任何图形软件创建一幅 136*126 Pixels 的 2色(1bit) BMP 图形,你大可以在里面写上 PIII 500MHZ 等等你喜欢的字眼,做好保存成一个文件后,就到 BMPTOEPA 这个软件出场了.这个软件有 DOS 和 WINDOWS 两个版本,功能上没太大的区别,随自己喜欢就是了,我的 BMP 文件是 wcx.bmp ,打入: epados wcx.bmp wcx.epa 后,就进入到该软件的界面了,你在这里还可以为你设计的 LOGO 填上颜色,但只能逐个色块的填,修改满意后,存盘退出就可以生成wcx.epa 这个文件了.当然,如果你不想自己设计 LOGO 也可以用一些已经做好的现成 EPA 文件,我把这篇文章里提到的所有软件和几十个 EPA 文件打包成一个文件放到了我的站上,有兴趣想改改看的朋友可以到 http://www.netease.com/~topage 下载,这个压缩包里面就包含了很多很 COOL 的 EPA 文件啦,什么 K6-3 Pentium III 等等 LOGO 都有了.选定 EPA文件后就可以用 CBROM 来把 BIOS 文件里原来那幅 EPA 给换掉了,打入:
cbrom126 wcxbios.bin /epa wcx.epa 后,再用 CBROM 来查看 BIOS 文件信息的时候,你就应该可以发现原来的那个 EPA 文件已经被你换掉了.检查无误后,进入 AWDFLASH ,在输入框里输入你已经修改好的 BIOS 文件的文件名,回车,接着如果你想保存原来的 BIOS 的话就按 Y ,不需要的的话,按 N 跳过,再向上帝祈祷给你不断电的几秒钟后,按下 Y ,几秒后,升级完成,过程和一般升级 BIOS 没什么两样,重新开机,如无以外,恭喜,你终于看到了你改掉后的 COOL LOGO 了!
  如果你在输入:cbrom126 wcxbios.bin /d 后看到的第一条信息里不是 EPA pattern ...而是 bmp .... ,那么换起来就更加简单了,因为这样的话就不需要用 BMPTOEPA 这个软件来转来转去,而且可以用 16 色的 BMP 图形了,其它的命令一样,据我所知,升技和大众的的一些主板就是用 BMP 而不是 EPA 的,大家在改的时候一定要把这个给看清楚哦.用 BMP 的主板 BIOS 还有一种更 COOL 的玩法:用 cbrom126 wcxbios.bin /logo wcx.bmp 这个命令的话,升级 BIOS 重开机后,你会发现屏幕上就整屏都是由 wcx.bmp 平铺出来的图形了,这个时侯显示“能源之星”的那个页面也不会出现了,可见其优先权之高.由此可知,要做出像原装电脑那样的开机画面也不难,只要你的 FLASH ROM 的空间够,再设计一幅全屏的 16 色 BMP 图象用这种方式写进去就可以了!放心,如果图形的尺寸太大,写不进去的话,最多是提示出错,不能写进去而已,没什么大不了的。
最后要注意的是以上一切操作请在纯 DOS 或“Safe Command Prompt Only”环境下进行，如果你没升级 BIOS 的经验，最好还是彻底弄懂才做修改。


完全BIOS手册—升级前我们还应该知道

升级前我们还应该知道

本文摘自《新潮电子》

看过前面的文章，也许有许多朋友已经跃跃欲试想将自己主板上的BIOS升级了（有这种便宜，能不动心吗？）。别心急，我们先来看看升级BIOS的进行过程。首先，你必须知道自己的主板型号；其次，要确认主板上的BIOS的类型和版本；第三，到主板生产商的网页上去下载同自己主板型号和BIOS类型一致的BIOS升级程序；最后，进行BIOS升级操作。在这里，我们先介绍前两个步骤的实现方法。

如何查知电脑的主板类型？
看看包装盒和说明书
    新主板刚买回来时，都是装在包装盒里的，还附有产品介绍和使用说明，这些资料上都明确地标明了主板的生产厂家和产品型号，如华硕（ASUS）P/I-P55T2P4主板在包装盒和使用手册上都有明显标注。

有的主板上有标注
    有的主板上标注有厂商标志和产品型号，如华硕（ASUS）TX97-LE。有的主板将厂商标志标注在CPU的散热片上，而产品型号却标注在主板上的其他位置。

查看开机画面
    如果找不到主板的包装和说明资料，主板上也没有任何标注，你可以在电脑启动进行自检时看到关于主板和BIOS的信息。具体方法是当系统检测内存时按下键盘上的Pause/Break键，这样系统的检测过程就会暂停。通常这时屏幕上的第一行（或前两行）为BIOS的相关信息，如右图所示，Amerian Megatrends，Inc.就是AMIBIOS的出品公司名称；接下来就是主板的型号，如A5169MS 表示是微星（MSI）公司生产的MS-5169型主板，V2.2表示AMIBIOS的当前版本为2.2。

使用测试软件
    有一些测试软件可以测出电脑的各项硬件配置，如主板、CPU、显卡、声卡等，可以用它们来测电脑的主板类型。但是这些测试软件可能无法辨认新近出品的硬件类型，或者会出现错误分类的情况。由于升级BIOS要求十分严格，型号规格必须完全对应，如果弄错了主板类型或者升级程序有问题，后果将非常严重，所以请尽量以前三种方法来确定电脑的主板型号。

确定BIOS的种类和版本

1． BIOS的分类
    目前市面上较流行的主板BIOS主要有 Award BIOS、AMI BIOS、Phoenix BIOS三种类型。
    Award BIOS是由Award Software公司开发的BIOS产品，在目前的主板中使用最为广泛。Award BIOS功能较为齐全，支持许多新硬件，目前市面上多数586主机板和PⅡ主板都采用了这种BIOS。
    AMI BIOS是AMI公司出品的BIOS系统软件，开发于80年代中期，早期的286、386大多采用AMI BIOS，它对各种软、硬件的适应性好，能保证系统性能的稳定，到90年代后，绿色节能电脑开始普及，AMI却没能及时推出新版本来适应市场，使得Award BIOS占领了大半壁江山。
    Phoenix BIOS是Phoenix公司产品，Phoenix意为凤凰或埃及神话中的长生鸟，有完美之物的含义。Phoenix BIOS 多用于高档的586原装品牌机和笔记本电脑上，其画面简洁，便于操作。

2． 主板BIOS版本的确定方法
    要想升级BIOS ，前提是主板上的BIOS必须是Flash BIOS（快闪存储器），普通的BIOS是不能用软件方法升级的。识别其是否是Flash BIOS可查看电脑主板的使用手册（一般586及以上的主板都采用了Flash BIOS），还可根据主板的品牌及型号，到主板生产公司的网页上查看有无该型号主板的BIOS新版本，如有，当然就可判断其为Flash BIOS 。如果是原装机，应到生产整机的厂商主页去查看有无该机型的BIOS升级软件。
    确定了主板BIOS可升级后，还应确定其目前的版本号，具体方法如下：
    重新启动机器，我们可看到如下几种开机画面。如需仔细查看，可在显示这些画面时按下键盘右上角的“Pause”键。

3． BIOS升级的最后确定
    由于各厂家技术的不断发展，对时间稍久一点的机器进行BIOS升级后，机器性能增强的效果最为明显。在知道自己的主板BIOS版本后，建议到生产该主板厂家的主页去看看有无针对该种主板BIOS的新版本，如有，可再看看该版本的BIOS较自己现在的版本增加了些什么功能，对自己的机器有无实用价值。例如：新版本只增加了支持P Ⅲ CPU的功能，而你现在根本就没有这种CPU，这种功能对你就形同虚设，也就没必要进行升级了。如果有修复原BIOS的一些BUG或增加了如CD-ROM启动、解决“2000年问题”、解决主板与某些硬件冲突问题等提高系统性能的BIOS升级版本，就应进行升级工作了！


完全BIOS手册—免跳线主板CPU的BIOS设置

免跳线主板CPU的BIOS设置

本文摘自《电脑报》

很多主板都是采用跳线设置CPU工作状态，其主要缺点是更新设置须打开机箱，操作不便。还有一些主板采用CPU即插即用方式，自动检测CPU的种类、工作电压并设置系统的工作状态，能确保不会出现因设置不正确而使主板和CPU等设备受到损坏，其优点是确定系统工作状态极为方便，缺点是无法更改系统的工作状态，如无法超频使用。
    当前有不少新型主板采用BIOS程序设置CPU工作状态，修改设置非常方便。如升技BH6、微星6119 W（中文BIOS）等主板，只要将CPU插好，打开电源，进入BIOS，就可对设置CPU参数进行设置。
    设置CPU工作状态的内容包括CPU工作电压、CPU外频（系统总线工作频率）和CPU内频（CPU内部时钟频率）设置，CPU内频设置是通过更改倍频完成的（CPU内频= CPU外频×倍频）。下表是PⅡ系列CPU的标称参数。

注：除Kalmath 233－300系列CPU采用0.35(mm) 制造工艺、2.8V核心电压以外，其它均采用0.25(mm) 制造工艺、2.0V核心电压，包括SL2WX系列和Celeron系列。
    下文以升技BH6（440BX，Slot1主板）为例介绍用BIOS设置系统工作状态的方法。
    进入升技BH6主板的Award BIOS后，选取“CPU SOFT MENU II”选项，可以看到以下内容：
    CPU Name Is : Intel Celeron MMX
    CPU Operating Speed : User Define
    － Turbo Frequency : Disable
    － External Clock : 100MHz
    － Multiplier Factor : ×4.5
    － SEL100/66＃ Signal : Low
    － AGPCLK/CPUCLK : 2/3
    － Speed Error Hold : Disable
    － CPU Power Supply : CPU Default
    － Core Voltage : 2.00V
    上述内容是Celeron 300A超频设置为4.5×100=450 MHz时显示的状态。以下分别说明各设置项的内容：
    1）CPU Operating Speed
    CPU的内核工作速度，有User Define、233（66×3.5）、266（66×4）、300（66×4.5）、333（66×5）、350（100×3.5）、400（100×4）等选项。选择User Define(用户定义)选项时，CPU外频和倍频由用户在下述条目3）和4）中自行设置。
    说明1：对不超频的用户来说，这项功能简化了设定过程。
    2：微星6119（W）的BIOS设置中，有CPU Plug & Play选项，即自动检测CPU、设置其工作状态的功能选项。
    2）Turbo Frequency
    CPU外频加速模式选择，有“Disable”和“Enable”选项。选择Enable时,CPU的频率被提升2.5％，实际频率=外频×倍频×（1＋2.5％ ）。此条目仅在External Clock（外频）支持Turbo模式时方出现（目前只对100MHz提供支持）。
    3）External Clock
    CPU外频选择，有66、75、83、100、112、124、133MHz等选项
    4）Multiplier Factor
    CPU倍频选择，有2.0、2.5、3.0、3.5、4.0、4.5、5.0、5.5等选项
    5）SEL100/66＃ Signal
    Signal 100/66信号选择，有“High"（高）和“Low"（低）两个选项。设置为“High"时CPU外频为100MHz，设置为“Low"时为66MHz。
    说明1：PⅡ350和PⅡ400运行在100MHz外频时，倍频分别被锁定于3.5和4.0倍频，只要SEL100/66＃信号被设置为“Low"，就解除了对倍频的锁定。
    2：大多数PⅡCPU被锁定了倍频，包括低倍频。此信号只对1998年9月以前生产的有些PⅡ和极少部分未锁频的赛扬起作用。
    6）AGPCLK/CPUCLK
    AGP时钟选择，默认值为2/3，此时AGP工作频率是CPU外频的2/3，如改设为1/1，则AGP工作频率等于CPU外频。
    说明1：AGP的标准工作频率是66MHz，对外频为66MHz的CPU应设置为1/1，对外频为100MHz的CPU应设置为2/3，此时AGP实际工作频率为100 × 2/3=66MHz。
    2：当系统频率高于66MHz时，设置为1/1会大大增加AGP的性能，但对于大多数2XAGP卡，超频过高会导致不稳定。
    7）Speed Error Hold
    速度错误处理选择，有“Disable"和“Enable"选项。默认 “Disable"，如设置为“Enable"则相当于禁止超频，由系统自动检测CPU，发现设置值与CPU标称值不符时系统拒绝工作。
    说明：如果选择了无法顺利开机的BIOS设定值，关机等待一定时间，系统将使用原始BIOS default值启动。
    8）CPU Power Supply
    CPU电源（压）选择，有“CPU Default”（CPU默认）和“User Define”（用户定义）选项，选择“User Define”选项时，由下一条目9）设置CPU内核电压，略略提高一点对CPU内核电压可提高超频的稳定性，一般加0.1V左右的电压即可。
    9）Core Voltage
    CPU内核电压选择，有1.30V至3.2V间的电压选项，1.30V——2.10V以每档0.05V递增，2.10——3.20V以每档0.10V递增。由于电压过高会对CPU造成伤害，选择项中对调高电压有一定限制。对2.8V 的 Pentium Ⅱ，电压最高可调至3.2V；对2.0V的Pentium Ⅱ，最高只可调至2.3V。
BIOS设置的内容很多，本文仅讨论了与CPU相关的设置。另外，不同主板设置的方法不一，应参考主板说明进行设置。最后要说明的是，即使是免跳线主板，实际上在一些特殊情况下还是需要用跳线设置某些系统状态，有些声称免跳线的主板上还是有极少的跳线用于解决一些特殊问题。


完全BIOS手册—打造自己的品牌机--一起来修改BIOS全屏开机画面

打造自己的品牌机
—— 一起来修改BIOS全屏开机画面

本文作者为 安徽 张雁 　版权为《电脑报》报社所有,不得抄袭或转载。

资源下载[下载OEM LOGO图片及相关程序]

  前几期刊登了数篇关于修改BIOS LOGO的文章后，引起了广泛关注。如果你已领略了修改BIOS LOGO所带来的快感的话，是不是想再试试修改最过瘾、最精彩、最令人兴奋的像品牌机一样的全屏开机画面（下称“OEM LOGO”）？本篇就将详细地介绍修改OEM LOGO的每一步骤及相关知识。好了，还等什么，让我们一起来打造自己的品牌机吧！

你的BIOS支持OEM LOGO吗？

    你的BIOS支持OEM LOGO吗？这个问题也许会让你感到失望，但这是修改OEM LOGO首先应解决的问题。你也许会摇摇头说：“我的主板（或是BIOS）还是X（X<=3）年前的，不可能支持”。 先别肯定，笔者的扳子是华硕TX97LE（BIOS是98年3月17日的），起初也认为不可能支持OEM LOGO，但经过一串冒险的实验后（是拿BIOS做实验呀），证实笔者的BIOS也支持OEM LOGO。而通过下面的实验和分析，你也许也会有新的发现棗原来我的BIOS也支持OEM LOGO 呀。

实验一：

    先用PFLASH（笔者用的是华硕板子自带的）将BIOS数据备份到文件中（例如BIOS.BIN），键入命令：CBROM BIOS.BIN /D（只有1.26以上版本的CBROM才有此功能）,此时显示BIOS文件信息如下：

  No. Item-Name Original-Size Compressed-Size Original-File-Name
    0. System BIOS 20000h(128.00K) 12F16h(75.77K) original.tmp
    1. NCR ROM 08000h(32.00K) 04E33h(19.55K) pci32.rom
    2. EPA pattern 00642h(1.56K) 002A1h(0.66K) awardepa.epa

    Total compress code space = 1B000h(108.00K)
    Total compressed code size = 17FEAh(95.98K)
    Remain compress code space = 03016h(12.02K)

    从第4行可以看到已压缩的EPA格式文件，但却找不到BMP文件的半点踪影。从第5?/FONT>7行可以看出，BIOS文件最大压缩空间（即“Total compress code space”值的大小）为108K，已用95.98K，还剩12.02K。
    如果我们用以前文章中提到的方法分析上面的信息，从BIOS文件中仅剩12.02K剩余压缩空间和找不到BMP文件格式这两点就可以“肯定”地判断笔者的BIOS不支持OEM LOGO。但事实真的如此吗？让我们再来看——

实验二：

    笔者随便做了一张640x480大小16色的BMP文件，上面画了几个字，大小为145K，文件名为GOLDWAVE.BMP。首先“强行”将BMP文件植入BIOS.BIN中，键入命令：CBROM BIOS.BIN /LOGO GOLDWAVE.BMP。让笔者惊喜的是，这一过程顺利地进行了，并没有出现错误信息。接着键入：CBROM BIOS.BIN /D,此时显示BIOS文件信息为：

No. Item-Name Original-Size Compressed-Size Original-File-Name
……
3. LOGO BitMap 2443Ch(145.06K) 009B5h(4.43K) goldwave.bmp
……

    从多出的一行可以看出，植入的BMP文件Original-Size（原始文件大小）为145.06K, Compressed-Size（压缩后文件大小）为4.43K。咦，原来BMP文件是经过CBROM这个程序压缩了的，怪不得小小的BIOS文件能装下145.06K的“庞然大物”。
    向BIOS文件植入图片这一过程已顺利完成，但能否就此说笔者的BIOS完全支持OEM LOGO呢？现在只有通过更新BIOS来证明了。
    笔者用PFLASH小心地将也植入图片的BIOS.BIN烧录到ROM中，怀里紧抱着从朋友那里借来的板子（以防万一），嘴里喊着“阿门”，惴惴地按下了RESET。
    随着一声清脆的喇叭响，屏幕顶端显示出熟悉的PCI显卡检测信息，这时笔者已经感觉到BIOS没有出致命性的问题。随后屏幕一闪，上面显示一堆颜色很乱东西（即后面要说的“花屏”），仔细一看，原来是开始时“随便”画的图片，不过已面目全非了，再随后就是蓝天白云……
    终于松了一口气，实验结果完全可以证明笔者的BIOS支持OEM LOGO。从上面的和后来的若干次实验，可以得出以下结论：

  1. 并不能以原BIOS文件中是否有BMP格式文件来判断BIOS能否支持OEM LOGO（这也许是许多人已犯过的错误）。

  2. 图片是经过压缩后才植入BIOS中的，而不是直接植入的，所以并不能用图片文件的大小来判断其经压缩后在BIOS文件中所占的空间，而是以图片中图形和色彩的多少（这与压缩算法有关）来判断。例如，同为16色640x464大小，文件大小为145K的两张BMP图片，一张上面画了几笔，经压缩后仅0.52K；而另一张用了多种颜色，画了多个图形，经压缩后竟达8K。

  3. 由结论2也可推出：使图片（压缩后的）变小的方法是：原图片尽量使用少的颜色和简单的图形，而不仅仅是改变原图片的像素大小。

  4. 图片不论是大于或小于640x480像素，都将以平铺的形式显示OEM LOGO（与WIN9X桌面背景平铺一样），并且在OEM LOGO底部还有640x16像素用来显示提示信息（即：Press [TAB] to Show POST screen，[DEL] to enter SETUP），而无论图片大小，此信息始终显示，所以创建640x480像素的图片是没有必要的，而640x464像素是最合适的（这样也可以更好地控制满屏显示的效果）。

  5. FLASH ROM（闪存，即存储BIOS的地方）的容量有1M和2M的，而BIOS文件大小一般情况下也有两种，即126K和256K。假设在BIOS支持OEM LOGO的情况下，那么并不是以FLASHROM的容量和BIOS文件大小来判断BIOS是否能装下图片文件（压缩后的），而是以BIOS文件剩余的压缩空间来判断（即“Remain compress code space”值的大小）。例如：图片经压缩后为10K。那么即使你的FLASH ROM容量为2M，BIOS文件最大压缩空间为210K，但BIOS文件中仅剩9K压缩空间，也照样装不下图片；而你的FLASH ROM容量为1M，BIOS文件最大压缩空间仅仅108K，但还剩11K压缩空间，那么照样能装下图片。当然，一般情况下BIOS文件越大，其剩余压缩空间就越大（一般为60?/FONT>120K），而BIOS文件越小，其剩余压缩空间也就越小（一般为3?/FONT>30K）。

  6. 如果修改OEM LOGO后，出现“花屏、变色”而非“黑屏或无任何显示”的现象，那么并不会影响系统安全，也不是你的BIOS不支持OEM LOGO，相反你的BIOS完全支持OEM LOGO。之所以出现“花屏、变色”的情况只是与图片有关（如何修改图片将在后文介绍），而非BIOS是否支持及BIOS空间大小的问题。

  7. 如果在“CBROM xxx.BIN /LOGO xxx.BMP”向BIOS文件植入图片这一过程出错，那么可能的原因有两种：一种是BIOS不支持OEM LOGO （笔者测试了从96到99年的几十种BIOS文件，目前还没发现这样的错误信息），解决方法只能是你就此作罢了；另一种是BIOS文件中的剩余压缩空间小于图片压缩后的大小，解决方法是按结论3中的方法减小图片大小（一般256K的BIOS文件不会出现这种情况）。

  8. 由于修改OEM LOGO只是CBROM这个程序向BIOS文件中加入图片数据及调用它的程序代码，并不会修改BIOS的核心模块（包括BOOT BLOCK），所以结论7中的步骤如果没有出现错误的话，那么即使你的BIOS不支持OEM LOGO，也不会导致BIOS致命性的错误（开机无任何反应）。当然并不排除由于操作失误和其他原因而导致的失败。

    为证实以上几点结论的可重复性，笔者在另一台VX（BIOS是97年4月的）板子上实验通过。由于条件限制，不能在更多的机子上做验证性实验，所以以上的结论可能会在不同的情况下有所偏差，但在大数情况下是适用的（至少是适用于TX及以后的扳子）。
    你的BIOS支持OEM LOGO吗？我想现在你的答案已很清楚了，但答案是什么只能由你自己决定，笔者不会煽动你修改BIOS，毕竟这是计算机操作中最危险的事（就看谁有“运气”亲身体验了），导致的任何损失，笔者也不会负责（谁在扔鸡蛋！）。

  创建LOGO图片

    在本文写之前，一定有不少朋友已尝试了修改OEM LOGO，但也许会发现“花屏”或“变色”（即画的是这种颜色，而显示时却是其他颜色）的现象，使自己精心设计的LOGO面目全非。而许多朋友认为只要用绘图程序的“另存为16色位图”就可以创建LOGO图片了，其实事情并没有想象的那么简单，问题也就出在这LOGO图片上。所以在创建图片之前，先了解一下LOGO图片的文件格式是必要的。
    在20期的《修改BIOS LOGO FAQ》一文中，曾提到这种文件格式是“不知名的二进制格式文件”，之所以这样认为，我想是用了“CBROM XXX.BIN /LOGO EXTRACT”提取BIOS文件中的图片这一功能，但这一功能提取出的图片文件与原来植入BIOS的图片文件完全不同（虽然文件大小相同）。提取出的文件确实是“不知名的二进制格式文件”， 但植入BIOS的图片文件却是标准的16色“索引”位图文件。
    其实位图文件（BITMAP，即BMP文件）从文件格式上分有两类，一类是我们熟悉的“RGB”格式，它是用“R、G、B”红、绿、蓝三种颜色来表示一个点的颜色，例如某一点为蓝色，那么就用代码“00 00 FF”表示这一点的颜色。由于RGB三个量中每个可取256种值（0到FF），所以最多可显示16M（256^3）种颜色。而另一类就是“INDEX”（索引）格式，这种格式的文件首先在文件头（从3CH开始）建立颜色表（可用PHOTOSHOP等程序查看颜色表），然后用颜色表中的颜色代码来表示每一点的颜色。例如颜色表中第15位颜色为蓝色，某一点的颜色也为蓝色，那么就用0F（十六进制）表示这一点的颜色，而不是用RGB格式中的“00 00 FF”来表示。“索引”位图最多只能显示256（2^8）种颜色。
    上面简单地介绍了位图文件的格式，那么“花屏”到底是什么原因呢？原来一般的16色索引位图颜色表中的颜色可以是16M种颜色中的任何16种，而LOGO图片却是标准的16色索引位图文件，它的颜色表中只能是即定的16种颜色，如果颜色表中的颜色不是这16种或超出了这16种，那么就会引起显示时的“花屏”现象。从原因上看，解决的办法就很简单了，即将LOGO图片创建成标准的16色“索引”位图文件（可用“画图”程序的另存为“16色位图”完成）。
    “变色”的原因相对于“花屏”来说就没有那么简单了，由于不知道BIOS是怎样显示LOGO图片的（和一般的程序肯定不一样），所以也就不能从根本上了解原因，但一个有趣的现象是，CBROM的1.03 和1.3版“变色”的结果竟不一样，1.03版的把红色变成浅红，1.3版的却把红色变成灰色（有时变成其他颜色），1.03版的“变色”不是很严重，而1.3版的简直就是张冠李戴地变，效果非常差。由此也可以判断图片是经过CBROM这个程序处理后再压缩进BIOS文件的，而CBROM这个程序也会影响变色。
    上面的分析是不是说不可能避免“变色”呢？其实只要创建图片的过程符合一定的规范，那么基本上可以保证图片不“变色”，下面是笔者在操作中的一点作图经验：

  1. 如果你对PHOTOSHOP（下称“PS”）不是很精通，建议使用WINDOWS自带的画笔程序作图，其因有二：一是用画笔程序的“另存为‘16色位图’”就可以创建符合要求的16色索引位图，而PS要用经过“转换成索引模式”，处理颜色表等多种步骤。二是由于PS功能过强，在RGB模式下它会对图片进行特殊的处理，这样反而使图片容易发生“变色”

  2. 作图时，最好使用黑色为背景色，蓝色为文字及图形色，另外可加一些绿色或白色，而少用些其他颜色。例如图1所示的“金潮电脑”（这牌子听过吗）中除了“潮”字用了绿色外，其他均是蓝色，而这幅图就没有“变色”。

  3. 如果使用画笔，那么只要注意好使用颜色，画好画后再用“另存为‘16色位图’”就可以了。而用PS时要先将“RGB模式”转换为“INDEX模式”（由于这一过程还要载人颜色表，所以最简便的方法是先用画笔程序建立好16色索引位图后，再用PS打开），再进行绘图。因为在“RGB”模式下PS会对图片进行“去锯齿边缘处理”（即用相近的颜色填充边缘），而这样反而容易引起“变色”。

  4. 尽量画直线和矩形之类的规则图形，而少画曲线和圆形之类的，否则最终显示时的“锯齿”现象很严重，影响LOGO图片的整体效果。

  5. 最好使用CBROM的1.03版植入图片，因为即使是变色也不会很严重。

  6. 图片创建的其他注意事项，请参看结论中的第2、3、4条。

    以上经验的成果就是图1所示的“金潮电脑”（谁在流口水），最终显示时没有变色。当然，如果你觉得创建图片太麻烦的话，也可以到我的网站下载已做好的LOGO图片（个个精彩，不会变色，另外还有配套的WIN9X 动画开机LOGO，赶快下载！)

最后的“手术”

    终于到了给BIOS做“手术”的时候了，如果你有修改BIOS的经历，那么现在已很容易了。首先运行AWDFLASH等BIOS更新程序（建议使用主板商所提供的，如ASUS的PFLASH），将BIOS中的数据保存到文件XXX.BIN中（具体操作请参看有关文章，这里不再细说），然后键入CBROM XXX.BIN /LOGO XXX.BMP将做好的LOGO图片植入BIOS文件，最后用AWDFLASH将已植入图片的BIOS文件更新到ROM中。好了，这样就完事了！哦！别急，还有，真诚地向上帝祈祷，开机后看到的是自己精心设计的LOGO，可别是声、光、味效果惧佳的“青烟”效应（你见过吗？很“精彩”的！）。

唠叨完了（我的手快酸死了！），最后还是要罗嗦一句老话：BIOS修改具有一定危险，修改过程中一定要仔细慎重，以免造成损失！本文所提程序、LOGO图片以及更多更详细的资料可到http://zyweb.myrice.com 下载。另外，本文所述不当之处，还请各位多多指正，我的妹儿是netfree@netease.com。

（安徽 张雁）


完全BIOS手册—什么是POST自检

什么是POST自检

本文摘自《电脑报》

接通微机的电源，系统将执行一个自我检查的例行程序。这是BIOS功能的一部分，通常称为POST——上电自检(Power On Self Test)。

完整的POST自检包括对CPU、系统主板、基本的640KB内存、1MB以上的扩展内存、系统ROM BIOS的测试；CMOS中系统配置的校验；初始化视频控制器，测试视频内存、检验视频信号和同步信号，对CRT接口进行测试；对键盘、软驱、硬盘及CD－ROM子系统作检查；对并行口(打印机)和串行口(RS232)进行检查。自检中如发现有错误，将按两种情况处理：对于严重故障(致命性故障)则停机，此时由于各种初始化操作还没完成，不能给出任何提示或信号；对于非严重故障则给出提示或声音报警信号，等待用户处理。

当自检完成后，系统转入BIOS的下一步骤：从A驱、C驱或CD－ROM以及网络服务器上寻找操作系统进行启动，然后将控制权交给操作系统。


BIOS 资源集锦

目录：

  • 全球主要 BIOS 生产公司网站
  • 台湾各大主板厂商及BIOS更新数据相关网址 （GOOD）
  • BIOS相关软件
  • 教授 BIOS 设置 (GOOD!!!)

全球主要 BIOS 生产公司网站

  • Award BIOS 公司 (美国)
  • Award BIOS 公司 (台湾)
  • Award 技术咨询中心 (只限email)
  • AMI BIOS 公司
  • Microid Research
  • Micro Firmware , 开发并发行Phoenix BIOS及升级BIOS数据文件
  • Phoenix BIOS 公司
  • Unicore :提供BIOS升级数据文件 (只限Award BIOS)

台湾各大主板厂商及BIOS更新数据相关网址

  • 华硕ASUS( http://www.asus.com.tw )
     486电脑BIOS升级程序网址（ http://www.asus.com.tw/Products/Bios/bios-486.html ）
    Pentium电脑BIOS升级程序网址（ http://www.asus.com.tw/Products/Bios/bios-p54.html ）
    Pentium pro和PentiumⅡ电脑BIOS升级程序网址（ http://www.asus.com.tw/Products/Bios/bios-p6.html ）

  • 技嘉GIGABYTE（http://www.giga-byte.com ）
     Beta BIOS系列（http://www.giga-byte.com/gigabyte-web/sw_bata.htm）
    AGP BIOS系列（ http://www.giga-byte.com/gigabyte-web/swagp.htm ）
    Intel 440GX 系列（ http://www.giga-byte.com/gigabyte-web/swgx.htm ）
    Intel 440BX 系列（ http://www.giga-byte.com/gigabyte-web/swbx.htm ）
    Intel 440ZX 系列（ http://www.giga-byte.com/gigabyte-web/swzx.htm ）
    Intel 440EX 系列（ http://www.giga-byte.com/gigabyte-web/swex.htm ）
    Intel 440LX 系列（ http://www.giga-byte.com/gigabyte-web/swlx1.htm ）
    Intel 430TX 系列（ http://www.giga-byte.com/gigabyte-web/swtx.htm ）
    VIA 系列（ http://www.giga-byte.com/gigabyte-web/swvia.htm ）
    ALi 系列（ http://www.giga-byte.com/gigabyte-web/swali.htm ）
    SiS 系列（ http://www.giga-byte.com/gigabyte-web/swsis.htm ）
    其他旧型号主板（ http://www.giga-byte.com/gigabyte-web/swother.htm ）

  • 微星MSI（http://www.ecs.com.tw）
     MS-41系列主板（ http://www.msi.com.tw/chinese/bios/486.htm ）
    MS-51系列主板（ http://www.msi.com.tw/chinese/bios/51.htm ）
    MS-61系列主板（ http://www.msi.com.tw/chinese/bios/61.htm ）
  • 升技 [ABIT] (http://www.abit.com.tw/html/cload.htm)
  • 联尚 [AIR] (http://www.airwebs.com/download.html)
  • 浩鑫 [SHUTTLE] ( ftp://ftp.spacewalker.com/bios/)
  • 建基 [AOPEN] (http://w3.aopen.com.tw/tech/biosdrv.htm)
  • 映泰 [BIOSTAR] (http://192.72.144.27/service.htm)
  • 艾崴 [IWILL] (http://www.iwill.com.tw/csupport/index_bios.html)
  • 捷邦 [J-BOND] (http://www.jbond.com/companyf.html)
  • 迈科 [MICRONICS] (http://www.micronics.com/)
  • 梅捷 [SOYO] (http://www.soyo.com.tw/chinese/product/biosup.htm)
  • 丽台 [SUPERMICRO] (http://www.supermicro.com/download/dlframe.htm)
  • 磐英 [EPOX] (http://www.epox.com/support/bios.html)
  • 忆华 [EFA] (http://www.efa.com.tw/elec/efa/c-service.html)
  • 友通 [DFI ] (http://components.dfiweb.com/support/downloads.asp)
  • 精英 [ECS] (http://www.ecs.com.tw/ecs/ecs/spp-m.htm)
  • 大众 [LEO] (http://www.fic.com.tw/techsupport/bios/index.htm)
  • 迈肯 [MYCOMP] (http://www.mycomp-tmc.com/BIOS.htm)
  • 福扬 [FYI] (http://www.fyi.com.tw/download-c.htm)
  • 中凌 [ATREND] (http://www.atrend.com.tw/download/frame-bios.html)
  • 海洋 [OCTEK] (http://www.oceanhk.com/drivers/others/biso)
  • 宏基 [ACER] (http://www.aopenamerica.com/tech/mainbd/default.htm)
  • 联想 [QDI] (http://www.qdigrp.com/driver.htm)
  • 宏鹰 [PCCHIPS] (http://www.pcchips.com.tw/BIOS.html)
  • 捷波 [JETBOARD] (http://www.jetway.com.tw/evisn/jwd/jwd01/index.html)
  • 联讯 [DATAEXPERT] (http://www.dataexpert.com.tw/service/)
  • 皇朝 ( http://megastar.kamtronic.com )
  • 承启( http://www.chintech.com.tw )
  • 钻石( http://www.dfiweb.com )
  • 致福( http://www.gvc.com.tw )
  • 英特尔( http://www.intel.com )
  • 华基( http://www.zida.com )
  • 麒麟( http://www.pcchips.com )

BIOS相关软件

  • AMI Setup Version 2.99: AMI Setup 是一个基于 386/486/Pentium PC的AMI BIOS外部设置工具，它能保存设置到磁盘中并可以恢复，你的配置，并且它允许你设置BIOS中一些难以改变的配置
  • BIOS Password cracks：BIOS密码破解
  • CTBIOS: 这个程序是由 Andreas Stiller编写，他能识别主板的生产厂商等信息
  • TweakBIOS: 允许你改变BIOS中难以设置的选项(支持不同的芯片组)

教授 BIOS 设置 (GOOD)

  • AMI BIOS Survival Guide v3.1
  • Award Documentation and Whitepapers: 提供非常有用的技术信息，并有相关文档和软件下载
  • Instructions on how to change the EPA Logo of your Award BIOS ：教我们怎样把BIOS中的 EPA文档换成自己喜欢的LOGO（并不是《电脑报》上的）
  • Phoenix BIOS error beep codes ：Phoenix BIOS错误信息代码详解
  • ZDNet Links
  • Jan's PC Upgrade problems Page ：教我们怎样处理BIOS升级时出现的问题，比如 IDE硬盘的容量极限等
  • Getting beyond the ATA 8.4 GB limit ：这 IBM的一个网页，教我们怎样处理BIOS不识别8.4G以上硬盘的局限。
  • Installing Win95 with Award BIOS 4.50G
  • What all those numbers in your BIOS id string really mean
  • Matrix Technologies BIOS Web - 著名的硬盘厂商Matrix（迈拓）公司关于BIOS的网站，其中也会教我们怎样处理BIOS不识别8.4G以上硬盘的局限。


right

[张雁网站] 收集整理资料 [轩辕网站] 制作电子书籍

BIOS一向被普通朋友视之为禁地，不敢随便操作，而正是由于这种误区再加上最近的 CIH 病毒带来的恐慌，使得越来越多的用户对 BIOS 产生了一种恐惧的心理，有的甚至到了“闻 BIOS 丧胆”的“境界”。

实际上 BIOS 并没有我们想象中的那么神秘，也不是那么难以驾御，只要我们按规范操作，一切真的就是那么简单。例如最近在《电脑报》上就刊出了不少玩家修改BISO LOGO的经验，通过这些修改，给我们带来的乐趣和方便是显尔易见的。

基础篇

什么是 BIOS

从头看端详，什么是 BIOS，通过简单的介绍，你会有个感性的认识。

BIOS 是什么

一样的题目，但不同的介绍方式，让你了解到的知识也不同。

BIOS极其功能

了解了BIOS是什么之后，就让我们再了解一下它的功能是什么。

什么是POST自检

计算机每天启动时都要干的事情，但你知道它是怎么回事吗？

CMOS与BIOS一样吗？

许多朋友都把CMOS 和 BIOS混淆，他们到底是什么又又什么区别呢？

BIOS与CMOS

但我们知道了上面所的答案——COMS 和 BIOS不一样后，一定想知道它们到底是什么，那好，就看这里。

什么是BIOS 和 COMS

百家争鸣，各有各的看法，且看这里是怎样介绍BIOS和COM的。

浅谈CMOS

在上面我们了解了COMS和BIOS，这了再来“浅谈COMS”，虽说是“浅谈”，但内容可不浅了，什么COMS口令破解，汇编等等，总之让你再一次提高。

BIOS ID大揭秘

怎样识别BIOS呢？这里就将介绍一种用BIOS ID来识别的方法。

BIOS 设置篇

什么是BIOS设置

什么是BIOS设置呢？也许谁都知道，但就是具体说不上来。通过这篇文章，你会对BIOS设置有个初步认识。

AMI BIOS设置手册

由于AMI BIOS在PC机中占有的比率很小，使得很多AMI拥护很难得到他的一些服务。这篇就是为AMI用户准备的。

AWARD BIOS设置手册

和AMI BIOS不同的是AWRAD BIOS市场占有量很大，但即便是这样，许多主板厂商在其说明书上还是没有详细介绍BIOS的设置，这里就是作者通过自己的实际经验，向大家介绍其具体BIOS设置

华碩 BIOS 设置说明

华硕扳子的市场占有率一直很大，这里就是其一般的BIOS设置方法说明。

免跳线主板CPU的BIOS设置

现在的免跳线主板已逐渐流行，和它的功能一样，它的设置也发生很多变化，这里就我们来看一看。

BIOS 设置升级篇

为什么要升级 BIOS 呢？

对呀，我们为什么要好好的就升级BIOS呢？看完后你就知道到底是为什么了。

升级前我们还要知道什么

凡事预则立，不预则费，我们升级也要知道其来龙去脉，这样才能成功修改嘛。

跟我来升级BIOS——资源篇

你也许早就想升级你的BIOS，但苦于找不到升级软件而让希望一次次的破灭。好了，现在“资源篇”就帮你解决这个问题。

跟我来升级BIOS——实战篇

学了上面那么多的东西，这里就要实战了，紧张吗？

升级BIOS的每一步

一步一步地教你，包你立马搞定BIOS

升级主板BIOS完全手册

既然是“完全手册”，那么一定有它独到之处，怎样的特色还要你来看一看。

华硕主板 BIOS 的升级与管理

现在市场上 ASUS 的板子不少，许多用户都用它，而这里是专门针对 ASUS 主板 BIOS 进行升级和管理。

BIOS LOGO 修改篇

如何修改 BIOS 里“能源之星”的 LOGO

BIOS 里的 LOGO 也能修改？看了你就知道了。

更改能源之星的图标

虽然和上文的主题是一样的，但不同的介绍方法，也许让你了解到更多的东西。

再谈更换“能源之星”的图标

是什么主题，这么热闹，一个、两个、再一个……，既然是再谈，那就看会带给我们什么新东西。

如何修改 BIOS 里的显示信息

LOGO 修改了还是不过瘾，那好，就再来修改BIOS中的信息，连存款密码也放进去。

BIOS文字信息全面修改

一篇更厉害的修改BIOS中文字及显示信息的文章，看了一定长进不少。

如何使用CBLOGO

相信大家已知道了CBLOGO，但具体怎么用也许还不太清楚，而这里就向你介绍

大家来谈修改BIOS LOGO

通过修改BIOS LOGO所带来的乐趣和刺激既然这么大，而它又是这样的简单，那我们大家就一起来修改吧，好的东西自然是共同拥有的。

打造自己的品牌机—— 一起来修改BIOS全屏开机画面

你看了题目也许就被镇住了，也许你是那么的向往品牌机，但又不能违背DIY原则，既想品牌机的雍容华贵，又想DIR的自由和价格，这也许本身就是矛盾的。
其实品牌机最大的也最难模仿的特点就是它的开机画面，但现在不同了，通过文章的介绍，你也可以打造自己的品牌机了，让你也过一把瘾，到底怎么做，你看了就知道了。

BIOS LOGO 修改 FAQ

你在修改BIOS时一定遇到一些问题，不要紧，这里就向你解答。

BIOS 修复篇

万一BIOS升级出了问题

是啊，BIOS升级和修改并不是那么危险，但万一出了问题怎么办？这篇文章就将给你答案

修复被破坏的 BIOS

BIOS万一出问题怎么办？当然是按我们伟大的DIR精神自己修复啦，不过你也许没有经验，这里就教你一点，学会了就是你自己的啦。

升级BIOS失败后的处理

天有不侧风云，BIOS升级失败无疑是最倒霉的时，如果你真的碰到了，那么现在了解其对策，到时处理起来已就不怕了。

修复BIOS有新法

不同的环境可能发生不同的事情，同一个问题也可能有不同的解决方法，这里就是一种修复BIOS的新方法，如果你的BIOS真的坏了，它也许对你很有用。

用插拔法修复BIOS

一提起“插拔法”，我想一般的用户都听过，但具体还是没试过，怎样使用、应注意什么问题，有什么技巧等第问题也许我们都不知道，当然那是以前，看了这篇后，你会有个新的认识。

升级BIOS有惊无险

通过作者的一次遭遇，教我们一种BIOS损坏时的处理方法

升级主板 BIOS 小记

这是作者出现问题、分析问题最后解决问题的一种解决事情的好方法，我们在出现问题时不妨已如此这般。

如何用好大容量IDE硬盘

现在有不少朋友的计算机（或BIOS）不能正确地识别IDE接口的大硬盘，给许多用户带来了麻烦。这里就总结了一些方法和经验，相信会对遇到类似问题的朋友有帮助。


什么是BIOS设置

最新AMI BIOS设置手册

本文摘自《电脑报》

BIOS是英文Basic Input/Output System(基本输入/输出系统)的缩写，其程序储存在主板上的 EPROM或Flash ROM 内，作用是测试装在主板上的部件能否正常工作，并提供驱动程序接口，设定系统相关配备的组态。当你的系统配件与原CMOS参数不符合时，或CMOS参数遗失时，或系统不稳定时，就需要进入BIOS设定程序，以重新配置正确的系统组态。
    进入AMI BIOS设定程序
    1.打开系统电源或重新启动系统，显示器屏幕将出现自我测试的信息；
    2. 当屏幕中间出现"Press <Del> to enter setup"提示时，按下<Del>键，就可以进入BIOS设定程序。
    3. 以方向键移动至你要修改的选项，按下<Enter>键即可进入该选项的子画面；
    4. 使用 方向键及〈Enter〉键即可修改所选项目的值，也可用鼠标（包括PS/2鼠标）选择BIOS选项并修改。
    5. 任何时候按下<Esc>键即可回到上一画面；
    6. 在主画面下，按下<Esc>键，选择“Saving Changes And Exit"即可储存你的新设定并重新启动系统。选择“Exit Without Saving"，则会忽略你的改变而跳出设定程序。
    Standard Setup（标准设定）窗口
    Date/Time: 显示当前的日期/时间，可修改。
    Floppy Drive A，B: 设定软盘驱动器类型为None/720K/1.2M/1.44M/2.88M 。
    Pri Master/Slave以及Sec Master/Slave: 此选项可设定:
    HDD Type（硬盘类型）: Auto(自动检测)、SCSI(SCSI HDD)、CD－ROM驱动器、Floptical(LS－120大容量软驱)或是Type 1～47等IDE设备。
    LBA/Large: 硬盘LBA/Large 模式是否打开。目前540M以上的硬盘都要将此选项打开(On)，但在Novell Netware 3.xx或4.xx版等网络操作系统下要视情况将它关掉(Off)。
    Block Mode: 将此选项设为On，有助于硬盘存取速度加快，但有些旧硬盘不支持此模式，必须将此选项设为Off。
    32 Bit Mode: 将此选项设为On，有助于在32位的操作系统（如WIN95/NT）下加快硬盘传输速度，有些旧硬盘不支持此模式，必须将此选项设为Off。
    PIO Mode: 支持PIO Mode0～Mode5(DMA/33)。用BIOS程序自动检查硬盘时，会自动设置硬盘的PIO Mode。
    注意：当你在系统中接上一台IDE设备（如硬盘、光驱等）时，最好进入BIOS，让它自动检测。如果使用的是抽屉式硬盘的话，可将Type设成Auto，或将Primary以及Secondary的Type都改成Auto 即可。所谓Primary指的是第一IDE接口，对应于主板上的IDE0插口，Secondary指的是第二IDE接口，对应于主板上的IDE1插口。每个IDE接口可接Master/Slave（主/从）两台IDE设备。
    Advanced Setup（高级设定）窗口
    1st/2rd/3rd/4th Boot Device: 开机启动设备的顺序，可选择由IDE0～3、SCSI、光驱、软驱、 Floptical (LS－120大容量软驱)或由Network(网络)开机。
    S.M.A.R.T For HardDisk: 开启（Enable）硬盘S.M.A.R.T功能。如果硬盘支持，此功能可提供硬盘自我监控的功能。
    Quick Boot: 开启此功能后，可使开机速度加快。
    Floppy Drive Swap: 若将此功能Enable，可使A驱与B驱互换。
    PS/2 Mouse Support : 是否开启PS/2鼠标口，若设定为Enable，则开机时，将IRQ12保留给PS/2鼠标使用，若设定为Disable，则IRQ12留给系统使用。
    Password Check: 设定何时检查Password(口令)，若设定成Setup时，每次进入BIOS设定时将会要求输入口令，若设定成Always时，进入BIOS或系统开机时，都会要求输入口令，但先决条件是必须先设定口令(Security窗口中的User选项)。
    Primary Display: 设定显示卡的种类。
    Internal Cache: 是否开启CPU内部高速缓存（L1 Cache），应设为Enable。
    External Cache: 是否开启主板上的高速缓存（L2 Cache），应设为Enable。
    System BIOS Cacheable: 是否将系统BIOS程序复制到内存中，以加快BIOS存取速度。
    C000－DC00，16K Shadow: 此8项是将主内存的UpperMemory（上位内存区）开启，将所有插卡上ROM程序映射到内存中，以加快CPU对BIOS的执行效率。Disable:不开启本功能；Enable:开启，且可提供读写区段功能；Cached:开启，但不提供读写功能。
    Chipset Setup（芯片组设定）窗口
    本功能中的选项有助于系统效率的提升，建议使用默认值。若将某些Chipset、DRAM/SDRAM或SRAM部分的Timing值设得过快，可能会导致系统"死机"或运行不稳定，这时可试着将某些选项的速度值设定慢一点。
    USB Function Enabled: 此选项可开启USB接口的功能，如没有USB设备，建议将此选项设为Disable，否则会浪费一个IRQ资源。
    DRAM Write Timing: 设定DRAM的写入时序，建议值如下:
    70ns DRAM: X－3－3－3； 60ns DRAM: X－2－2－2。
    Page Mode DRAM Read Timing: 设定DRAM读取时序，建议值如下 :
    70ns DRAM: X－4－4－4； 60ns DRAM: X－3－3－3。
    RAS Precharge Period: 设定DRAM/EDO RAM的Precharge（预充电）时间，建议设成4T。
    RAS to CAS Delay Time: 设定DRAM中RAS到CAS延迟时间，建议设定成3T。
    EDO DRAM Read Timing: 设定EDO DRAM读取时序，建议值如下:
    70ns DRAM : X－3－3－3； 60ns DRAM : X－2－2－2。
    DRAM Speculative Read: 此选项是设定DRAM推测性的引导读取时序，建议设定成Disable。
    SDRAM CAS Latency: 设定SDRAM的CAS信号延迟时序，建议设定值如下 :
    15ns(66MHz)/12ns(75MHz) SDRAM: 3
    10ns(100MHz) SDRAM: 2。
    SDRAM Timing: 设定SDRAM(同步内存)的时序，建议设定值如下:
    15ns(66MHz)/12ns(75MHz) SDRAM: 3－6－9
    10ns(100MHz) SDRAM: 3－4－7。
    注意：若系统使用SDRAM不稳时，建议将SDRAM速度调慢。
    SDRAM Speculative Read : 此选项是设定SDRAM推测性的引导读取时序，建议设定成Disable。
    Pipe Function: 此选项设定是否开启Pipe Function（管道功能），建议设定成Enable。
    Slow Refresh: 设定DRAM的刷新速率，有15/30/60/120us ，建议设在60us。
    Primary Frame Buffer: 此选项保留，建议设定成Disable。
    VGA Frame Buffer: 设定是否开启VGA帧缓冲，建议设为Enable。
    Passive Release: 设定Passive Release（被动释放）为Enable时，可确保CPU与PCI总线主控芯片（PCI Bus Master）能随时重获对总线的控制权。
    ISA Line Buffer: 是否开启ISA总线的Line Buffer，建议设为Enable。
    Delay Transaction: 设定是否开启芯片组内部的Delay Transaction（延时传送），建议设成 Disable。
    AT Bus Clock: 设定ISA总线时钟，建议设成Auto。
    Power Management Setup（能源管理）窗口
    能源管理功能可使大部份周边设备在闲置时进入省电功能模示，减少耗电量，达到节约能源的目的。电脑在平常操作时，是工作在全速模式状态，而电源管理程序会监视系统的图形、串并口、硬盘的存取、键盘、鼠标及其他设备的工作状态，如果上述设备都处于停顿状态，则系统就会进入省电模式，当有任何监控事件发生，系统即刻回到全速工作模式的状态。省电模式又分为“全速模式(Normal)、打盹模式(Doze)、待命模式(Standby)、沉睡模式(Suspend)"，系统耗电量大小顺序:Normal>Doze>
    Standby > Suspend。
    Power Management/APM: 是否开启APM省电功能。若开启(Enable)，则可设定省电功能。
    Green PC Monitor Power State/Video Power Down Mode/Hard Disk Power Down Mode : 设定显示器、显示卡以及硬盘是否开启省电模式，可设定成Standby、Suspend以及Off(即不进入省电模式)。
    Video Power Down Mode: 设定显示器在省电模式下的状态 :Disable: 不设定 ；Stand By: 待命模式；Suspend: 沉睡模式。
    Hard Disk Power Down Mode: 设定硬盘在省电模式下的状态。（同上）
    Standby Timeout/Suspend Timeout: 本选项可设定系统在闲置几分钟后，依序进入Standby Mode/Suspend Mode等省电模式。
    Display Activity: 当系统进入Standby Mode时，显示器是否进入省电模示，Ingroe:忽略不管；Monitor:开启。
    Monitor Serial Port/Paralell Port/Pri－HDD/Sec－ HDD/VGA /Audio/Floppy: 当系统进入省电模式后，是否监视串并行口、主从硬盘、显示卡、声卡、软驱的动作。Yes:监视，即各设备如有动作，则系统恢复到全速工作模式；No:不监视。
    Power Button Override: 是否开启电源开关功能。
    Power Button Function: 此选项是设定当使用ATX电源时，电源按扭（SUS－SW）的作用。 Soft Off: 按一次就进入Suspend Mode，再按一次就恢复运行。Green: 　　按第一下便是开机，关机时要按住4秒。
    Ring resume From Soft Off:是否开启Modem唤醒功能。
    RTC Alarm Resume From Soft Off: 是否设定BIOS 定时开机功能。
    PCI/PnP Setup窗口
    此选项可设定即插即用(PnP)功能。
    OnBoard USB: 是否开启芯片组中的USB功能。
    Plug and Play Aware OS: 如你的操作系统(OS)具有PnP功能(如 Win95)，此项应选Yes；若不是，则选No。如某些PnP卡无法检测到时，建议设成No。
    PCI Latency Timer: 此选项可设定PCI时钟的延迟时序。
    Offboard PCI IDE Card: 如使用了其它的PCI IDE卡，则此项必须设定，这要视你的PCI IDE卡是插在哪个Slot(1－4)上而定，并设定以下各IDE IRQ 值。Slot5、6以及Hardwared为保留选项。
    Offboard PCI IDE Primary IRQ: 设定PCI IDE卡上IDE 0所要占用的INT＃，一般都是设定成INT＃A。
    Offboard PCI IDE Secondary IRQ: 设定PCI IDE卡上IDE 1所要占用的INT＃，一般都是设定成 INT＃B。
    Assign IRQ to PCI VGA Card: 指定一个IRQ给VGA卡使用，一般不用指定IRQ给VGA卡。
    IRQ 3、4、5、7、9、10、11、12、14、15/DMA Channel 0、1、3、5、6、7:本选项是设定各IRQ/DMA是否让PnP卡自动配置，若设定成PCI/PnP，则BIOS检测到PnP卡时，会挑选你所有设成PCI/PnP状态的其中一个IRQ/DMA来使用；反之，若设成ISA/EISA，则BIOS将不会自动配置。一般设为PCI/PnP。
    Peripheral Setup（外围设备设定）窗口
    Onboard FDC: 是否启用主板上的软驱接口。
    Onboard Serial Port 1: 选择串行口1（COM1）的地址，一般设成Auto。
    Serial Port1 IRQ: 此选项可设定串行口1的IRQ，建议设成4。
    Onboard Serial Port 2: 选择串行口2的地址， 一般设成Auto。
    Serial Port2 Mode : 若设成 Normal，为一般接鼠标、Modem用；如有红外线装置(IrDA)，则建议设成IrDA ASKIR。
    Serial Port2 IRQ: 此选项可设定串行口2的IRQ，建议设成3。
    Onboard Parallel Port: 选择并行口的地址。
    Onboard Parallel Mode: 选择并行口的传输模式(ECP/EPP/Normal)。默认为标准模式(Normal)。
    Parallel Mode IRQ : 设定并行口IRQ，建议设定成7。
    EPP Version: 设定EPP Mode为1.7或1.9 版。
    Onboard IDE : 是否启用主板上的PCI IDE0、IDE1接口。如果采用外接的IDE卡，则此项必须改成Disable，反之则设成Both。此选项若设错，将会导致硬盘、光驱等IDE设备检测不到。
    Security(安全）窗口
    User:允许User(用户)设定密码，输入密码后，必须再输入一次确认。
    Anti－Virus：此选项开启后，可防止病毒入侵硬盘的Boot区以及BIOS。
    Utility (实用)窗口
    Detect IDE：此功能可以自动检测所有接在IDE0及IDE1上的设备，包括硬盘、CD－ROM、LS－120等，且会自动判断其PIO模式，以及LBA/Normal/Large模式，一次即可检测完毕。


完全BIOS手册—浅谈CMOS

浅谈CMOS

本文作者：赵江波

大家都知道，在286以上的计算机中，一般都有一个CMOS RAM电路，它用于关机以后继续存放日期、时间、内存设置、软硬盘类型及其他许多有用的设置信息。CMOS即互补金属氧化物半导体，它的设置、应用和管理是保证系统正常工作的关键，下面就介绍一些有关CMOS的基本概念和应用。

ROM BIOS和CMOS RAM芯片
ROM BIOS是固化在ROM中的BIOS（Basic Input/Output System，简称基本输入/输出系统），他控制着系统全部硬件的运行，又为高层软件提供基层调用，BIOS芯片是插在主板上的一个长方形芯片。其比较著名的生产厂家有：American Megatrends INC.的AMI BIOS和Award Software INC.的AWARD BIOS。存放在ROM BIOS中的内容是不能被用户修改的，它主要用于存放：自诊断测试程序、系统自举装入程序、系统设置程序和主要I/O设备的I/O驱动程序及中断服务程序。自诊断测试程序：它通过读取系统主板上CMOS RAM中的内容来识别系统硬件的配置，并根据这些配置信息对系统中的各个部件进行自检和初始化。在POST（Power―On Self加电自检）过程中，如果CMOS RAM中的设置参数与系统实际配置的硬件不符，就会导致系统不能启动或不能正常工作。系统自举装入程序：该程序在系统自检正确后将操作系统盘的引导记录读入内存，然后由引导程序安装操作系统的核心程序。系统设置程序：在系统引导后，适时用热键（如Del）启动设置程序（SETUP），在这个设置程序中可对软硬件参数进行设置，然后由其存入CMOS RAM中。一般地，当系统第一次加电；系统增加、减少或更换硬件；CMOS RAM因掉电、病毒、放电等原因造成内容丢失；系统因需要而调整某些设置参数等原因时需要运行SETUP程序。常见的SETUP程序有AMI BIOS SETUP、AWARD BIOS SETUP、AMI WINBIOS SETUP、QUADTEL BIOS SETUP等。主要I/O设备的I/O驱动程序及中断服务程序：主要为计算机的低端输入/输出和各种中断提供服务。
CMOS RAM是一种互补金属氧化物半导体随即存储器，它主要具有功耗低（每位约10毫微瓦）、可随机读取或写入数据、断电后用外加电池来保持存储器的内容不丢失、工作速度比动态随机存储器（DRAM）高等特点。ROM BIOS对系统自检初始化后，将系统自检到的配置与CMOS RAM中的参数进行比较，在早期的PC中，用主板上的一组DIP开关（以不同组合来代表系统硬件资源的配置情况）来完成现在的CMOS RAM功能，在286以后则基本全都采用了CMOS RAM来保存系统设置的参数。CMOS RAM一般为64字节或128字节，用可充电的电池或外接电池（286机器用干电池较多，386以上的机器基本上都用充电电池了）对CMOS RAM芯片供电。
CMOS基本应用
CMOS数据的备份：由于CMOS的数据是否正确关系到系统是否能正常启动，所以对CMOS数据进行定期备份是非常重要的。备份的最简单方法是在SETUP程序中，用笔把各个参数记下来或者用屏幕硬拷贝（按Print Screen键）的方法把各个设置界面打印出来。这里介绍一种用程序把数据备份下来的方法（以AMI BIOS为例，这些方法对其他的CMOS也适用；用Turbo C 2.0，下同）：
/*把CMOS中的数据读到A盘的CMOS.DAT文件中*/

#include "stdio.h"

main()

{ char cmos[64];FILE *fp;int i;

for (i=0;i<64;i++)

{ outportb(0x70,i);

cmos[i]=inportb(0x71);

}

fp=fopen("A:\CMOS.DAT","wb");

fwrite(&cmos[0],1,64,fp);

fclose(fp);

}

CMOS数据的恢复：文件CMOS.DAT的内容可以在GEBUG（或PCTOOLS等工具软件）中显示和编辑，也可将其再写回CMOS，这里给出自动写回数据的程序：
/*把A盘CMOS.DAT文件的数据写回CMOS中*/

#include "stdio.h"

main()

{ char cmos[64];FILE *fp;int i;

fp=fopen("A:\CMOS.DAT","rb");

fread(&cmos[0],1,64,fp);

for (i=0;i<64;i++)

{ outportb(0x70,i);

outportb(0x71,cmos[i]);

}

fclose(fp);

}

破译或摧毁CMOS口令：由于各种原因，有时需要破译或者摧毁CMOS的口令，此时可以根据具体情况采取各种不同的方法。如果能启动系统，但由于忘记或不知CMOS口令而无法进入CMOS设置状态，此时可采用程序法来破译CMOS的口令（由于程序较长，这里省略，如那位朋友有兴趣请Mail to：zuiyue@263.net）。用程序摧毁CMOS密码的设置：
/*摧毁CMOS密码*/

#include <dos.h>

void far (*p)()=MK_FP(0xffff,0x0000);

main()

{ int i;

for (i=0x34;i<0x40;i++) outp(0x70,i);

out(0x71,0);

(*p)();

}

用DEBUG向端口发送数据的O命令向端口70h和71h发送一个数据，也可以清除CMOS的设置，具体操作如下：

C:\>DEBUG

―O 70 10

―O 71 01

―Q

另外，也可以把上述操作用DEBUG写成一个程序放在一个文件（如DELCMOS.COM）中，具体操作如下：

C:\>DEBUG

―A 100

XXXX:0100 MOV DX,70

XXXX:0103 MOV AL,10

XXXX:0105 OUT DX,AL

XXXX:0106 MOV DX,71

XXXX:0109 MOV AL,01

XXXX:010B OUT DX,AL

XXXX:010C

―R CX

CX 0000

: 0C

―N DELCMOS.COM

―W

Writing 000C bytes

―Q

以后，只要能用软盘启动系统，运行DELCMOS.COM就能取消CMOS的设置。CMOS放电。如果由于人为原因或由于机器故障使CMOS被破坏，而又不能用软盘启动系统，即系统引导顺序为“C:,A:”，或者Floppy Drive A：设置为Not Installed（或Disabled），系统不认A驱，这是便只有放电一途了。放电的方法有电池短接法、跳线短接法和芯片放电法。电池短接法：如果利用可拆卸电池供电，可以把电池拔下，用一根导线将电池插座两端短路，对电路中的电容放电，使CMOS RAM中的信息被清除；如果电池被焊死在主板上，就必须用电烙铁和吸锡器拔开电池的一个管脚来放电。需说明的是，电池短接法必须在短电的情况下进行，此法对一般用户是不可取的，因为拆卸和焊接电池时可能造成主板的损坏、短路、断路等问题，建议用下面的跳线短接法给CMOS放电。跳线短接法：在电池附近有一个跳线开关，跳线旁边注有RESET CMOS、CLEAN CMOS、CMOS CLOSE或CMOS RAM RESET等字样，跳线开关一般为四脚，有的在1、2两脚上有一个跳接器，此时将其拔下接到2、4脚上即可放电；有的所有脚上都没有跳接器，此时将2脚于充电电容短接即可放电。芯片短接法：开机后运行CMOS的SETUP命令全是由于机内一块芯片的作用，此芯片一般位于主板的左上方，很容易找到。找到后，用一段裸露的铜丝线，在管脚上快速划过，可多划几次，这样CMOS所设置的参数便以丢失，开机后重新设置各参数即可。


完全BIOS手册—大家来谈修改开机LOGO

大家来谈修改开机LOGO

本文摘自《电脑报》

自从本报第15期刊登了《修改开机画面上的LOGO》一文以来，在读者中引起巨大反响，不少读者来信询问CBROM软件在何处可下载，这里为大家提供一个网址： http://topage.126.com 。这是作者的主页，有问题也可直接与他联系。另外，也有不少读者对这个问题提出了自己的看法，下面这两篇就比较有代表性。

修改品牌电脑Logo的经验

    看了《电脑报》1999年第15期上的《修改开机画面上的LOGO》，立刻从作者网站上下载了该套修改软件，并很快在我的磐英P2－112A（EPA格式）上实验通过，但在我1997年购的联想P5I430TX TITANIUM IB＋（LOGO为BMP格式，BIOS版本号1.5，日期98.6.5）上怎么也试不成功，不论我写入什么样式的BMP图案，启动时都不会显示任何标志。
    经过若干次失败后，本想放弃努力，但脑中一闪而过一个念头，最终帮我解决了问题，下面是我的尝试及解决过程：　　1.按原文方法写入TEST.BMP（136×126×16）后重新启动，经检查无作用；
    2.用extract参数将原BIOS中的BMP图像spdesy.bmp存取出来，命令行为：
    CBROM BIOS.BIN /logo extract　，回车后输入BMP文件名spdesy.bmp
    3.在Windows下用画笔、PHOTOSHOP等软件打开spdesy.bmp均失败，但用ACDSEE可以查看该文件确为启动时显示的logo，格式为136×71×256的BMP文件；
    4.用画笔自制格式为136×71×256的LIJIANG.BMP，再次写入BIOS后仍然不能显示！至此好像已是山穷水尽。　　5.根据第3步出现的问题，我猜测可能原BIOS所用BMP文件格式有问题，于是调出Ultraedit，以16进制方式对比查看spdesy.bmp和LIJIANG.BMP，发现spdesy.bmp的头2个字节为20 01，而NORMAL.BMP的头2个字节为42 4D（BM），遂将LIJIANG.BMP的头2个字节改为20 01后存盘退出到DOS；
    6.用CBROM将改过的BMP写入BIN文件，并用QDIFLASH.EXE（QDI主板专用的写入程序）将BIN写入BIOS；
    7.重启动，睁大眼看……哇塞!真是酷毙了，原来QDI真的是以这种方式制作的BIOS LOGO，我可又算是长了番见识。　　至此，修改LOGO的经历算是告一段落，经过这番尝试，我总结了几条经验，供有志于吃螃蟹的同志参考：
    1.改之前要保存原BIOS并看清原LOGO的格式；
    2.对BMP格式，应用extract参数提取原BIOS中的BMP文件，并用看图软件查看它所用的格式，保证自制文件的格式与原文件相同；
    3.如果自制文件无效，可检查原文件格式是否做了手脚
    4.改写BIOS时，如果仅仅变动LOGO部分，在写入过程中发生断电等情况不会使系统不能自举，所以你大可放心尝试。
    最后，祝愿大家都能顺利的“造出”自己的品牌机！

其他修改BIOS LOGO的软件

    在第15期的《电脑报》上看到了一篇关于修改开机LOGO文，我很感兴趣，于是也想换一换自己的电脑上的开机LOGO。但找遍了许多软件下载地，怎么也找不到作者所的CBROM。无奈中，我去到联想QDI的主页上转了转，无意中竟发现了一个更好用的改开机LOGO的小工具：CBLOGO。用它可以很容易的修改电脑的开机LOGO，甚至不借助Flash来将LOGO写进BIOS。
    不过在改变LOGO之前，必须用Flash把BIOS取出来：先重新启动计算机并进入MS－DOS方式，再执行Flash pindy.bin/g，这样你的BIOS里的东西就被复制到pindy.bin这个文件里来了。现在你可以用CBLOGO把文件里的开机LOGO提取出来，存为一张bmp的文件，键入：CBLOGO pindy.bin lws.bmp/g你原来的开机LOGO就被存到lws.bmp里。在这里要看清楚它的文件大小，千万记下来，你自己的LOGO最好别超过它，否则BIOS里放不下就可能会出问题！
    接下来你可以用画笔或PHOTOSHOP等绘图软件来画一张自己的LOGO，最多不超过256色。当然也可以用现成的。画完后用“文件／另存为”把它存为256色的位图文件。再重新启动计算机并进入纯MS－DOS方式，执行：CBLOGO ＊.bmp/g(这里的＊.bmp也就是你所画的LOGO的文件名）就可以。
    现在重新启动计算机，怎么样？自己的LOGO感觉就是不一样吧？不过有一点事先声明：更改BIOS是有一定风险的，如果您因为看了本文而遭受什么损失，本人概不负责。
    附上：
    flash.exe和cblogo.exe的下载地址：
     http://www.qdigrp.com/gb/p－d_util.htm
    我的主页： http://www4.netease.com/～pindy
    我的E－mail: weisong@ynmail.com
(励江　Pindy)


top

bios.jpg (6840 字节)


完全BIOS手册—跟我来升级BIOS——资源篇

跟我来升级BIOS——资源篇

本文摘自 《新潮电子》

知道自己主板的BIOS型号后就可以去找最新的BIOS升级程序了。通常主板生产商都会把与产品对应的BIOS升级程序放在自己的网站上供用户免费下载，没有上网的朋友可以到硬件零售商那儿去要求升级服务。在这里要强调一下，电脑用户最好直接到主板生产商的网站上去下载BIOS的升级程序，而不要通过一些其他软件站点下载，也不要使用盗版光盘里面的升级程序，因为后两者的升级程序可能有错误或者含有病毒。

华硕ASUS(网址： http://www.asus.com.tw )
●486电脑BIOS升级程序网址（ http://www.asus.com.tw/Products/Bios/bios-486.html ）
可下载以下华硕主板的BIOS升级程序：
PVI-486AP4，PVI-486SP3，VL/EISA-486SV1，VL/I-486SV2G/GX4，VL/I-486SV2GO/GOX4，PCI-A486S

● Pentium电脑BIOS升级程序网址（ http://www.asus.com.tw/Products/Bios/bios-p54.html ）
可下载以下华硕主板的BIOS升级程序：
P5A，P5A-B，P5A-VM，TX97，TX97-X，TX97-E，TX97-XE，TX97-N，TXP4，TXP4-X，TX97-LE，TX97-L，P/I-P55T2P4S，P/I-P55T2P4，P/I-XP55T2P4，P/I-P55TVP4，P/I-AP55TV，VX97，P/I-P55SP4V，PCI/E-P54NP4，PCI/I-P54NP4D，PCI/I-P54SP4，P/I-P55SP4，P/I-P55SP3AV，SP98AGP-X，SP97-(V)，SP97-XV， SP98-N， P/I-P54TP4，P/I-P55TP4，P/I-P55TP4N，P/I-P55TP4XE(G)，P/I-AP55T，C-P55T2D

● Pentium pro和PentiumⅡ电脑BIOS升级程序网址（ http://www.asus.com.tw/Products/Bios/bios-p6.html ）
可下载以下华硕主板的BIOS升级程序：
P/I-XP6NP5，P/I-P6NP5，P/I-P6RP4， P/I-P65UP5 + C-P6ND，P/I-P65UP5 + C-PKND，P/I-P65UP8 + C-P6ND，P/I-P65UP8 + C-PKND，KN97-X， KN97， P2E-B， P2L-B， P2L-N， P2L97， P2L97-S， P2L97-DS， P2L97A， P2L-M， P2L-VM， P2E-N， P2E-M， P2E-VM， P2B， P2B-B，P2B-LS，P2B-VM， P2B-F， P2B-DS， P2B-D， P2B-D2，XG-DLS，MEL-M， MEL-C，P2V ，MEB-VM，，MEZ-M，MEZ-VM，P2B-N ，MEL-B

技嘉GIGABYTE（网址： http://www.giga-byte.com ）
●Beta BIOS系列（http://www.giga-byte.com/gigabyte-web/sw_bata.htm）
GA-586AT，GA-586ATE，GA-586ATM，GA-586ATS，GA-586ATV，GA-686DL2 ，GA-686DLX，GA-686EX2 ，GA-686LX，GA-686SLX，GA-6EMM，GA-6LA7 ，GA-6LX7(A)，GA-6VX

●AGP BIOS系列（ http://www.giga-byte.com/gigabyte-web/swagp.htm ）
GA-600 系列，GA-610 系列，GA-630

●Intel 440GX 系列（ http://www.giga-byte.com/gigabyte-web/swgx.htm ）
GA-6GXU，GA-6BXDW

●Intel 440BX 系列（ http://www.giga-byte.com/gigabyte-web/swbx.htm ）
GA-BX2000，GA-686BX，GA-6BA，GA-6BA7，GA-6BX7(A)，GA-6BXA，GA-6BXC，GA-6BXC(Rev 1.9) ，GA-6BXD，GA-6BXDS，GA-6BXDU，GA-6BXE，GA-6BXM，GA-6BXS，GA-6BXU

●Intel 440ZX 系列（ http://www.giga-byte.com/gigabyte-web/swzx.htm ）
GA-6ZM7A，GA-6ZMA，GA-6ZMM，GA-6ZMM7，GA-6ZOZ42

●Intel 440EX 系列（ http://www.giga-byte.com/gigabyte-web/swex.htm ）
GA-6EMAL，GA-6EMM，GA-6EMMP(1X)，GA-6EMMP (J2)，GA-6EX，GA-6EX2，GA-6EM，GA-6EA

●Intel 440LX 系列（ http://www.giga-byte.com/gigabyte-web/swlx1.htm ）
GA-686BLX，GA-686DL2 ，GA-686DLX，GA-686LX，GA-686LX2，GA-686LX3 ，GA-686LX4 ，GA-686SLX，GA-6EA (Rev 3.1)，GA-6LA7，GA-6LM7(A)，GA-6LMM7，GA-6LX7(A)

●Intel 430TX 系列（ http://www.giga-byte.com/gigabyte-web/swtx.htm ）
GA-586ATX，GA-586ATX2，GA-586ATX3，GA-586ATX4，GA-586TX3，GA-586TX2，GA-586TX，GA-586T2

●VIA 系列（ http://www.giga-byte.com/gigabyte-web/swvia.htm ）
GA-6VA，GA-6VM7A，GA-6VMA，GA-6VX，GA-6VXE

●ALi 系列（ http://www.giga-byte.com/gigabyte-web/swali.htm ）
GA-5AX (Ver 4)，GA-5AA，GA-5AMMC，GA-5AX

●SiS 系列（ http://www.giga-byte.com/gigabyte-web/swsis.htm ）
GA-6SX，GA-5SMM，GA-586SG，GA-586SGX，GA-586SGM

●其他旧型号主板（ http://www.giga-byte.com/gigabyte-web/swother.htm ）
使用686 Pentium Ⅱ处理器的主板： GA-686KDX，GA-686KX
使用686 Pentium Pro处理器的主板： GA-686NX，GA-686DX，GA-686FX
使用586 Pentium 处理器的主板：GA-586S4，GA-586S，GA-586MS，GA-586DX，GA-586UX，GA-586HX，GA-586HX2，GA-586VX，GA-586SVX，GA-586ATV，GA-586ATV3，GA-586ATV4，GA-586ATM/P，GA-586ATM，GA-586ATS/P，GA-586ATS，GA-586ATE/P，GA-586ATE，GA-586AVS/P，GA-586AT/P，GA-586AT，GA-586AM，GA-586AP，GA-586AS，GA-586ID，GA-586IP，GA-586IS，GA-586AL，GA-586IM
使用486 处理器的主板：GA-5486AL，GA-486AM，GA-486IM，GA-486VS/VF

微星MSI（网址：http://www.ecs.com.tw）
● MS-41系列主板（ http://www.msi.com.tw/chinese/bios/486.htm ）
可下载以下微星主板的BIOS升级程序：
MS-4144，MS-4145（这两种都是微星的老式主板，支持486处理器）
● MS-51系列主板（ http://www.msi.com.tw/chinese/bios/51.htm ）
可下载以下微星主板的BIOS升级程序：
使用Cyrix（r） GXM芯片的微星主板：MS-5178，MS-5176
支持Pentium（r）处理器和AGP的新微星主板：MS-5184，MS-5182，MS-5172，MS-5169，MS-5168
支持Pentium（r）处理器的新微星主板：MS-5177，MS-5170，MS-5167，MS-5166，MS-5165，MS-5164，MS-5163，MS-5158，MS-5156，MS-5153，MS-5148，MS-5145
支持Pentium（r）处理器的微星主板：MS-5149，MS-5147，MS-5146，MS-5144，MS-5143，MS-5142，MS-5139，MS-5137，MS-5136，MS-5130，MS-5129，MS-5128
支持Pentium（r）处理器的旧微星主板：MS-5124，MS-5123，MS-5122，MS-5120，MS-5119，MS-5118，MS-5117，MS-5116
● MS-61系列主板（ http://www.msi.com.tw/chinese/bios/61.htm ）
可下载以下微星主板的BIOS升级程序：
使用Intel（r）440BX芯片的微星主板：MS-6156，MS-6147，MS-6131，MS-6121，MS-6120，MS-6119，MS-6116
使用Intel（r）440EX/LX芯片的微星主板：MS-6161，MS-6159，MS-6140，MS-6132，MS-6126，MS-6125，MS-6123，MS-6122
使用Intel（r）440LX芯片的微星主板：MS-6118，MS-6117，MS-6114，MS-6113，MS-6112，MS-6111
使用Intel（r）440FX芯片的微星主板：MS-6110，MS-6109，MS-6108
使用Intel（r）440GX芯片的微星主板：MS-6135
使用Intel（r）440ZX芯片的微星主板：MS-6154
支持Pentium（r） Pro处理器的微星主板：MS-6107，MS-6106，MS-6104，MS-6103

上面介绍的三种主板较为常见，所以我们列出了详细的BIOS升级程序列表。其他电脑主板的种类还很多，限于篇幅，在这里就只将其BIOS升级程序所在的网页地址列出，有需要的朋友请对应自己电脑的主板类型进行查找。


完全BIOS手册—跟我来升级BIOS——实战篇

跟我来升级BIOS——实战篇

本文摘自《新潮电子》

新型计算机主板都采用Flash BIOS，使用相应的升级软件就可进行升级，Flash BIOS升级需要两个软件：一个是新版本BIOS的数据文件（需要到Internet网上去下载）；一个是BIOS刻录程序（一般在其主板的配套光盘上可以找到，也可到Internet网上去下载）。

BIOS刻录程序有以下功能：
1． 保存原来的BIOS数据；
2． 更新BIOS数据（将新数据刻进BIOS芯片）；
3． 其它功能
常见的BIOS刻录软件有以下几种：
1． AWDFLASH：Award BIOS专用的BIOS刻录软件；
2． AMIFLASH：AMI BIOS专用的BIOS刻录软件；
3． PFLASH： 华硕主板专用的BIOS刻录软件；
4． PHLASH： Phoenix主板BIOS刻录软件。

Award BIOS升级方法

我们以华硕P2B主板为例，详细介绍其BIOS的升级步骤，也可供其它Award BIOS的主板升级时参考:
一、选取所需的软件：BIOS的刻录程序Pflash.exe，可在主板附带的光盘上找到它（也可以到华硕BIOS下载网址http://www.asus.com.tw/Chinese/Products/BIOS/bios-util.html下载）。同时在http://www.asus.com.tw/Chinese/Products/BIOS/bios-p6.html（BIOS与驱动程序更新档案）可查到P2B主板栏中有如下信息：
P2B
Bx2i1008.zip
P2B BIOS Ver.1008 01/11/1999
新增功能：……

以上内容说明P2B主板的最新BIOS版本是1999年1月11日提供的，版本号为1008，比机器原来的1005版BIOS增加了不少功能并解决了一些造成系统死机的BUG（1008版也包括1006、1007版增加的全部功能），值得升级。点击Bx2i1008.zip即可将其下载回来，再将其解压成为bx2i1008.awd文件（凡下载的数据文件是ZIP文件时，自己均应将其解压缩为AWD文件后备用）。
二、进入Windows的DOS模式，键入Format a:/s ，制作一张系统启动盘（盘上不能有病毒），再将下载解压后的bx2i1008.awd文件和升级程序PFLASH.EXE拷贝到该软盘根目录下。
三、在BIOS设置中，将“BIOS update”选项设定为“Enable”（某些主板应在关机后将主板上“Boot Block Programming”跳线设定在“Enable”位置），将“Virus Warning”（病毒警告）设置为“Disabled”，再以DOS实模式开机，因为BIOS升级必须在DOS实模式下进行，以下三种方法可确定系统是在DOS实模式下进行：
1．用无Config.sys和Autoexec.bat文件系统启动软盘启动电脑；
2．如使用硬盘的MS-DOS 6.X系统开机，当屏幕出现：“Starting MS-DOS......”时，按<F5>键跳过Config.sys及Autoexec.bat的执行；
3．如使用Win95/98开机，当出现Starting Win95/98...... 时，按<F8>键进入启动菜单，选取Safe mode command prompt only选项。
我们推荐使用先前制作的系统启动盘来启动机器。

四、在系统以DOS实模式开机后，将工作目录切换到PFLASH.EXE所在的目录下如A：\>后，键入：PFLASH<Enter>，即可进入BIOS更新程序，显示器上出现如下图画面：

ASUSTek PNP BIOS
FLASH MEMORY WRITER V1.5
Copyright (C) 1995, ASUSTek COMPUTER INC.

Flash Type -- SST 29EE010
Current BIOS Revision: #401A0-1005
Choose one of the following:
1. Save Current BIOS To File
2. Update BIOS Main Block From File
3. Advanced Feature

Enter choice: [3]
Press ESC To Exit

五、为了安全起见，先选择〈1〉“Save Current BIOS To File”将目前系统的BIOS内容备份到软盘上并记住它的文件名（为了方便、易记，文件名应简单为好，如存为AA等），以便在更新BIOS的过程中发生错误时，可以重新写回原来的BIOS数据。

六、 选取〈2〉“Update BIOS Main Block from File”来更新BIOS中的主要区块（如果新版BIOS文件要更改Boot block（开机区块），则会看到下面的提示:
Boot Block of New BIOS is different from old one !!!
Please Use *Advanced Feature* to flash whole bios !!!
表示必须再选取〈3〉“Advanced Features”来更新BIOS，没看到该信息，则直接转下面第八步；

七、再选取 〈3〉“Advanced Features”后会出现下面画面：

Advanced Feature

Flash Type -- SST 29EE010
Current BIOS Revision: #401A0-0105
Choose one of the following:
1. Clear PNP ESCD Parameter Block
2. Update BIOS Including Boot Block and ESCD
Enter choice: [2]
Press ESC To Return to Main Menu

选取〈2〉“Update BIOS Including Boot Block and ESCD”将整个BIOS区域更新。

八、然后按屏幕提示，键入新版的BIOS文件名（此例为bx2i1008.awd），系统开始更新BIOS，你可以看到其数据更新的过程，直到它完成。

九、成功地完成BIOS更新后，按ESC键退出，然后关机取出软盘。重新开机，按DEL键进入BIOS设置，除了设置“HDD、FDD、DATE……”外，还应选取“Load Setup Defaults”来加载系统预设值，至此，便完成了BIOS的升级工作。
特别需要注意的是：在BIOS更新过程中不得切断微机电源，以免造成无法开机，如果更新过程中发生问题，你可立即将先前备份的BIOS文件（如AA）写回即可！

AMI BIOS的升级方法

我们以微星主板MS-5169为例来讲AMI BIOS升级的操作步骤：
1．按前面方法制作一张系统启动盘（c:\>format a:/s）;
2． 进入http://www.msi.com.tw/chinese/bios/bios.htm,首先按主板对应的型号下载新的BIOS文件为a569ms23.exe,它是自解压文件，将其拷贝到前面制作的启动盘上，解压后得到四个文件：
Flash.doc(BIOS升级说明文件，里面有升级操作的方法和详细步骤)
AMIFl634.com（升级BIOS的刻录软件）
A569ms23.rom（2.3版的BIOS数据文件）
69ms23.txt（2.3版BIOS的新增功能说明文件）
3．按Flash.doc文件说明，关机后用软盘启动后，在工作目录a:\>后，键入A:\> AMIFL634 A569MS23<ENTER>，然后按屏幕提示完成操作；
4． 重新开机，进入BIOS设置，选取“Auto Configuration With optimal settings”载入系统优化默认值，即完成了对BIOS的升级工作。在开机画面上我们可以看到有“A569MS VER2. 3 070398”的字符显示，说明主板BIOS确已升级到2. 3版了。
Phoenix BIOS升级方法同AMI BIOS 大致相同，只是刻录软件和BIOS数据文件的名称不同而已。一般来讲，各主板或计算机厂商的网页上都有该公司产品的BIOS升级方法介绍和所需的升级程序下载，大家可在其网页上的“技术支持”或“软件下载”等栏目中找到它。然后就可按其提供的方法进行BIOS升级工作。
BIOS升级后能消除一些原来影响系统性能的BUG，增强系统功能，提高系统运行速度，但要使系统性能得到完全发挥，还得正确设置BIOS中的各项参数。在后面的文章中我们会就BIOS中各项参数的设置及其作用作详细的介绍，读者可参考对应的机型优化BIOS设置，让自己的机器性能得到最佳发挥！


升级BIOS的每一步
本文摘自《电脑爱好者》

第一步　确定您是否需要升级BIOS

我们升级BIOS的首要原因通常是2000年问题。

很多电脑，尤其是1997年以前生产的电脑（主板），硬件方面基本上都存在2000年问题。为了消除此问题，电脑厂商和主板的厂商纷纷推出了其修正版的BIOS。因此，将原来存在2000年问题的BIOS升级为不存在2000问题的版本成了当务之急。 升级BIOS的另一个原因在于硬盘和光驱的升级。早期一点的电脑往往不能支持ULTRA DMA方式的IDE接口。因此，虽然原来的硬盘换成了大容量的支持ULTRA DMA 方式数据传输的硬盘，但主板不支持这种工作方式，这样就不能发挥硬盘的工作速度。这时，您也需要升级BIOS版本。 升级BIOS的再一个原因是为了让主板识别升级以后的CPU，比如IDT C6系列、AMD K6－2系列、CYRIX公司的MⅡ等。很多朋友在升级原来的电脑时，往往只是换一下CPU，遗憾的是，更换CPU后，往往主板识别不出来CPU了。例如，MⅡ/300的CPU，主板报告的却是PR266；K6－2/266的CPU，主板报告的却是K6/266；C6/200的CPU，主板报告的却是486DX。为了解决这些问题，您需要升级BIOS。 以上三个原因是我们遇到的需要升级BIOS的最常见的原因。

一般来讲，如果主板的BIOS有更新的版本，您就需要将BIOS升级。因为更新的BIOS版本，往往意味着BIOS性能的提升和功能的完善。 笔者曾经遇到过一块主板（芯片组采用VXPRO＋，主板的右上角有V5.2A的标记），它在WIN97/98的环境下安装ISA声卡的驱动程序不能成功，而只有在最早版本的WIN95下，才可以安装ISA声卡。后来，我尝试将该主板的BIOS升级，升级以后，不仅在任何版本的WIN95下均可以安装声卡，而且在WIN98下安装声卡也无问题。

第二步 确定主板的BIOS是否可以升级

观察您的主板上的BIOS芯片（一般为一个28针或32针的双列直插式的集成电路，上面有BIOS字样），该芯片大多为AWARD或AMI的产品。揭掉BIOS芯片上面的标签（纸质或者金属标签），观察芯片的外观，如果芯片上面的号码中有28或29的数字，或者是以下号码，那么该BIOS就是可以升级的。 Am29F010、Am28F010、Am28F010A、AT28C010、AT28MC010、AT29C010、AT29LC010、AT29MC010、CAT28F010V5、CAT28F010V5I、CAT28F010、CAT28F010I、28F010、HN58C1000、HN28F101、HN29C010、HN29C010B、HN58C1001、HN58V1001、A28F010、28F001BX－B、28F001BX－T、28F010、M5M28F101FP、M5M28F101P、M5M28F101RV、M5M28F101VP、MX28F1000、MSM28F101、KM29C010、DQ28C010、DYM28C010、DQM28C010A、DQ47F010、DQ48F010、M28F010、M28F1001、28EE011、29EE010、PH29EE010、TMS29F010、TMS28F010、W29EE011、W27F010、X28C010、X28C010I、XM28C010、XM28C010I、29LVxxx 或者直接查看主板说明书，看上面是否有关于主板的BIOS是否可以升级的说明。不过，即使主板说明书上没有有关的说明，也不必灰心，您完全可以亲自动手试一下。因为并不是所有的主板都将此特性写在说明书上的。

第三步　寻找可以擦写BIOS的工具软件

目前市场上的主板的BIOS类型一般为AWARD 和AMI两种，其它还有MR、PHOENIX等几种，对应于这些BIOS类型，分别有相应的BIOS擦写程序（或称擦写器）。 建议大家擦写BIOS时，优先采用各自配套的擦写器。比如您的主板若采用AWARD公司的BIOS芯片，则要采用软件AWDFLASH来擦写；若为AMI公司的BIOS芯片，那么则要采用AMIFLASH来擦写。这两个擦写器可以在下列网页中找到：WWW．PING．BE／BIOS／BIOSUTIL．HTML。 AWARD的擦写器还可以在WWW.AWARD.COM.TW中下载到；MRBIOS的擦写程序可以在FTP．MRBIOS．COM处找到。 许多人声称MRBIOS的擦写器MRFLASH可以用来擦写任意的BIOS，但是椐笔者实验，情况并非如此，很多主板的BIOS，MRFLASH都无能为力。但是，AWDFLASH和AMIFLASH两个擦写器在大多数情况下可以换用，比如尽管您的BIOS是AWARD的，但是您还是可以使用AMIBIOS的擦写器来改写BIOS。值得注意的是，一些著名的主板例如华硕（ASUS）随机会提供一个擦写器程序，要对华硕主板的BIOS进行擦写时，必须使用这个擦写器。还可以到华硕的网站WWW.ASUS.COM.TW下载。

第四步　寻找主板新版本的BIOS文件

一般来讲，每个主板厂商都会定期针对自己原来的产品推出更新的BIOS版本，以解决该主板在实际中遇到的新问题。这些新的BIOS，主板厂商都以文件的形式存放在自己的站点上，以供用户们前来下载。因此，获取主板更新的BIOS版本的最直接途径是到主板生产厂商的因特网站点去下载。 如果不知道厂商的网址，可以借助引擎在网上搜索一下。搜索的内容就是主板的型号（一般在主板上有标记）或者厂商的名称。 如果您手头没有任何有关主板的资料（既不知道主板的厂商，也不知道主板型号，主板上也没有任何其他的足以辨别主板身份的标记），那么也不必沮丧，您还可以通过主板的BIOS号码来找更新版本的BIOS。 所谓BIOS号码是指机器启动、自检到内存时，在屏幕最下方显示的诸如“7／31／95－TRITON－2A59CF54C－00”（对于AWARD BIOS）或者“51－0102－1101－00111111－101094－AMIS123－P”（对于AMI BIOS）之类的信息。该信息内含主板所采用的芯片组、生产厂商、BIOS版本和BIOS的日期等内容。通过该号码可以获得有关该主板的准确信息。 如果BIOS号码是AWARD格式的，那么您可以将BIOS号码的倒数第二个字段记下来（前述中的2A59CF54C），然后到台湾站点WWW.AWARD.COM.TW处,根据此号码寻找一个同样号码的BIOS下载。 如果是AMI公司的,那么您可以根据BIOS号码,到站点WWW．PING．BE中找找看。该网站提供了全世界几乎全部的主板厂家以及几乎全部的主板的列表。在这里不仅可能找到所需要的BIOS信息，而且还可以讨论有关BIOS的话题以获得帮助。自然，也可以将您的不知名的主板描述一番，让大家帮您鉴定。 如果以上办法均不能奏效，那么您还可以试一下下面的办法，找出一个替用的BIOS。方法就是根据您的主板所使用的芯片组类型，板上ISA、PCI插槽的个数，内存槽的种类和个数，是否有AGP插槽，电源插座是AT的还是ATX等特性，来寻找一个具有同样特性的已知型号的主板，用已知型号的主板的BIOS来升级您的未知名称的主板（此方法仅供专业人士使用，风险自负）。

第五步　升级主板BIOS的过程

BIOS的升级，实质是借助BIOS擦写程序，将BIOS芯片中旧版本的内容以更新版本的内容来代替。因此，为了升级您的BIOS，就需要有BIOS擦写程序和新版本的BIOS数据文件。有了两者以后，我们就可以开始了。具体的方法如下： 1首先开机进入BIOS设置画面，在CMOS CHIPSET FEATURE SETUP选项中，将SYSTEM BIOS CACHEABLE和VIDEO BIOS CACHEABLE项禁止掉（否则在某些情况下会造成一些麻烦），然后依次敲ESC键、F10键，保存设置并退出。 2重启机器，使硬盘以DOS方式引导并避免加载任何可能驻留内存的程序（在引导DOS至出现“STARTING MS－DOS”时，按F5键）；若硬盘上安装的是WIN95/98，那么，当硬盘引导至＂STARTING WINDOWS 95/98＂时，同时按下CTRL和F5键，以避免DRVSPACE．BIN程序的加载，从而省出大约108KB的常规内存。 此步也可省略为用一张干净无毒并且带有DOS系统文件、BIOS擦写程序、新版本的BIOS数据文件的软盘启动。 3引导系统成功后，输入下面的命令来进行BIOS升级：

    AWDFLASH　（用于使用AWARD公司的BIOS）
    AMIFLASH　（用于使用AMI公司的BIOS）
    MRFLASH　（用于MR公司的BIOS）

擦写程序运行时，会提醒您输入新版本的BIOS文件名。改写结束后，会提醒您重新启动机器。

注意: AWDFLASH擦写程序运行时会首先提示您输入新的BIOS数据文件的名称，然后提示是否保存旧版本的BIOS，您应该起一个文件名，将旧版本的BIOS文件保存下来，以便将来万一发现升级后的BIOS存在问题，还可以将原来的BIOS版本恢复。接着擦写器将会让您再次确定是否真的要改写BIOS的内容，回答Y后，BIOS的升级正式开始，您将可以看到一条闪亮的小方块不停地延伸长度（该过程中应杜绝机器断电）。最后，改写结束，擦写器程序提示您按F1重新启动机器。
AMIFLASH运行时如果不加参数的话，那么擦写程序并不提示您保存原来的BIOS文件，因此在运行该程序时，最好以这样的命令格式来运行“AMIFLASH /F：OLD.ROM”,以便有机会将原来的BIOS文件用OLD.ROM文件名保存一份。 MRFLASH运行时，会出现一个菜单，您可以非常直观地选择保存当前的BIOS或升级当前的BIOS。
某些主板厂商（如华硕）只允许使用他们自己的BIOS擦写程序来升级主板的BIOS，但过程与前面几种基本一致。 4升级BIOS结束后，如果升级成功，那么重启机器时，将会出现正常的显示。这时，我们需要再次进入BIOS设置画面，在CMOS CHIPSET FEATURE SETUP选项中，将SYSTEM BIOS CACHEABLE和VIDEO BIOS CACHEABLE项设为允许后，依次敲ESC→F10，保存设置并退出。 这样，整个BIOS的升级过程即大功告成。

特别提醒：

新版本的AWARD擦写程序运行时，会检查您指定的新版本的BIOS文件是否与主板一致。如果不匹配，该程序将会给出警告信息：“您想要升级使用的BIOS文件与您的主板不匹配”。不过，如果使用下面的参数，擦写程序将不做一致性的检查：AWDFLASH 2A××××××．BIN／Py 。 升级BIOS时，最好使用在线式的UPS对主机供电，以避免在擦写BIOS的过程中主机掉电。 无论是使用了错误的主板BIOS版本，还是在BIOS擦写过程中主机掉电，您的电脑都将有可能从此不再正常启动。

第六步　万一升级BIOS失败怎么办？

当擦写主板的BIOS不成功时，可以尝试下面的办法来进行挽回。

方法1: 使用BIOS中的自举块

很多基于AWARD BIOS的主板上都有一个自举块（BOOT BLOCK），自举块是主板BIOS的一部分，它在您擦写BIOS时不会被改写。 自举块只支持软驱和ISA协议的显卡，并且可以执行引导软盘上的AUTOEXEC．BAT文件，所以可以利用自举块将一个擦写失败的BIOS芯片恢复。
方法为：将AWARD擦写程序和正确版本的BIOS文件拷贝到可引导的软盘上，并且在AUTOEXEC．BAT文件中加入“AWDFLASH ．BIN（正确版本的BIOS文件）”的语句，然后用此软盘引导机器。

方法2：换一片新的BIOS芯片

与主板生产商联系，看他们是否出售BIOS芯片。一些主板生产厂商免费向其用户提供该芯片。如果他们不出售BIOS芯片，那么请和RCSystems公司联系。只要提供与BIOS对应的．BIN文件，该公司就可以提供您所需要的任何BIOS芯片。该公司的网址为：WWW．RCSYSTEMS．COM。

方法3：热交换

寻找一块与您的主板一样的主板，将该主板上可以正常工作的BIOS芯片拆下来替换到您的主板上。然后通过软盘或硬盘启动到DOS。在主机带电的情况下，将正常工作的BIOS芯片取下，然后将升级失败的BIOS芯片换到主板上。最后，将一个正确的BIOS版本擦写入您的BIOS芯片中，重启机器。 如果找不到一样的主板也无妨碍，您可以寻找一块可以正常工作的主板，启动后，将正常工作的BIOS芯片取下，然后将升级失败的BIOS芯片换到主板；使用一个正确的BIOS版本擦写入您的BIOS芯片中即可。擦写时注意屏蔽掉BIOS版本和主板一致性的检查。 不过，需要注意的是，可能有的主板并不一定支持擦写您的升级失败的BIOS芯片，最常见的原因在于芯片擦写的电压不同和BIOS芯片的种类不同。这时就需要寻找一款和您的BIOS芯片相同的主板了。


完全BIOS手册—

升级主板BIOS完全手册

现如今，电脑的硬件技术一日千里，电脑的升级也就成了发烧友的家常便饭了，甚至有人开玩笑地说“现在的电脑不会用坏，只会被淘汰！”。这种说法虽说有点偏颇，但也确实有一定的道理。不过，话又说回来了，电脑毕竟不像时装，它更注重实用、够用、好用。试想想用一台Ｐ Ⅲ的电脑来进行文字处理，无疑是一种巨大的浪费。所以对于普通的电脑用户来说，一则没有必要，二则没有经济能力来追赶电脑的潮流。但是，笔者在这里想要和大家探讨的不是电脑的升级，而是主板的ＢＩＯＳ 的升级。这种升级可以用极小的代价换取电脑性能的提高，可谓是免费升级。但是，对于新手来说，升级主板ＢＩＯＳ 并不是一件非常容易的事儿，因为它不仅要求使用者具备一定的电脑知识，而且还存在一定的危险性，所以笔者在此详细地介绍一下与升级主板ＢＩＯＳ 有关的各种问题。

一、为什么要升级主板ＢＩＯＳ？
所谓ＢＩＯＳ，即“Ｂａｓｉｃ Ｉｎｐｕｔ／Ｏｕｔｐｕｔ Ｓｙｓｔｅｍ＂（基本输入输出系统）。目前，市面上的５８６档次以上的主板的ＢＩＯＳ 绝大多数采用的是Ｆｌａｓｈ ＥＰＲＯＭ （闪速可擦可编程只读存储器）存储，可直接用软件改写升级，因而给ＢＩＯＳ 的升级带来极大的方便。目前ＢＩＯＳ 的生产厂商主要有Ａｗａｒｄ、ＡＭＩ、Ｐｈｏｅｎｉｘ 和ＭＲ 等。升级主板ＢＩＯＳ 当然不只是为了获得ＢＩＯＳ 版本的提升，更重要的是它可以修正以前版本中的Ｂｕｇ 并对新的硬件设备或技术规范提供支持，总的说来可以归纳为以下三点：
首先，Ｙ２Ｋ 问题：提到电脑，可能许多人首先会想到近来被媒体炒得火热的Ｙ２Ｋ （千年虫）问题。的确，１９９６年以前生产或组装的电脑上的主板基本都存在这一问题。为此，许多电脑或主板的生产商先后推出了各自修正版的ＢＩＯＳ，可以在一定程度上解决Ｙ２Ｋ 问题。
其次，提供对新的硬件或技术规范的支持：如前所述，电脑硬件技术日新月异的发展使得早期生产的主板“见识”太短，不能正确识别新的硬件或技术规范。比如Ｋ６－３、Ｐ Ⅲ等新的ＣＰＵ ，ＤＭＡ３３、ＤＭＭ６６等硬件技术规范。笔者今年１月份组装了的一台电脑，用的是梅捷６ＢＡ＋主板，但是不支持英特尔的Ｐ Ⅲ处理器。于是到梅捷的网站找到了４月份推出的ＢＩＯＳ 并成功地升级，结果发现新的ＢＩＯＳ 不仅可以很好地支持Ｐ Ⅲ，而且支持的倍频也由以前的５．５提升到了８．０。这样一来，我的主板可以支持到１００ＭＨｚ 的ＣＰＵ 了。
最后，修正老版本ＢＩＯＳ 中的一些Ｂｕｇ ：这也是升级ＢＩＯＳ 的一个十分重要的原因，无须多述，仅举个简单的例子说明一下。笔者的梅捷主板在启动时检测ＣＤ－ＲＯＭ 的时间过长，但升级ＢＩＯＳ 后，检测速度有了明显的改观，而且对Ｒｉｖａ １２８的显卡的支持也更好了。
所以，从某种意义上说，升级主板的ＢＩＯＳ 就意味着整机性能的提升和功能的完善。

二、如何判断主板ＢＩＯＳ 可否升级？
升级之前，当然必须明确自己的主板是否支持ＢＩＯＳ 的升级，最好的办法是找到主板的说明书，从中查找相关的说明。不过，并不是所有的主板说明书中都有此方面的介绍，但也不用灰心，可以咨询一下销售商或请懂行的朋友帮帮忙。如果以上方法行不通的话，你就必须亲自动手了，其实也挺简单的。方法是：观察你的主板上的ＢＩＯＳ 芯片，如果它是一个２８针或３２针的双列直插式的集成电路，而且上面印有ＢＩＯＳ 字样的话，该芯片大多为Ａｗａｒｄ 或ＡＭＩ 的产品。然后，揭掉ＢＩＯＳ 芯片上面的纸质或金属标签，仔细观察一下芯片，你会发现上面印有一串号码，如果号码中有２８或２９的数字，那么就可以证明该ＢＩＯＳ 是可以升级的。

三、升级ＢＩＯＳ 需要什么工具？
升级主板ＢＩＯＳ 之前，你必须拥有ＢＩＯＳ 的烧录程序（擦写程序或擦写器）和新版本的ＢＩＯＳ 数据文件。ＢＩＯＳ 的烧录程序其实就是一个可执行文件，不同的ＢＩＯＳ 生产商使用的程序是不同的，最好不要混用。也就是说，Ａｗａｒｄ 芯片最好用它自身的烧录程序，这是最安全、最保险的方法。所以，要升级ＢＩＯＳ 之前，必须明确自己的主板使用的是何种品牌的ＢＩＯＳ 芯片，然后找到相应的烧录程序。目前主板上使用最多的是Ａｗａｒｄ和ＡＭＩ 的芯片，其烧录程序分别为Ａｗｄｆｌａｓｈ 和Ａｍｉ—ｆｌａｓｈ。既然要升级ＢＩＯＳ，你还必须拥有该主板最新的
ＢＩＯＳ 数据文件，一般以ＢＩＮ 为扩展名。需要注意的是，ＢＩＯＳ 文件一定要与主板的型号严格一致，也就是说即使是同一牌号的主板，只要型号不一致，其ＢＩＯＳ 数据也不能通用。比如华硕ＴＸ－９７的ＢＩＯＳ 文件就千万不能用来升级华硕Ｐ２Ｂ的主板ＢＩＯＳ，否则后果是不堪设想的。烧录程序和ＢＩＯＳ 文件可以分别从ＢＩＯＳ 生产商和主板厂商的网站上获得，详细的网址请见附录。对于没有条件上网的朋友，可以向销售商索取，另外许多电脑报刊的配套光盘上也会收录这些文件。也有的主板生产商将二者压缩在同一个文件中，放在网站上供用户下载。

四、升级ＢＩＯＳ 具体该如何操作？
在确定已经具备以上的条件后，你就可以进行ＢＩＳＯ 的升级操作了，具体步骤如下：
１．准备工作：
一般主板上有个Ｆｌａｓｈ ＲＯＭ 的跳线开关，用于设置ＢＩＯＳ 的只读／可读写状态。关机后在主板上找到它并将其设置为可写（Ｅｎａｂｌｅ 或Ｗｒｉｔｅ）。新一点的主板可以在ＣＭＯＳ 中设置，详情请参照主板的使用手册。另外，笔者建议在ＣＭＯＳ 中设置成从Ａ 盘引导。
２．引导计算机进入安全ＤＯＳ 模式：
升级ＢＩＯＳ 绝对不能在Ｗｉｎｄｏｗｓ 下进行，万一遇上设备冲突，主板就可能报废，所以一定要在ＤＯＳ 模式下升级，而且不能加载任何驱动程序。在Ｗｉｎ ９５／９８环境下，在出现Ｓｔａｒｔｉｎｇ Ｗｉｎｄｏｗｓ ９Ｘ……的画面时，同时按下Ｓｈｉｆｔ ＋Ｆ５；ＤＯＳ６．２２环境下，开机后按Ｆ５，跳过Ｃｏｎｆｉｇ ．ｓｙｓ 和Ａｕｔｏｅｘｅｃ ．ｂａｔ 进入ＤＯＳ 提示符。俗话说“百密难免一疏”，所以为防万一，笔者建议最好事先准备一张干净的不包含Ｃｏｎｆｉｇ ．ｓｙｓ 和Ａｕｔｏｅｘｅｃ ．ｂａｔ 两个文件的系统启动盘，并将烧录程序和ＢＩＯＳ 文件拷贝到其中，然后直接从软驱启动系统。
３．开始进行升级ＢＩＯＳ （以Ａｗａｒｄ 的ＢＩＯＳ 为例）：
直接运行Ａｗｄｆｌａｓｈ ．ｅｘｅ ，屏幕显示当前的ＢＩＯＳ 信息，并要求你输入新的ＢＩＯＳ 数据文件的名称，然后提示你是否要保存旧版本的ＢＩＯＳ。建议选择Ｙｅｓ ，将其保存起来，并起一个容易记忆的名字，然后存放在安全的地方。以便将来万一升级失败或发现升级中存在问题时，还可以把原来的ＢＩＯＳ 版本恢复。接着，程序会再询问是否确定要写入新的ＢＩＯＳ，选择Ｙｅｓ。这时，有一个进度框显示升级的进程，一般情况下几秒钟之内即可完成升级操作。最后，根据提示按Ｃｔｒｌ ＋Ａｌｔ ＋Ｄｅｌ ，重新开机。
４．如果系统能正常引导并运行，就表明升级成功了。最后，恢复在第一步中改动过的设置，至此就大功告成了。
特别说明：
＊升级ＢＩＯＳ 一定不能在Ｗｉｎｄｏｗｓ 下操作；
＊写入的ＢＩＯＳ 文件一定要确保正确、完整；
＊ＢＩＯＳ 的升级过程中绝对不能被中断，也不能出现断电，否则会造成升级失败，系统不能引导。所以如有条件最好使用在线式的ＵＰＳ 对主机供电；
＊烧录程序可以带不同的参数来控制升级的过程，详情请参见程序的帮助，并谨慎使用。
＊某些主板厂商，比如大名鼎鼎的华硕，拥有自己的ＢＩＯＳ 烧录程序，所以最好用它升级主板的ＢＩＯＳ，升级过程大同小异。
＊升级ＢＩＯＳ 后，某些安装到硬盘上的软件可能会不能正常运行，如ＵＣＤＯＳ 等。原因是这类软件采用了主板上的ＢＩＯＳ 数据作为加密参数。这时，只要将这些软件重新安装一遍即可。
＊部分主板在升级ＢＩＯＳ 后必须清除ＣＯＭＳ 并重新设置，具体做法可参看主板的用户手册。

五、升级ＢＩＯＳ 失败了怎么办？
在升级ＢＩＯＳ 时，可能会由于写入的ＢＩＯＳ 版本不对、不全或本身存在错误，或者在升级过程中出现断电现象等原因而导致升级失败，你可以用如下方法进行挽救工作。
方法一：用软驱和ＩＳＡ 显卡引导系统：主板厂商提供ＢＩＯＳ 程序让普通用户自行升级，早就料到有升级失败而导致机器瘫痪的意外，所以加入了一个普通用户不可改写的Ｂｏｏｔ Ｂｌｏｃｋ（引导块）程序，用以启动软驱和基本插卡，然后再恢复ＢＩＯＳ。几块钱的花费总比换主板好多了。Ａｗａｒｄ 的ＢＩＯＳ 芯片中的ＢｏｏｔＢｌｏｃｋ 在你烧录ＢＩＯＳ 时不会被改写，所以你仍可以引导系统。不过，自举模块只支持软驱和ＩＳＡ 显卡，所以你必须找一个ＩＳＡ的显卡，二手市场上１０块钱左右就可买到一块，另外还要确保软驱可以正常使用。接下来的工作就是从软驱引导系统，用上述方法将备份的ＢＩＯＳ 数据文件重新写入主板的ＢＩＯＳ 中。如果你在升级过程中没有备份原来的ＢＩＯＳ 文件，可以找一个与你的主板型号完全一致的可以正常使用的主板，读取它的ＢＩＯＳ 文件，然后再执行烧录操作。
方法二：更换一个新的ＢＩＯＳ 芯片：这是最直接的一个方法，但是实施起来有一定的难度，主要原因是，如果你的主板比较老了，其ＢＩＯＳ 芯片便也相应地成了古董，在市场上较难寻觅。当然这也不是绝对的。有些主板厂商向用户提供ＢＩＯＳ 芯片，有的甚至还是免费的，所以最好与销售商或主板厂商联系，看看他们是否有你需要的ＢＩＯＳ 芯片。如果你幸运地得到的话，用它替换旧的芯片即可。
方法三：热拔插法：所谓的“热拔插法”，是指在开机的情况下通过替换ＢＩＯＳ 芯片的方法恢复损坏的ＢＩＯＳ 的操作方法。首先，找一台主板型号与你的完全一致的完好的机器，将它引导至安全的ＤＯＳ 方式下，然后轻轻地拔下好的ＢＩＯＳ 芯片，再将你的ＢＩＯＳ 插到主板上，最后依照上面讲述的步骤将你原来备份好的ＢＩＯＳ 数据文件恢复到ＢＩＯＳ 芯片中。这样，你的ＢＩＯＳ就重获新生了。在这里要提醒大家的是，在热拔插的过程中动作一定要轻，否则如果损坏ＢＩＯＳ 芯片的引脚就很麻烦了。最好的方法是先在关机的情况下将好的ＢＩＯＳ 芯片拔出，然后再插回去，注意不要插得太紧。然后进行上面介绍的热拔插法，以确保安全。如果你找不到一样的主板，可以找一块其它的可以正常工作的主板，用上面的方法重写ＢＩＯＳ，但要屏蔽掉ＢＩＯＳ 版本和主板不一致的检查，方法是带参数执行烧录程序，比如Ａｗａｒｄ 是：ａｗｄｆｌａｓｈ ＊．ｂｉｎ／ｐｙ （＊．ｂｉｎ 是要烧录的ＢＩＯＳ数据文件名）。
方法四：用写入设备重写ＢＩＯＳ：许多大中城市的电脑城中有专门的ＢＩＯＳ 写入设备，请商家为你重写ＢＩＯＳ，也仅仅花费二三十元而已，方便而实惠。上述方法也可用来修复被ＣＩＨ 病毒破坏的主ＢＩＯＳ。

六、笔者忠告
１．由于升级ＢＩＯＳ 存在一定的危险性，所以在升级前一定要做好充分的准备。如果自己做起来把握性不大的话，可以在有经验的电脑高手的指点下操作；
２．如果你的主板一切工作正常而且可以很好地支持你所使用的硬件，你就要慎重地考虑升级的必要性了；
３．升级ＢＩＯＳ 具有一定的风险，任何后果自负。


完全BIOS手册—为什么要升级BIOS呢?

为什么要升级BIOS呢?

本文摘自《新潮电子》

免费获得新功能
    升级BIOS最直接的好处就是不用花钱就能获得许多新功能，比如原来你用的是PⅡ的CPU，升级BIOS后也许就能直接使用PⅢ的CPU，不用换主板了；看着别人能用光驱来启动的计算机，自己的不行，升级BIOS后，成了；另外还能增加PnP即插即用功能、新硬盘的LBA和DMA功能、识别其它新硬件等等，简直就是免费升级电脑！

解决莫名其妙的故障

    另外，升级BIOS还可以解决一些特殊的电脑故障，这些故障往往令电脑高手也觉得莫名其妙。下面我们就介绍两个因微机BIOS版本过旧引起的故障实例，让大家对升级BIOS的必要性有一个初步认识。

故障一:BIOS引起老声卡不能工作
    春节前新攒了一台微机，主板选用磐英P2-112A，操作系统为Windows 98，为了节约Money，使用一块朋友升级换下的ESS1868声卡，可装上后无论怎样调整、更换驱动程序，却始终发不出声音，将其装回朋友的电脑上却工作正常，当时判断可能是该声卡与主板不兼容，只得悻悻作罢。后来我怀着侥幸心理到磐英的主页上去浏览，在 “技术支援/BIOS下载/PⅡ”网页上发现P2-112A主板栏目中有如下字样：
新版本BIOS添加（增强）了以下功能：
01/25/1999
1．升级内存大于512MB的功能；
2．解决了SB-LINK在WINDOWS95/98中读取软盘造成系统死机的问题；
3．BIOS预设“CPU/System warning temp”（系统报警）为60℃；
4．支援Pentium Ⅲ CPU （Katmai）；
5．……

12/03/1998
1．支持HD（硬盘）S. M. A. R. T 功能；
2．修正SB-Link与ESS1868相冲突的问题；
3．……

  哈！看来新版的BIOS不仅解决了ESS1868声卡兼容问题，还给主板新增了不少最新的功能（如支持最新P ⅢCPU、支持新硬盘的S. M. A. R. T 功能），真是太好太及时了！立即下载升级程序，将主板BIOS升级为最新版本，嘿，声卡终于开口了！

故障二:升级BIOS 找回“失去”的Modem
    一台伦飞P97tx笔记本电脑，在最近将原Windows 95升级为Windows 98后，发现其内置Modem不能工作了（已排除病毒原因）。“设备管理”里面没有它，用手动方式添加硬件及驱动程序后，系统却检测报告COM3打开错误，而且Windows 98运行程序的速度也非常慢。用原机附带的恢复光盘将操作系统恢复成Windows 95，速度倒是恢复到同以前一样了，可系统仍找不到Modem。反复折腾了一天也无法解决，打电话到伦飞公司办事处，对方回答“可能是Modem坏了”，可在此以前，它明明工作很正常，Windows 98总不至于像CIH一样能破坏硬件设备吧！无奈，只好到伦飞公司的主页上去看看 “问题解答”栏中有没有这种问题的答案，结果发现该机升级操作系统为Windows 98的注意事项中有“安装Windows 98前，机器的BIOS版本应为1.04”的提示，而我的笔记本电脑的BIOS版本是1.01，难怪运行速度那么慢！不知Modem“意外丢失”与此有无关系？立即按其提供的方法下载升级程序，将该机的BIOS升级为1.04版。 开机，哈！自检时显示的CPU型号变成了Pentium 200 MMX，比以前多了MMX三个字母。哎，怎么有三个串口的IRQ了？记得以前这里只显示两个的？看来COM3能打开了，进入Windows 98后，报告发现新硬件，按要求提供驱动程序……Modem工作正常了！这次升级BIOS 不但找回了升级Windows时意外“丢失”的Modem，还使整机性能大大地提高了一步（大家应记得Inter公司的Pentium与Pentium MMX的性能差别吧！），Windows 98 运行非常顺畅，而且操作中再也没有原来那么多的“非法操作”，系统变得更稳定了，真是“因祸得福！”

解决2000年问题
    2000年的到来对全世界都是一件大事，对电脑更是一个大问题，存在银行里的钱连本金带利息都可能被电脑算错，管理户籍的电脑可能会删掉你的户口……诸如此类的问题不胜枚举。当然，你的电脑不会出这样的大漏子，但是你能保证电脑里的数据不会因为2000年问题而被错误删除吗？或者你电脑里老旧的数据库软件把2000年当成了1900年。不怕一万防备万一，升级BIOS不过是举手之劳，然后你就能放放心心地同全世界人民一起迎接2000年了。
    像这样通过升级BIOS解决特殊故障或使系统性能得到提升的事例不胜枚举，而且BIOS的先进、完善程度也是进行整机性能优化的基础，无论你是电脑发烧友还是初级玩家，像这样既不花钱又能增强机器性能、提高系统稳定性的好事，你应该不会拒绝吧！关键是怎样才能安全、有效地将它升级为最新版本，那好，请你接着往后看。


完全BIOS手册—什 么 是 BIOS

什　么　是　BIOS

本文摘自《电脑报》

计算机用户在使用计算机的过程中，都会接触到BIOS，它在计算机系统中起着非常重要的作用。
BIOS，完整地说应该是ROM－BIOS，是只读存储器基本输入／输出系统的简写，它实际上是被固化到计算机中的一组程序，为计算机提供最低级的、最直接的硬件控制。准确地说，BIOS是硬件与软件程序之间的一个“转换器”或者说是接口(虽然它本身也只是一个程序)，负责解决硬件的即时需求，并按软件对硬件的操作要求具体执行。
  一、BIOS的功能

    从功能上看，BIOS分为三个部分：
    1.自检及初始化程序；
    2.硬件中断处理；
    3.程序服务请求。
    下面我们就逐个介绍一下各部分功能：

    (一)自检及初始化
    这部分负责启动计算机，具体有三个部分，第一个部分是用于计算机刚接通电源时对硬件部分的检测，也叫做加电自检(POST)，功能是检查计算机是否良好，例如内存有无故障等。第二个部分是初始化，包括创建中断向量、设置寄存器、对一些外部设备进行初始化和检测等，其中很重要的一部分是BIOS设置，主要是对硬件设置的一些参数，当计算机启动时会读取这些参数，并和实际硬件设置进行比较，如果不符合，会影响系统的启动。
    最后一个部分是引导程序，功能是引导DOS或其他操作系统。BIOS先从软盘或硬盘的开始扇区读取引导记录，如果没有找到，则会在显示器上显示没有引导设备，如果找到引导记录会把计算机的控制权转给引导记录，由引导记录把操作系统装入计算机，在计算机启动成功后，BIOS的这部分任务就完成了。

    (二)程序服务处理和硬件中断处理
    这两部分是两个独立的内容，但在使用上密切相关。
    程序服务处理程序主要是为应用程序和操作系统服务，这些服务主要与输入输出设备有关，例如读磁盘、文件输出到打印机等。为了完成这些操作，BIOS必须直接与计算机的I／O设备打交道，它通过端口发出命令，向各种外部设备传送数据以及从它们那儿接收数据，使程序能够脱离具体的硬件操作，而硬件中断处理则分别处理PC机硬件的需求，因此这两部分分别为软件和硬件服务，组合到一起，使计算机系统正常运行。

    BIOS的服务功能是通过调用中断服务程序来实现的，这些服务分为很多组，每组有一个专门的中断。例如视频服务，中断号为10H；屏幕打印，中断号为05H；磁盘及串行口服务，中断14H等。每一组又根据具体功能细分为不同的服务号。应用程序需要使用哪些外设、进行什么操作只需要在程序中用相应的指令说明即可，无需直接控制。

二、BIOS的种类

    由于BIOS直接和系统硬件资源打交道，因此总是针对某一类型的硬件系统，而各种硬件系统又各有不同，所以存在各种不同种类的BIOS，随着硬件技术的发展，同一种BIOS也先后出现了不同的版本，新版本的BIOS比起老版本来说，功能更强。
    目前市场上主要的BIOS有AMI BIOS和Award BIOS。

    1.AMI BIOS
    AMI BIOS是AMI公司出品的BIOS系统软件，最早开发于80年代中期，为多数的286和386计算机系统所采用，因对各种软、硬件的适应性好、硬件工作可靠、系统性能较佳、操作直观方便的优点受到用户的欢迎。
    90年代，AMI又不断推出新版本的BIOS以适应技术的发展，但在绿色节能型系统开始普及时，AMI似乎显得有些滞后，Award BIOS的市场占有率借此机会大大提高，在这一时期，AMI研制并推出了具有窗口化功能的WIN BIOS，这种BIOS设置程序使用非常方便，而且主窗口的各种标记也比较直观，例如，一只小兔子表示优化的默认设置，而一只小乌龟则表示保守的设置，一个骷髅用来表示反病毒方面的设置，画笔和调色板则表示色彩的设置。
    AMI WinBIOS已经有多个版本，目前用得较多的有奔腾机主板的Win BIOS，具有即插即用、绿色节能、PCI总线管理等功能。

    2.Award BIOS
    Award BIOS是Award Software公司开发的BIOS产品，目前十分流行，许多586主板机都采用Award BIOS，功能比较齐全，对各种操作系统提供良好的支持。Award BIOS也有许多版本，现在用得最多的是4.X版。


完全BIOS手册—ＢＩＯＳ 是什么

ＢＩＯＳ　是什么

本文摘自《新潮电子》

BIOS的主要作用有三点

1.自检及初始化：开机后BIOS最先被启动，然后它会对电脑的硬件设备进行完全彻底的检验和测试。如果发现问题，分两种情况处理：严重故障停机，不给出任何提示或信号；非严重故障则给出屏幕提示或声音报警信号，等待用户处理。如果未发现问题，则将硬件设置为备用状态，然后启动操作系统，把对电脑的控制权交给用户。

2.程序服务：BIOS直接与计算机的I/O（Input/Output，即输入/输出）设备打交道，通过特定的数据端口发出命令，传送或接收各种外部设备的数据，实现软件程序对硬件的直接操作。

3.设定中断：开机时，BIOS会告诉CPU各硬件设备的中断号，当用户发出使用某个设备的指令后，CPU就根据中断号使用相应的硬件完成工作，再根据中断号跳回原来的工作。

BIOS对整机性能的影响

从上面的描述可以看出：BIOS可以算是计算机启动和操作的基石，一块主板或者说一台计算机性能优越与否，从很大程度上取决于板上的BIOS管理功能是否先进。大家在使用Windows 95/98中常会碰到很多奇怪的问题，诸如安装一半死机或使用中经常死机；Windows 95/98只能工作在安全模式；声卡解压卡显示卡发生冲突；CD-ROM挂不上；不能正常运行一些在DOS、Windows 3.x下运行得很好的程序等等。事实上这些问题在很大程度上与BIOS设置密切相关。换句话说，你的BIOS根本无法识别某些新硬件或对现行操作系统的支持不够完善。在这种情况下，就只有重新设置BIOS或者对BIOS进行升级才能解决问题。另外，如果你想提高启动速度，也需要对BIOS进行一些调整才能达到目的，比如调整硬件启动顺序、减少启动时的检测项目等等。

BIOS和CMOS相同吗？

BIOS是一组设置硬件的电脑程序，保存在主板上的一块ROM芯片中。而CMOS通常读作C-mo-se（中文发音“瑟模室”），是电脑主板上的一块可读写的RAM芯片，用来保存当前系统的硬件配置情况和用户对某些参数的设定。CMOS芯片由主板上的充电电池供电，即使系统断电，参数也不会丢失。CMOS芯片只有保存数据的功能，而对CMOS中各项参数的修改要通过BIOS的设定程序来实现。

关于CMOS放电

    常常听到计算机高手或者非高手说“口令忘啦？给CMOS放电吧。”，这到底是什么意思呢？
    如果你在计算机中设置了进入口令，而你又碰巧忘记了这个口令，你将无法进入计算机。不过还好，口令是存储在CMOS中的，而CMOS必须有电才能保持其中的数据。所以，我们可以通过对CMOS 的放电操作使计算机“放弃”对口令的要求。具体操作如下：
    打开机箱，找到主板上的电池，将其与主板的连接断开（就是取下电池喽），此时CMOS将因断电而失去内部储存的一切信息。再将电池接通，合上机箱开机，由于CMOS已是一片空白，它将不再要求你输入密码，此时进入BIOS设置程序，选择主菜单中的“LOAD BIOS DEFAULT”（装入BIOS缺省值）或“LOAD SETUP DEFAULT”（装入设置程序缺省值）即可，前者以最安全的方式启动计算机，后者能使你的计算机发挥出较高的性能。